PluXml.org

Blog ou CMS à l'Xml

Vous n'êtes pas identifié(e).

#1 09/04/2010 14:47:47

Frédéric
Membre
Inscription : 03/06/2009
Messages : 2 533

[RESOLU] Bogue html_entity_decode dans les commentaires

Bonjour,

En voulant insérer les "quotes" comme celles ci: “ ”
ou encore comme cela:

“ mon mot ”

J'obtiens ce message d'erreur:

Warning: cannot yet handle MBCS in html_entity_decode()! in /mnt/149/sdb/1/8/fred/core/lib/class.plx.utils.php  on line 410

Soit cette ligne:

return html_entity_decode($str,ENT_QUOTES,PLX_CHARSET);

Dans l'affichage des derniers commentaire niveau thème mais c'est ok dans la prévisualisation dans l'admin même une fois posté.

J'imagine que cela viens du charset mais pourquoi est il bon dans l'admin.

Voilà pour info wink

Dernière modification par Fred (09/04/2010 14:50:17)

Hors ligne

#2 09/04/2010 15:04:59

Stéphane
Responsable du projet
Lieu : pas loin de Metz
Inscription : 07/08/2007
Messages : 6 203
Site Web

Re : [RESOLU] Bogue html_entity_decode dans les commentaires


Mes articles et tutoriels pour PluXml
Pluxopolis mon site sur PluXml, mais pas seulement...
Twitter: @pluxopolis

Hors ligne

#3 09/04/2010 15:13:20

Frédéric
Membre
Inscription : 03/06/2009
Messages : 2 533

Re : [RESOLU] Bogue html_entity_decode dans les commentaires

Ho merci, je pensé pas que ce la provenais de php5.

Résolus donc ..

Hors ligne

Pied de page des forums

A propos Nous soutenir Contact Twitter Google+
Copyright © 2006-2017 PluXml.org, tous droits réservés