PluXml.org

Blog ou CMS à l'Xml

Vous n'êtes pas identifié(e).

#1 28/03/2017 13:49:00

Yanux
Membre
Lieu : Vannes
Inscription : 28/03/2017
Messages : 4

[Résolu]Erreur 500 après installation

Bonjour,
Je cherche à installer PluXml sur un serveur  VM ubuntu-server 16.04.1.

J'installe un serveur LAMP (méta-paquets lamp-server^) + quelques appoints (GD,...)
Je récupère le zip, je l'extrait dans /var/www/html (la racine du site).
J'arrive sur la page d'installation (URL : localhost:3180/PluXml/install.php), je remplis et je clique sur installer.

Il me redirige vers l'URL localhost:3180/PluXml/
Via le débogueur de firefox, je vois 2 requete réseaux :
Une 302 (redirection) vers index.php
Une 500

Et la, je bloque sad
Je sais pas trop ou chercher, merci d'avance pour votre aide smile

Yanux

Dernière modification par Yanux (28/03/2017 16:43:39)

Hors ligne

#2 28/03/2017 14:17:04

bazooka07
Membre
Lieu : Quelque part en Rhône-Alpes
Inscription : 06/02/2014
Messages : 765
Site Web

Re : [Résolu]Erreur 500 après installation

Dans un terminal en ligne de commande, il faut regarder la fin du fichier de logs de ton serveur HTTP  avec cette commande :

[== Indéfini ==]
tail -n 20 -f /var/log/apache2/error.log

PluXml a besoin de certaines librairies PHP pour fonctionner, en particulier pour XML. Peutx-tu afficher une page PHPINFO. Sinon crée à la racine de ton serveur une page phpinfo.php avec ce code  l'intérieur :

[== PHP ==]
<?php
phpinfo();
?>

et ouvre la avec ton navigateur

Hors ligne

#3 28/03/2017 14:32:21

Yanux
Membre
Lieu : Vannes
Inscription : 28/03/2017
Messages : 4

Re : [Résolu]Erreur 500 après installation

retour de la première commande :

blog@blog:~$ tail -n 20 -f /var/log/apache2/error.log
[Tue Mar 28 12:40:26.863756 2017] [mpm_prefork:notice] [pid 14920] AH00169: caught SIGTERM, shutting down
[Tue Mar 28 12:40:27.949714 2017] [mpm_prefork:notice] [pid 15676] AH00163: Apache/2.4.18 (Ubuntu) configured -- resuming normal operations
[Tue Mar 28 12:40:27.949781 2017] [core:notice] [pid 15676] AH00094: Command line: '/usr/sbin/apache2'
[Tue Mar 28 12:40:56.187765 2017] [:error] [pid 15680] [client 10.0.2.2:56144] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/PluXml/core/lib/class.plx.motor.php:338\nStack trace:\n#0 /var/www/html/PluXml/core/lib/class.plx.motor.php(69): plxMotor->getConfiguration('./data/configur...')\n#1 /var/www/html/PluXml/core/lib/class.plx.motor.php(53): plxMotor->__construct('./data/configur...')\n#2 /var/www/html/PluXml/index.php(30): plxMotor::getInstance()\n#3 {main}\n  thrown in /var/www/html/PluXml/core/lib/class.plx.motor.php on line 338, referer: http://localhost:3180/PluXml/install.php
[Tue Mar 28 12:41:03.448987 2017] [:error] [pid 15681] [client 10.0.2.2:56154] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/PluXml/core/lib/class.plx.motor.php:338\nStack trace:\n#0 /var/www/html/PluXml/core/lib/class.plx.motor.php(69): plxMotor->getConfiguration('./data/configur...')\n#1 /var/www/html/PluXml/core/lib/class.plx.motor.php(53): plxMotor->__construct('./data/configur...')\n#2 /var/www/html/PluXml/index.php(30): plxMotor::getInstance()\n#3 {main}\n  thrown in /var/www/html/PluXml/core/lib/class.plx.motor.php on line 338
[Tue Mar 28 12:41:08.275311 2017] [:error] [pid 15682] [client 10.0.2.2:56160] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/PluXml/core/lib/class.plx.motor.php:338\nStack trace:\n#0 /var/www/html/PluXml/core/lib/class.plx.motor.php(69): plxMotor->getConfiguration('./data/configur...')\n#1 /var/www/html/PluXml/core/lib/class.plx.motor.php(53): plxMotor->__construct('./data/configur...')\n#2 /var/www/html/PluXml/index.php(30): plxMotor::getInstance()\n#3 {main}\n  thrown in /var/www/html/PluXml/core/lib/class.plx.motor.php on line 338
[Tue Mar 28 12:41:18.124149 2017] [:error] [pid 15683] [client 10.0.2.2:56164] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/PluXml/core/lib/class.plx.motor.php:338\nStack trace:\n#0 /var/www/html/PluXml/core/lib/class.plx.motor.php(69): plxMotor->getConfiguration('./data/configur...')\n#1 /var/www/html/PluXml/core/lib/class.plx.motor.php(53): plxMotor->__construct('./data/configur...')\n#2 /var/www/html/PluXml/index.php(30): plxMotor::getInstance()\n#3 {main}\n  thrown in /var/www/html/PluXml/core/lib/class.plx.motor.php on line 338
[Tue Mar 28 12:41:18.779572 2017] [:error] [pid 15686] [client 10.0.2.2:56168] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/PluXml/core/lib/class.plx.motor.php:338\nStack trace:\n#0 /var/www/html/PluXml/core/lib/class.plx.motor.php(69): plxMotor->getConfiguration('./data/configur...')\n#1 /var/www/html/PluXml/core/lib/class.plx.motor.php(53): plxMotor->__construct('./data/configur...')\n#2 /var/www/html/PluXml/index.php(30): plxMotor::getInstance()\n#3 {main}\n  thrown in /var/www/html/PluXml/core/lib/class.plx.motor.php on line 338
[Tue Mar 28 12:41:18.910122 2017] [:error] [pid 15679] [client 10.0.2.2:56172] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/PluXml/core/lib/class.plx.motor.php:338\nStack trace:\n#0 /var/www/html/PluXml/core/lib/class.plx.motor.php(69): plxMotor->getConfiguration('./data/configur...')\n#1 /var/www/html/PluXml/core/lib/class.plx.motor.php(53): plxMotor->__construct('./data/configur...')\n#2 /var/www/html/PluXml/index.php(30): plxMotor::getInstance()\n#3 {main}\n  thrown in /var/www/html/PluXml/core/lib/class.plx.motor.php on line 338
[Tue Mar 28 12:41:31.055438 2017] [:error] [pid 15680] [client 10.0.2.2:56176] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/PluXml/core/lib/class.plx.motor.php:338\nStack trace:\n#0 /var/www/html/PluXml/core/lib/class.plx.motor.php(69): plxMotor->getConfiguration('./data/configur...')\n#1 /var/www/html/PluXml/core/lib/class.plx.motor.php(53): plxMotor->__construct('./data/configur...')\n#2 /var/www/html/PluXml/index.php(30): plxMotor::getInstance()\n#3 {main}\n  thrown in /var/www/html/PluXml/core/lib/class.plx.motor.php on line 338
[Tue Mar 28 12:41:35.294448 2017] [:error] [pid 15681] [client 10.0.2.2:56178] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/PluXml/core/lib/class.plx.motor.php:338\nStack trace:\n#0 /var/www/html/PluXml/core/lib/class.plx.motor.php(69): plxMotor->getConfiguration('./data/configur...')\n#1 /var/www/html/PluXml/core/lib/class.plx.motor.php(53): plxMotor->__construct('./data/configur...')\n#2 /var/www/html/PluXml/index.php(30): plxMotor::getInstance()\n#3 {main}\n  thrown in /var/www/html/PluXml/core/lib/class.plx.motor.php on line 338
[Tue Mar 28 12:41:42.865068 2017] [:error] [pid 15682] [client 10.0.2.2:56180] PHP Fatal error:  Uncaught Error: Call to undefined function utf8_decode() in /var/www/html/PluXml/install.php:37\nStack trace:\n#0 {main}\n  thrown in /var/www/html/PluXml/install.php on line 37
[Tue Mar 28 12:46:03.239468 2017] [:error] [pid 15683] [client 10.0.2.2:56238] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/PluXml/core/lib/class.plx.motor.php:338\nStack trace:\n#0 /var/www/html/PluXml/core/lib/class.plx.motor.php(69): plxMotor->getConfiguration('./data/configur...')\n#1 /var/www/html/PluXml/core/lib/class.plx.motor.php(53): plxMotor->__construct('./data/configur...')\n#2 /var/www/html/PluXml/index.php(30): plxMotor::getInstance()\n#3 {main}\n  thrown in /var/www/html/PluXml/core/lib/class.plx.motor.php on line 338
[Tue Mar 28 12:48:10.985542 2017] [:error] [pid 15680] [client 10.0.2.2:56264] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/PluXml/core/lib/class.plx.motor.php:338\nStack trace:\n#0 /var/www/html/PluXml/core/lib/class.plx.motor.php(69): plxMotor->getConfiguration('./data/configur...')\n#1 /var/www/html/PluXml/core/lib/class.plx.motor.php(53): plxMotor->__construct('./data/configur...')\n#2 /var/www/html/PluXml/index.php(30): plxMotor::getInstance()\n#3 {main}\n  thrown in /var/www/html/PluXml/core/lib/class.plx.motor.php on line 338, referer: http://localhost:3180/PluXml/install.php
[Tue Mar 28 12:48:26.493672 2017] [:error] [pid 15681] [client 10.0.2.2:56268] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/PluXml/core/lib/class.plx.motor.php:338\nStack trace:\n#0 /var/www/html/PluXml/core/lib/class.plx.motor.php(69): plxMotor->getConfiguration('./data/configur...')\n#1 /var/www/html/PluXml/core/lib/class.plx.motor.php(53): plxMotor->__construct('./data/configur...')\n#2 /var/www/html/PluXml/index.php(30): plxMotor::getInstance()\n#3 {main}\n  thrown in /var/www/html/PluXml/core/lib/class.plx.motor.php on line 338, referer: http://localhost:3180/PluXml/install.php
[Tue Mar 28 12:48:52.434085 2017] [:error] [pid 15682] [client 10.0.2.2:56272] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/PluXml/core/lib/class.plx.motor.php:338\nStack trace:\n#0 /var/www/html/PluXml/core/lib/class.plx.motor.php(69): plxMotor->getConfiguration('./data/configur...')\n#1 /var/www/html/PluXml/core/lib/class.plx.motor.php(53): plxMotor->__construct('./data/configur...')\n#2 /var/www/html/PluXml/index.php(30): plxMotor::getInstance()\n#3 {main}\n  thrown in /var/www/html/PluXml/core/lib/class.plx.motor.php on line 338
[Tue Mar 28 12:51:05.737841 2017] [:error] [pid 15681] [client 10.0.2.2:56304] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/PluXml/core/lib/class.plx.motor.php:338\nStack trace:\n#0 /var/www/html/PluXml/core/lib/class.plx.motor.php(69): plxMotor->getConfiguration('./data/configur...')\n#1 /var/www/html/PluXml/core/lib/class.plx.motor.php(53): plxMotor->__construct('./data/configur...')\n#2 /var/www/html/PluXml/index.php(30): plxMotor::getInstance()\n#3 {main}\n  thrown in /var/www/html/PluXml/core/lib/class.plx.motor.php on line 338, referer: http://localhost:3180/PluXml/install.php
[Tue Mar 28 12:51:48.230708 2017] [:error] [pid 15682] [client 10.0.2.2:56314] PHP Fatal error:  Uncaught Error: Call to undefined function utf8_decode() in /var/www/html/PluXml/install.php:37\nStack trace:\n#0 {main}\n  thrown in /var/www/html/PluXml/install.php on line 37, referer: http://localhost:3180/PluXml/install.php
[Tue Mar 28 13:44:50.601978 2017] [:error] [pid 15683] [client 10.0.2.2:56902] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/PluXml/core/lib/class.plx.motor.php:338\nStack trace:\n#0 /var/www/html/PluXml/core/lib/class.plx.motor.php(69): plxMotor->getConfiguration('./data/configur...')\n#1 /var/www/html/PluXml/core/lib/class.plx.motor.php(53): plxMotor->__construct('./data/configur...')\n#2 /var/www/html/PluXml/index.php(30): plxMotor::getInstance()\n#3 {main}\n  thrown in /var/www/html/PluXml/core/lib/class.plx.motor.php on line 338, referer: http://localhost:3180/PluXml/install.php
[Tue Mar 28 13:44:51.862729 2017] [:error] [pid 15679] [client 10.0.2.2:56904] PHP Fatal error:  Uncaught Error: Call to undefined function xml_parser_create() in /var/www/html/PluXml/core/lib/class.plx.motor.php:338\nStack trace:\n#0 /var/www/html/PluXml/core/lib/class.plx.motor.php(69): plxMotor->getConfiguration('./data/configur...')\n#1 /var/www/html/PluXml/core/lib/class.plx.motor.php(53): plxMotor->__construct('./data/configur...')\n#2 /var/www/html/PluXml/index.php(30): plxMotor::getInstance()\n#3 {main}\n  thrown in /var/www/html/PluXml/core/lib/class.plx.motor.php on line 338, referer: http://localhost:3180/PluXml/install.php

voici le phpinfo. aditionnal module est vide, peut-être y devrai-t-il y avoir quelquechose ?
lien phpinfo

Hors ligne

#4 28/03/2017 15:24:07

Yanux
Membre
Lieu : Vannes
Inscription : 28/03/2017
Messages : 4

Re : [Résolu]Erreur 500 après installation

de ce que je comprends, il manquerai une librairie PHP lié à CML qui mettrai en erreur motor.php ? mais comment savoir laquelle ?

Hors ligne

#5 28/03/2017 16:17:43

Yannic
Membre
Lieu : Lac-Saint-Jean QC CA
Inscription : 17/01/2017
Messages : 182

Re : [Résolu]Erreur 500 après installation

Salut oui cest la librairie XML ( PHP-XML il me semble ) qui n'est pas installé


Bonjour chez vous !

Hors ligne

#6 28/03/2017 16:36:32

Jerry Wham
Membre
Inscription : 13/07/2011
Messages : 2 549
Site Web

Re : [Résolu]Erreur 500 après installation

Il y a deux fonctions qui manquent dans ton installation : undefined function xml_parser_create() et undefined function utf8_decode().
Tu n'as pas activé tous les modules nécessaires dans php. Ce n'est pas PluXml qui est en cause.


Mangez un castor, vous sauverez un arbre !

J'ai la tête dans le  ...code

Hors ligne

#7 28/03/2017 16:43:22

Yanux
Membre
Lieu : Vannes
Inscription : 28/03/2017
Messages : 4

Re : [Résolu]Erreur 500 après installation

merci, ça marche, j'ai mon blog !

Hors ligne

Pied de page des forums

A propos Nous soutenir Contact Twitter Google+
Copyright © 2006-2017 PluXml.org, tous droits réservés