PluXml.org

Blog ou CMS à l'Xml

Vous n'êtes pas identifié(e).

#1 16/11/2017 21:23:46

zejohn
Membre
Inscription : 16/11/2017
Messages : 3

[RESOLU] Probleme Authentification apres changement user pour apache

Bonjour,

Suite à un changement informatique sur l'infra (linux) où est hébergé un site pluxml, nous avons du faire tourner apache avec un user différent du user apache.
Suite à ce changement tout fonctionne sauf l'authentification.
Si on s'authentifie sur une page, ca marche mais dés qu'on change de page (ou qu'on veut aller dans l'admin), on perd l'authentification.
J'ai regardé les logs d'erreur d'apache et rien...
J'ai regardé les logs d’accès d'apache et rien...
J'ai regardé si il y avait des erreurs coté client, rien...

J'ai remis l’exécution d'apache avec le user apache et ca fonctionne. Donc c'est bien coté serveur.

Donc y a-t-il un probleme de droit sur un répertoire ?
Ou sont stockés les fichiers de cache qui contiennent les informations d'authentification ? (si il y en a)

Si vous avez une idée ou des pistes, je suis preneur  smile

Merci d'avance

Dernière modification par zejohn (17/11/2017 19:50:28)

Hors ligne

#2 16/11/2017 22:48:45

Stéphane
Responsable du projet
Lieu : pas loin de Metz
Inscription : 07/08/2007
Messages : 6 261
Site Web

Re : [RESOLU] Probleme Authentification apres changement user pour apache

Bonjour

Est-ce que l'url pour accéder au site à changr ?


Mes articles et tutoriels pour PluXml
Pluxopolis mon site sur PluXml, mais pas seulement...
Twitter: @pluxopolis

Hors ligne

#3 17/11/2017 00:54:00

bazooka07
Membre
Lieu : Quelque part en Rhône-Alpes
Inscription : 06/02/2014
Messages : 1 060
Site Web

Re : [RESOLU] Probleme Authentification apres changement user pour apache

Sous Debian/Apache, par défaut Apache2 tourne avec le compte www-data.
Donc a priori ton dossier PluXml doit appartenir au compte www-data. Y compris les sous-dossiers.

Mais apparament tu tournes sur une autre distrib linux Centos OpenSuse ?

Si tu bascules Apache sur le compte moncompte par exemple, il faut te placer dans le dossier qui contient PluXml et faire :

[== bash ==]
sudo chown -R moncompte PluXml
ls -l PluXml/*

PluXml tourne avec PHP. Donc il faut regarder les logs de PHP pour voir s'il ne râle pas pour des droits en lecture/écriture

Sur ton navigateur tu dois pouvoir au moins afficher une image :
http://mon-pluxml.net/core/admin/theme/ … pluxml.png
mon-pluxml.net est à remplacer par l'adresse de ton site

Dernière modification par bazooka07 (17/11/2017 00:54:29)

Hors ligne

#4 17/11/2017 11:39:10

zejohn
Membre
Inscription : 16/11/2017
Messages : 3

Re : [RESOLU] Probleme Authentification apres changement user pour apache

Bonjour,

Merci pour les réponses.
L'URL n'a pas changé.

La distrib c'est du redhat (donc apache2 s'appelle httpd).

J'ai bien fait le chown -R sur l'install de pluxml avec moncompte

Concernant l'affichage du site, il fonctionne tres bien. Seul l'authentification ne fonctionne pas.
Elle fonctionne sur la page courante et se "perd" lorsqu'on change de page.

Ou puis je trouver les logs php ?
Pluxml gére t il des fichiers de cache pour l'authentification ? si oui, ou puis les trouver pour verifier les droits.

Hors ligne

#5 17/11/2017 12:12:32

bazooka07
Membre
Lieu : Quelque part en Rhône-Alpes
Inscription : 06/02/2014
Messages : 1 060
Site Web

Re : [RESOLU] Probleme Authentification apres changement user pour apache

Oups !
PHP n'a pas de fichier de log. Il renvoie ses messages d'erreurs au serveur web.

Tu parles du user mais pas du group.
As tu mis le nouvel user dans le même groupe que Apache ?

Il y a longtemps que j'ai joué avec Fedora donc je ne connais pas trop cette famille de distributions (Redhat, Fedora, Centos)
Je me rappelle qu'elle utilise SELINUX pour gérer les droits des users et des services.

C'est bizarre qu'avec le nouvel user, tout fonctionne bien côté public et que cela plante dès qu'on tente un accès au back-office

Au cas où, tu redémarres bien Apache à chaque changement de user ?
Tu peux essayer de créer un fichier phpinfo.php dans le dossier core/admin avec simplement une ligne contenant "<?php infophp(); ?>" et voir si elle s'affiche dans le navigateur.

As-tu installé des plugins particuliers dans PluXml ?

Hors ligne

#6 17/11/2017 12:40:41

Gzyg
Membre
Inscription : 25/09/2006
Messages : 871
Site Web

Re : [RESOLU] Probleme Authentification apres changement user pour apache

Bonjour,

J'ai le même problème sur une openSUSE récente et uniquement avec l'authentification PluXml : autant sur une installation fraîche PluXml tout neuf (user créé) qu'avec un PluXml rapatrié (user existant)...

Pour info (peut-être inutile ?) WordPress, Drupal, et d'autres CMS fonctionnent tout à fait normalement.


à plus,

Gzyg

Hors ligne

#7 17/11/2017 18:00:06

Yannic
Membre
Lieu : Lac-Saint-Jean QC CA
Inscription : 17/01/2017
Messages : 216
Site Web

Re : [RESOLU] Probleme Authentification apres changement user pour apache

Salut, le pzramettre php.ini session.gc_maxlifetime est til correct ?
Perso jai du augmenter le mien car je me retrouvais déconnecté de l'admin apres 24 minutes (1440 secondes) d'inactivités dans l'admin


Bonjour chez vous !
Mon Site sous PluXml : cryptoservices.net
Mon Blog sous PluXml : yenten.today

Hors ligne

#8 17/11/2017 19:49:47

zejohn
Membre
Inscription : 16/11/2017
Messages : 3

Re : [RESOLU] Probleme Authentification apres changement user pour apache

Hello,

J'ai trouvé ! C'était juste le cookie existant coté client qui empeche l'authentification (suite au changement de user coté serveur).
Je l'explique pas mais j'ai pu le reproduire sur une debian.

En tout cas, merci pour votre aide et votre réactivité.

Hors ligne

#9 18/11/2017 13:37:02

bazooka07
Membre
Lieu : Quelque part en Rhône-Alpes
Inscription : 06/02/2014
Messages : 1 060
Site Web

Re : [RESOLU] Probleme Authentification apres changement user pour apache

J'utilise principalement Firefox.
Dans "préférences/Vie privée et sécurité" la case "accepter les cookies" est cochée et "les conserver" est réglée sur "jusqu'à la fermeture de Firefox".
Pour aller plus loin, je clique sur le bouton "Afficher les cookies", rentre l'url du serveur et j'efface tous ses cookies.
Cela sert si on a échoué les 3 tentatives pour s'authentifier

Hors ligne

Pied de page des forums

A propos Nous soutenir Contact Twitter Google+
Copyright © 2006-2018 PluXml.org, tous droits réservés