PluXml.org

Blog ou CMS à l'Xml

Vous n'êtes pas identifié(e).

#1 14/01/2018 17:08:03

Carambozilla
Membre
Inscription : 27/12/2017
Messages : 19

Masonry ne fonctionne pas sur le thème Masonic

Bonjour,
j'utilise le thème Masonic mais le problème c'est que Masonry ne fonctionne pas.
Je pensais que comme c'était une adaptation de thème Wordpress peut-être ça ne fonctionnait pas pour PluXml.
J'ai vu sur ce forum le post d'une personne qui l'utilisait et chez lui ça fonctionne.
http://www.gite-des-aubes.com/zetest/
Donc ça fonctionne sur PlumXml, et je me pose la question, qu'est-ce qu'il manque chez moi ?
J'ai téléchargé et mis dans les fichier js du thème le fichier masonry.pkgd.js et appelé ce dernier dans le fichier footer.php
J'ai fait un rajout dans le fichier category.php
<div id="container" class="wrapper clear masonry">
mais ça ne doit pas être au bon endroit car ça n'est pas pris en compte quand je regarde le code source…
j'ai rajouté "masonry-brick" dans les article id.
Toujours rien…
Quelqu'un a une idée ? J'ai sûrement fait des trucs inutiles, mais bon, je ne suis pas du tout experte…
Merci par avance pour vos réponse smile

P.S. ça fonctionne sur la colonne de roite, mais pas sur les autres… Page test ici :
https://www.pascale-varenne.fr/blog/blog

Dernière modification par Carambozilla (14/01/2018 17:57:05)

Hors ligne

#2 14/01/2018 20:26:08

bazooka07
Membre
Lieu : Quelque part en Rhône-Alpes
Inscription : 06/02/2014
Messages : 933
Site Web

Re : Masonry ne fonctionne pas sur le thème Masonic

Bonjour,

Ce genre de thème utilise beaucoup Javascript.
Dans ton navigateur Internet, tu peux appuyer sur la touche "F12" pour ouvrir l'inspecteur Web.
En regardant l'onglet console, tu verras que beaucoup de scripts javascript ne sont chargés.
Vérifie le contenu des attributs "src" de tes balises <script>. Il semble qu'ils ne pointent pas aux bons endroits.

Il faut également appuyer sur les touches "Ctrl-U" pour afficher le code source de la page HTML.
Ligne n°64 tu as 2 balises <a> imbriquées l'une dans l 'autre. C'est écrit en rouge.
Et c'est écrit en rouge en pas mal d'endroits. sad

Hors ligne

#3 15/01/2018 16:00:13

Carambozilla
Membre
Inscription : 27/12/2017
Messages : 19

Re : Masonry ne fonctionne pas sur le thème Masonic

Merci, en effet, je regarde et je me rends compte qu'en effet, il y a des tas de scripts qui ne se chargent pas pour la bonne raison qu'ils sont inexistants. J'ai essayé d'en trouver quelques uns mais je pense que je vais laisser tomber parce que de toutes manières je n'ai pas les compétences pour comprendre le js et que ça ne fonctionne toujours pas. C'est dommage parce que ça me convenait bien ce thème qui présente les posts en grille. Tant pis. En tout cas, ça n'ôte rien aux qualités de PluXml qui lui, correspond parfaitement à mes attentes, quelque chose de simple, pas usine à gaz.
Merci encore.

----Mise à jour ---
Finalement, j'ai désactivé tous les apples à Javascript et ça fonctionne tout pareil… (va comprendre…)  hmm

Dernière modification par Carambozilla (15/01/2018 16:44:41)

Hors ligne

#4 15/01/2018 16:21:25

Dudy
Membre
Lieu : Neuchâtel - Suisse
Inscription : 20/01/2007
Messages : 342

Re : Masonry ne fonctionne pas sur le thème Masonic

@Carambozilla
je viens de mettre à jour un theme avec les posts en grille en plus avec les filtres Isotope
ICI

Hors ligne

#5 15/01/2018 16:45:11

Carambozilla
Membre
Inscription : 27/12/2017
Messages : 19

Re : Masonry ne fonctionne pas sur le thème Masonic

Merci ! Je vais regarder… smile

Hors ligne

#6 15/01/2018 17:02:49

Carambozilla
Membre
Inscription : 27/12/2017
Messages : 19

Re : Masonry ne fonctionne pas sur le thème Masonic

Dudy a écrit :

@Carambozilla
je viens de mettre à jour un theme avec les posts en grille en plus avec les filtres Isotope
ICI

Merci, je viens de l'installer, mais les posts ne se mettent pas sur deux colonnes hmm
C'est pas grave, ce thème est très joli, quoi qu'il en soit wink

Dernière modification par Carambozilla (15/01/2018 17:09:26)

Hors ligne

#7 15/01/2018 17:07:20

Dudy
Membre
Lieu : Neuchâtel - Suisse
Inscription : 20/01/2007
Messages : 342

Re : Masonry ne fonctionne pas sur le thème Masonic

Pourrez tu me donner un lien ou voir Stp?

Hors ligne

#8 15/01/2018 17:09:48

Carambozilla
Membre
Inscription : 27/12/2017
Messages : 19

Re : Masonry ne fonctionne pas sur le thème Masonic

Hors ligne

#9 15/01/2018 17:15:16

Dudy
Membre
Lieu : Neuchâtel - Suisse
Inscription : 20/01/2007
Messages : 342

Re : Masonry ne fonctionne pas sur le thème Masonic

Je regarderais plus tard je suis su travail
Si jamais on continue le fil dans Réalisation

Hors ligne

#10 15/01/2018 17:25:12

Carambozilla
Membre
Inscription : 27/12/2017
Messages : 19

Re : Masonry ne fonctionne pas sur le thème Masonic

Ce n'est pas la peine, j'ai trouvé !
C'est parce que le lien vers le jquery était en http (comme l'appel à la typo d'ailleurs).
Comme mon site est en https, ces deux chargements étaient bloqués.
J'ai changé en https et ça fonctionne parfaitement.
Merci pour ton aide et encore bravo pour ce thème, très élégant smile

Hors ligne

#11 15/01/2018 18:39:49

Dudy
Membre
Lieu : Neuchâtel - Suisse
Inscription : 20/01/2007
Messages : 342

Re : Masonry ne fonctionne pas sur le thème Masonic

Ça est une bonne nouvelle
Merci bonne continuation

Hors ligne

#12 15/01/2018 19:05:13

bazooka07
Membre
Lieu : Quelque part en Rhône-Alpes
Inscription : 06/02/2014
Messages : 933
Site Web

Re : Masonry ne fonctionne pas sur le thème Masonic

Le plus simple est de télécharger JQuery et de le mettre sur ton serveur.

Comme cela, il n'y aura plus de mélange entre le protocole ouvert http et le protocole sécurisé https.
C'est comme l'huile et l'eau, le mélange ne marche pas.

C'est la 2ème fois ce week-end, et AMHA ce n'est que le début d'une longue série sur plusieurs années.

Hors ligne

#13 16/01/2018 21:13:12

Dudy
Membre
Lieu : Neuchâtel - Suisse
Inscription : 20/01/2007
Messages : 342

Re : Masonry ne fonctionne pas sur le thème Masonic

Bonsoir Carambozilla
J'aime beaucoup comment tu as personnaliser le thème

Dernière modification par Dudy (16/01/2018 21:31:27)

Hors ligne

#14 17/01/2018 08:12:02

cpalo
Membre
Lieu : Franqueville Eure
Inscription : 13/07/2011
Messages : 907

Re : Masonry ne fonctionne pas sur le thème Masonic

Bonjour Carambozilla,

Pareil.. J'aime beaucoup ta personnalisation du thème de Dudy

Hors ligne

#15 17/01/2018 12:07:47

Carambozilla
Membre
Inscription : 27/12/2017
Messages : 19

Re : Masonry ne fonctionne pas sur le thème Masonic

Merci à vous ! Je suis contente que ça vous plaise ! big_smile
J'aime beaucoup ce thème, et je trouve que le code est propre (pour autant que j'en puisse juger car je ne suis pas développeur).
Il fonctionne parfaitement.
Sauf…
que j'ai un bug sur la home page.
Tout fonctionnait parfaitement jusqu'à ce que hier, je crée 7 articles dans la section DIGITAL MEDIA. Depuis, les articles s'affichent mal lorsqu'on appelle les catégories depuis le menu horizontal (par contre cela fonctionne parfaitement lorsqu'on appelle les catégories depuis la sidebar).
Voilà :
Appel de toutes les catégories depuis l'item "Show all" > Tous les articles s'affichent, ainsi que la pagination, 10 articles sur la 1ère page (comme demandé dans les préférences) 4 articles sur la seconde.
Appel de la catégorie DIGITAL MEDIA. Là les problèmes commencent :
je n'ai que 7 articles qui s'affichent. Puis pagination, et sur la 2ème page, j'ai 4 articles mélangés (BUSINESS-RP et MAGAZINE)
Appel de la catégorie BUSINESS-RP, aucun article ne s'affiche juste la pagination, et en page 2 les mêmes articles mélangés que sur la page 2 de la catégorie DIGITAL MEDIA.

Je vous laisse tester le reste.
Quelqu'un a une idée ?

Bon, au pire je peux supprimer l'appel horizontal des catégories mais ce serait dommage…

NB : je déplace ce post vers Réalisations sur le thème Réalisations» Theme Pluxml Mag, ce qui me semble plus approprié…

Dernière modification par Carambozilla (17/01/2018 12:46:15)

Hors ligne

Pied de page des forums

A propos Nous soutenir Contact Twitter Google+
Copyright © 2006-2018 PluXml.org, tous droits réservés