PluXml.org

Blog ou CMS à l'Xml

Vous n'êtes pas identifié(e).

#176 01/03/2017 10:54:41

Stéphane
Responsable du projet
Lieu : pas loin de Metz
Inscription : 07/08/2007
Messages : 6 115
Site Web

Re : [plugin] MyMultiLingue

MyMultiLingue 0.8 rc1
https://github.com/Pluxopolis/plxMyMult … tag/0.8rc1

/!\ Nécessite PluXml 5.6 rc1

PluXml 5.6 rc1
https://github.com/pluxml/PluXml/releases/tag/5.6rc1

/!\ Si le plugin MyBetterUrls est utilisé, il doit également être mis à jour pour fonctionner

MyBetterUrls 1.5.4 rc1
https://github.com/Pluxopolis/plxMyBett … g/1.5.4rc1


Mes articles et tutoriels pour PluXml
Pluxopolis mon site sur PluXml, mais pas seulement...
Twitter: @pluxopolis

Hors ligne

#177 02/03/2017 14:40:40

Stéphane
Responsable du projet
Lieu : pas loin de Metz
Inscription : 07/08/2007
Messages : 6 115
Site Web

Re : [plugin] MyMultiLingue

MyMultiLingue 0.8 rc2a
https://github.com/Pluxopolis/plxMyMult … ag/0.8rc2a

Corrections:
- bug: dossier médias différent pour chaque langue
- bug: hreflang de la page statique mise comme page d'accueil
- bug: lien dans les dépendances des pages statiques vers une page statique correspondant à une page d'accueil

/!\ Nécessite PluXml 5.6 rc1

PluXml 5.6 rc1
https://github.com/pluxml/PluXml/releases/tag/5.6rc1

/!\ Si le plugin MyBetterUrls est utilisé, il doit également être mis à jour pour fonctionner

MyBetterUrls 1.5.4 rc1
https://github.com/Pluxopolis/plxMyBett … g/1.5.4rc1


Mes articles et tutoriels pour PluXml
Pluxopolis mon site sur PluXml, mais pas seulement...
Twitter: @pluxopolis

Hors ligne

#178 03/03/2017 10:44:37

Stéphane
Responsable du projet
Lieu : pas loin de Metz
Inscription : 07/08/2007
Messages : 6 115
Site Web

Re : [plugin] MyMultiLingue

MyMultiLingue 0.8 rc3
https://github.com/Pluxopolis/plxMyMult … tag/0.8rc3

Corrections:
- redirection 301 à partir d'url incomplète ex: http://localhost/fr/article1/

/!\ Nécessite PluXml 5.6 rc2

PluXml 5.6 rc2
https://github.com/pluxml/PluXml/releases/tag/5.6rc2

/!\ Si le plugin MyBetterUrls est utilisé, il doit également être mis à jour pour fonctionner

MyBetterUrls 1.5.4 rc1
https://github.com/Pluxopolis/plxMyBett … g/1.5.4rc1


Mes articles et tutoriels pour PluXml
Pluxopolis mon site sur PluXml, mais pas seulement...
Twitter: @pluxopolis

Hors ligne

#179 07/03/2017 15:55:57

Stéphane
Responsable du projet
Lieu : pas loin de Metz
Inscription : 07/08/2007
Messages : 6 115
Site Web

Re : [plugin] MyMultiLingue

MyMultiLingue 0.8 rc4

https://github.com/Pluxopolis/plxMyMult … tag/0.8rc4

- bug perte langue par défaut dans l'administration si modification du paramétrage
- mauvaise prise en compte des langues dans les flux rss <link>


/!\ Nécessite PluXml 5.6 rc2

PluXml 5.6 rc2
https://github.com/pluxml/PluXml/releases/tag/5.6rc2

/!\ Si le plugin MyBetterUrls est utilisé, il doit également être mis à jour pour fonctionner

MyBetterUrls 1.5.4 rc1
https://github.com/Pluxopolis/plxMyBett … g/1.5.4rc1


Mes articles et tutoriels pour PluXml
Pluxopolis mon site sur PluXml, mais pas seulement...
Twitter: @pluxopolis

Hors ligne

#180 08/03/2017 12:11:14

Stéphane
Responsable du projet
Lieu : pas loin de Metz
Inscription : 07/08/2007
Messages : 6 115
Site Web

Re : [plugin] MyMultiLingue

MyMultiLingue 0.8 rc5

https://github.com/Pluxopolis/plxMyMult … tag/0.8rc5

- bug réécriture des liens sur la page d'édition des pages statiques (administration)

/!\ Nécessite PluXml 5.6 rc3

PluXml 5.6 rc3
https://github.com/pluxml/PluXml/releases/tag/5.6rc3

/!\ Si le plugin MyBetterUrls est utilisé, il doit également être mis à jour pour fonctionner

MyBetterUrls 1.5.4 rc1
https://github.com/Pluxopolis/plxMyBett … g/1.5.4rc1


Mes articles et tutoriels pour PluXml
Pluxopolis mon site sur PluXml, mais pas seulement...
Twitter: @pluxopolis

Hors ligne

#181 05/04/2017 12:38:10

Stéphane
Responsable du projet
Lieu : pas loin de Metz
Inscription : 07/08/2007
Messages : 6 115
Site Web

Re : [plugin] MyMultiLingue

version 0.8 (27/03/2017)
[+] Compatibilité PluXml 5.6
[+] Gestion des dépendances entre articles rédigés dans des langues différentes
[+] Gestion des dépendances entre les pages statiques rédigées dans des langues différentes
[+] Amélioration de la gestion des liens lors de la bascule des langues
[+] Langue occitane (contribution Quentin)
[+] Langue affichée dans les urls sauf pour la langue par défaut
[+] Message d'information pour activer la réécriture d'url à l'activation du plugin
[+] (ajout) Configuration plugin > Utiliser un thème différent pour chaque langue
[+] (ajout) Configuration plugin > Préserver l'affichage de l'interface d'administration avec la langue du profil utilisateur connecté
[-] (suppr) Configuration plugin > Bascule sur l'article, catégorie ou page statique avec le même identifiant lors du changement de langue.
[-] (suppr) cookie plxMyMultiLingue pour la sauvegarde de la langue du site visité
BUG Pas d'affichage des drapeaux coté visiteurs si PluXml installé dans un dossier
BUG Warning à la création d'une page statique si paramètre "Page d'accueil" non renseigné


Mes articles et tutoriels pour PluXml
Pluxopolis mon site sur PluXml, mais pas seulement...
Twitter: @pluxopolis

Hors ligne

#182 07/04/2017 20:15:28

Sudwebdesign
Membre
Inscription : 15/02/2011
Messages : 86

Re : [plugin] MyMultiLingue

Yep Stéphane,

Suivant l'erreur que j'ai eu avec plxMyContact,
j'ai voulu tester si cela fonctionnait avec multilingue et un warning apparaît au menu plugin :
Warning: Constants may only evaluate to scalar values in plxMyMultiLingue/plxMyMultiLingue.php on line 90

il s'agit de cette ligne :

[== PHP ==]
		define('PLX_MYMULTILINGUE', array('langs' => $this->getParam('flags'), 'lang' => $this->lang));

Cela concerne seulement les serveurs en dessous de php 5.6

Quelle solution puis-je employer pour résoudre le problème sans bousculer les autres plugins?

une piste, en sérialisant Is it possible to declare an array as constant : réponse sur stackoverflow

[== PHP ==]
		define('PLX_MYMULTILINGUE', serialize(array('langs' => $this->getParam('flags'), 'lang' => $this->lang)));

ou
de multiple constantes
ou
...

Edit:
Après son activation, un
Warning: unlink(../../plugins/plxMyMultiLingue/update): Permission denied in core/lib/class.plx.plugins.php on line 82

Edit2: Soluce : supprimer ou renommer le fichier "update" du plugin wink

Edit3:
Ça a l'air de rouler avec serialize, par contre, lors de la rédaction dans une autre langue la phrase change en fonction du drapeau :
Dependencias de este artículo: lista de identificadores por idioma (opcional), Dependencies on this article: list of identifiers by language (optional),...

Ne devrait elle pas être en français? de même que la config du plugin, elles évoluent en fonction du drapeau choisi.

@ par ça, Tout roule pour l'instant.

superbe boulot wink

Dernière modification par Sudwebdesign (07/04/2017 20:45:40)

Hors ligne

#183 10/04/2017 10:22:48

Stéphane
Responsable du projet
Lieu : pas loin de Metz
Inscription : 07/08/2007
Messages : 6 115
Site Web

Re : [plugin] MyMultiLingue

version 0.8.1 (10/04/2017)
BUG tableau PLX_MYMULTILINGUE non géré avec php 5.x+
BUG Suppression fichier plugin update impossible (droit fichier)


Mes articles et tutoriels pour PluXml
Pluxopolis mon site sur PluXml, mais pas seulement...
Twitter: @pluxopolis

Hors ligne

Pied de page des forums

A propos Nous soutenir Contact Twitter Google+
Copyright © 2006-2017 PluXml.org, tous droits réservés