PluXml.org

Blog ou CMS à l'Xml

Vous n'êtes pas identifié(e).

#1 15/05/2017 12:05:02

Relaxrelax
Membre
Inscription : 15/05/2017
Messages : 2

Problème avec Htaccess Erreur 500 (OVH)

Hello ! je viens de me mettre à pluxml et je trouve ça génial niveau performance. Ça change de l'usine à gaz qu'est Wordpress. Je suis en train de bâtir un site avec cette solution. Tout se passe à peu près bien niveau développement et compréhension du CMS sauf que j'ai un problème majeur.

Je n'arrive pas à éditer mon fichier htaccess sans avoir une fuckinnnng erreur 500. Deux jours que j'essaye de trouver une solution par moi-même, mais aucune réussite. Ça me prend bien la tête d'autant plus que ce n'est pas le petit problème. C'est primordial que je puisse éditer ce fichier afin de faire des redirections.

Quelqu'un aurait-il rencontré ce problème et si oui ! comment faire pour le résoudre ? Voici quelques infos :

Je suis chez OVH serveur mutualisé
Version php 5.6
Le droit d'accès est de 644 sur le htaccess


Le contenu de mon htaccess

[== Indéfini ==]
# BEGIN -- Pluxml
Options -Multiviews
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
# Réécriture des urls
RewriteRule ^(?!feed)(.*)$ index.php?$1 [L]
RewriteRule ^feed\/(.*)$ feed.php?$1 [L]
</IfModule>
# END -- Pluxml

Aucune erreur 500 mais, si je l'édite par contre, c'est le début des problèmes et la fameuse erreur 500 s'affiche. En fait, j'aimerais rediriger www.#.com, http://#.com vers https://#.com pour profiter de la connexion sécurisée mais aussi éviter la duplication de pages. Je voudrais aussi rajouter un Expire header.

Désolé pour le pavé


Je suis l'homme sans signature

Hors ligne

#2 15/05/2017 20:22:52

kowalsky
Membre
Inscription : 20/08/2015
Messages : 257
Site Web

Re : Problème avec Htaccess Erreur 500 (OVH)

Salut Relaxrelax,

pour la redirection https, essaye l'une de ses 3 solutions suivantes (à placer avant "# BEGIN -- Pluxml")

[== Indéfini ==]
# redirections https 1
RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^/?(.*) https://%{SERVER_NAME}/$1 [R,L]

# redirections https 2
RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://monsite.com/$1 [R,L]

# redirections https 3
RewriteEngine On
RewriteCond %{HTTP_HOST} ^(www\.)?monsite.com$
RewriteCond %{HTTP_HOST} ^monsite\.com$ [OR]
RewriteCond %{HTTP_HOST} ^www\.monsite\.com$ [OR]
RewriteRule ^(.*)$ "https\:\/\/monsite\.com\/$1" [R=301,L,NE]

Pour l'expire header, je ne connais pas

Dernière modification par kowalsky (15/05/2017 20:26:01)

Hors ligne

#3 15/05/2017 21:52:07

bazooka07
Membre
Lieu : Quelque part en Rhône-Alpes
Inscription : 06/02/2014
Messages : 576
Site Web

Re : Problème avec Htaccess Erreur 500 (OVH)

Hors ligne

#4 16/05/2017 08:45:55

Relaxrelax
Membre
Inscription : 15/05/2017
Messages : 2

Re : Problème avec Htaccess Erreur 500 (OVH)

Re ! merci pour vos réponses.

Malheureusement, ça ne marche toujours pas. Je vais essayer de voir ça avec OVH. Je pense que ça doit venir de chez eux...

C'est la première fois que je galère autant pour gérer un fichier htaccess et c'est à se taper la tête contre un mur. C'est un peu comme si tu écrivais une ligne de code sans problème de syntaxe et que le truc t'afficher une erreur bref... sad 

Vous êtes chez quel hébergeur ?

Bonne journée smile


Je suis l'homme sans signature

Hors ligne

#5 16/05/2017 09:44:16

Stéphane
Responsable du projet
Lieu : pas loin de Metz
Inscription : 07/08/2007
Messages : 6 129
Site Web

Re : Problème avec Htaccess Erreur 500 (OVH)

Bonjour

Par expérience, ce qui pose des fois problème chez certains hébergeurs ce sont ces directives

Options -Multiviews
Options -indexes

Je ne sais pas dire si ça peut etre le cas chez OVH.
à savoir également qu'il faut contrôler leur présences dans les .htaccess qui sont dans les sous-dossiers également


Mes articles et tutoriels pour PluXml
Pluxopolis mon site sur PluXml, mais pas seulement...
Twitter: @pluxopolis

Hors ligne

#6 16/05/2017 20:39:10

kowalsky
Membre
Inscription : 20/08/2015
Messages : 257
Site Web

Re : Problème avec Htaccess Erreur 500 (OVH)

@Relaxrelax : avec quel logiciel et quel encodage édites-tu le fichier .htaccess ? Parce que la solution de redirection 2 est celle proposée sur le site d'OVH (https://docs.ovh.com/fr/fr/web/hosting/ … ments-web/) et la 3 est vraiment l'une des plus basique à mettre en place.

Une autre possibilité pour que cela ne fonctionne pas serait que tu n'aies pas de certificat SSL valide.

A vérifier dans ton espace client.

Hors ligne

Pied de page des forums

A propos Nous soutenir Contact Twitter Google+
Copyright © 2006-2017 PluXml.org, tous droits réservés