PluXml.org

Blog ou CMS à l'Xml

Vous n'êtes pas identifié(e).

#1 23/01/2018 19:31:15

heimphil
Membre
Inscription : 14/07/2013
Messages : 10

[Resolu]Erreur sur le plugin captchaImage

Bonjour

Bizarre
Sur mon uwamp en local je n'ai pas d'erreur
J'ai mis à jour mon site web hébergé chez free
en faisant un transfert ftp du pluxml local sur l'hébergement
Le site fonctionne bien a première vue
mais impossible de rentrer sur le module admin
L'image du Captcha ne s'affiche pas et j'ai une erreur :

captchaImage.php on line 52

Warning: array_rand() [function.array-rand]: First argument has to be an array in xxx/pluxml/plugins/captchaImage/captchaImage.php on line 52

J'ai refais le transfert du plugin
idem

Auriez vous une idée ?

Merci

Dernière modification par heimphil (09/02/2018 19:26:40)

Hors ligne

#2 23/01/2018 20:05:00

Stéphane
Responsable du projet
Lieu : pas loin de Metz
Inscription : 07/08/2007
Messages : 6 239
Site Web

Re : [Resolu]Erreur sur le plugin captchaImage

Bonjour

Est-ce que le dossier sessions est présent à la racine de ton hébergement ?


Mes articles et tutoriels pour PluXml
Pluxopolis mon site sur PluXml, mais pas seulement...
Twitter: @pluxopolis

Hors ligne

#3 26/01/2018 10:11:21

heimphil
Membre
Inscription : 14/07/2013
Messages : 10

Re : [Resolu]Erreur sur le plugin captchaImage

Bonjour

J'ai bien un dossier sessions à la racine du site

Merci pour votre aide

Hors ligne

#4 09/02/2018 19:30:29

heimphil
Membre
Inscription : 14/07/2013
Messages : 10

Re : [Resolu]Erreur sur le plugin captchaImage

Bonjour

J'ai pas mal bataillé
j'ai trouvé la solution
c'est la version de php chez free qui est insuffisante

j'avais un .htacces avec php 1 pour activer le php5 mais cela ne suffit plus avec la dernière version de pluxml
Dorenavant il faut modifier le .htaccess de la façon suivante

<IfDefine Free>
php56 1
</IfDefine>

Cela active sur notre site une version 5.6.8 de php
et là ça marche

Avis aux membres qui utilisent l'hébergeur free

Merci

Hors ligne

#5 09/02/2018 23:34:53

bazooka07
Membre
Lieu : Quelque part en Rhône-Alpes
Inscription : 06/02/2014
Messages : 932
Site Web

Re : [Resolu]Erreur sur le plugin captchaImage

Cela fait maintenant plus de 2 ans que Free.fr a basculé sur la version 5.6 de PHP.
les versions antérieures sont obsolètes (deprecated). AUCUNE MAINTENANCE ne sera faite pour elles.
Et ils sont en route pour la version 7.1, qui en autres avantages, est bien plus rapide.

Vu que la dernière distribution de Debian, qui n'est pas réputée pour coller aux nouveautés, a basculé vers la version 7.0, il est très probable que tous les serveurs sur le net vont  suivre

Quelques liens pour votre week-end verglacé :

AMHA, ce serait bien que la prochaine version de PluXml refuse de s'installer pour toute version de PHP < 7.0 en affichant un bel écran bleu pour rappeler que la maintenance du serveur n'est pas faite sérieusement.

mad  Je trouve pathétique de vouloir assurer une rétro-compatibilité de PluXml avec des versions obsolètes de PHP  mad

Evidemment, il y a Windows ....

Hors ligne

#6 09/02/2018 23:52:04

zakar!
Membre
Inscription : 10/04/2012
Messages : 118

Re : [Resolu]Erreur sur le plugin captchaImage

bazooka07 a écrit :

AMHA, ce serait bien que la prochaine version de PluXml refuse de s'installer pour toute version de PHP < 7.0 en affichant un bel écran bleu pour rappeler que la maintenance du serveur n'est pas faite sérieusement.

mad  Je trouve pathétique de vouloir assurer une rétro-compatibilité de PluXml avec des versions obsolètes de PHP  mad

Evidemment, il y a Windows ....

Je confirme tes propos JP, le code serait optimisé et plus rapide niveau bench. devil


Le no SQL en force !

Hors ligne

Pied de page des forums

A propos Nous soutenir Contact Twitter Google+
Copyright © 2006-2018 PluXml.org, tous droits réservés