commentaire: allow_com passe à 1

JoséJosé Member

Bonjour
quand j'enregistre un article sans autoriser les commentaires: allow_com est enregistré à 0.
quand je reviens modifier l'article, la valeur par défaut se présente à oui ( autoriser les commentaires !! ).
Si je ne prends pas garde en enregistrant mon article, les commentaires sont alors ouverts .

où est le défaut?
José

Réponses

  • Bonjour,
    Il faut donner une valeur par défaut quand à "allow_com" quand on analyse (parse) un fichier article.
    Rajouter "0" comme ci-dessous dans la fonction parseArticle() dans le fichier core/lib/class.plx.motor.php :

    $art['allow_com'] = plxUtils::getValue($values[$iTags['allow_com'][0]]['value'], 0);
    
  • JoséJosé Member

    Merci ,
    Cela ne change pas:
    dès que j'enregistre "ne pas autoriser = non " l'indicateur de choix revient sur "oui" .
    L'article sur le site est sans commentaire : il a bien été enregistré à "non"
    si je reviens dans l'administration sur l'article , l'indicateur est à "oui"

  • Tu utilises quelle version de PluXml ?
    Avec la version 5.8.4, la valeur pour la balise <allow_com> dans le fichier de l'article est soit 0, soit 1.

  • JoséJosé Member

    5.8.4
    dès que j'ouvre un article en admin , l'indicateur de choix est sur "oui", même s'il a été enregistré "non"

  • P3terP3ter PluXml Project Manager

    Bonjour, c'est corrigé sur la prochaine version de PluXml (5.8.5), merci bazooka pour la pull request : https://github.com/pluxml/PluXml/pull/516

    Site : p3ter.fr - Twitter : @P3terFr

  • JoséJosé Member

    Bonsoir
    Avec la modification complémentaire dans
    class.plx.utils.php , cela fonctionne. Bravo à vous, merci

Connectez-vous ou Inscrivez-vous pour répondre.