HELP ! Passage à 5.8.4 et à PHP 7.3 sur mutualisé OVH : thème et pages statiques inaccessibles

lbmhlbmh Member

Après une installation d'une 5.8.4 vierge, j'ai importé notre vieux site autaut.fr
et j'ai bien accès aux articles, aux commentaires importés et aux plugin importés,
mais impossible d'accéder ni au thème, ni aux pages statiques, ni à un plugin installé directement...

Les chmod ont été soigneusement faits,
toutes les informations sont bonnes...

PluXml version 5.8.4 (encodage UTF-8)

Version de PHP : 7.3.20
Apache

✔ ../../ est accessible en écriture
✔ ../../data/configuration/ est accessible en écriture
✔ ../../data/configuration/plugins/ est accessible en écriture
✔ ../../data/articles/ est accessible en écriture
✔ ../../data/commentaires/ est accessible en écriture
✔ ../../data/statiques/ est accessible en écriture
✔ ../../data/images/ est accessible en écriture
✔ ../../plugins/ est accessible en écriture
✔ ../../themes/ est accessible en écriture
✔ Bibliothèque GD installée
✔ Bibliothèque XML installée
✔ Fonction d'envoi de mail disponible

Nombre de catégories : 1

Nombre de pages statiques : 1

Nom du rédacteur en session :

Après activation de la ré-écriture des URL j'ai le .htaccess suivant

Order Allow,Deny
Deny from all


Order Allow,Deny
Deny from all

BEGIN -- Pluxml

Options -Multiviews

RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

Réécriture des urls

RewriteRule ^(?!feed)(.)$ index.php?$1 [L]
RewriteRule ^feed\/(.
)$ feed.php?$1 [L]

END -- Pluxml

Réponses

  • kowalskykowalsky Member

    Bonjour lbmh,

    quand tu dis : "importé notre vieux site autaut.fr",

    • est-ce que celui-ci était dans une version de PluXml inférieure à 5.8.4 avant l'import ? Ou bien avait-il été mis à jour ?
    • avais-tu désactivés les plugins et remis le thème par défaut sur l'ancien site avant l'import ?
  • Salut,
    Désactive la réécriture des URLS, sauvegarde la modif et réactive le.

  • Bonjour,
    Pour commencer :

    • désactive la réécriture d'urls
    • teste avec le thème par défaut même si tu le trouves moche
    • désactive tous les plugins si ça veut vraiment pas le faire

    Si cela marche, faire toutes ces opérations en sens inverse

  • lbmhlbmh Member

    @kowalsky, merci de tes questions : le site était dans une version antérieure avant l'import, sans mise à jour et je n'avais ni remis le thème par défaut ni désactivé les plugins avant l'export.

    @petitpouyo, excellente suggestion, que j'avais déjà tentée, sans succès.

    @bazooka07, merci pour ta marche à suivre : je teste avec le thème par défaut, qui n'a rien de moche ;) je viens de désactiver la réécriture des URLS et tous les plugins, les pages statiques n'apparaissent pas plus.

  • Salut @lbmh sinon je te propose une méthode radicale que j'ai déjà fais dans un de mes test.

    Il faut aller sur ton serveur FTP faire une sauvegarde complète de ton PluXml sur ton pc, ensuite tu supprime tout de ton FTP.

    Tu va sur pluxml et tu télécharge/installe la dernière version sur ton serveur FTP et tu importe de ta sauvegarde les tous les dossiers présents dans /data/.

    Ensuite tu réinstalle ton thème, puis tu importe tous tes plugins et tu les actives un par un.

    Normalement ça devrait fonctionner maintenant.

  • Tu as vérifié que les pages statiques sont actives et affichées dans le menu ?
    voir copie d'écran
    Sinon regarde les logs du serveur pour voir s'il n'y a pas une erreur

  • bazooka07bazooka07 Member
    8 janv. modifié

    @petitpouyo ,
    Auto-promotion 😛
    Pour installer le plus rapidement possible la dernière version de PluXml sur un serveur distant perdu dans le net on peut utiliser kzInstall2 :
    https://forum.pluxml.org/discussion/6268/kzinstall2-installation-automatisee-pour-pluxml/p1
    https://kazimentou.fr ( bouton en haut et à droite )
    PluXml est installé avec le plugin kzUpload qui permet de télécharger directement les archives zip d'autres plugins.

  • petitpouyopetitpouyo Member
    8 janv. modifié
  • kowalskykowalsky Member

    "le site était dans une version antérieure avant l'import" -> s'il s'agit d'une version antérieure à 5.8, c'est peut être l'origine de ton souci.

    • essaye d'upgrader ton ancien site vers la version 5.8.4 puis exporte le ensuite.
    • ou sinon installe la même ancienne version de PluXml que ton ancien site sur ton nouvel hébergement, importe le et fait ensuite les mises à jour.
  • lbmhlbmh Member

    @petitpouyo et @bazooka07, je viens de procéder comme vous le suggérez, à l'aide de kzInstall2 (super !) sans aucun succès :
    bien que présentes dans leur repertoire /www/data/statique/ aucune des pages statiques ne s'affiche dans le back office cf: copies d'écran ci dessous.

    https://www.dropbox.com/s/cd5wajg1bhi9ol0/Capture d’écran 2021-01-08 à 19.26.47.png

    https://www.dropbox.com/s/snpv9yq6eth9u2a/Capture d’écran 2021-01-08 à 19.27.05.png

    Je ne suis pas allé jusqu'à la réinstallation du thème.

    @kowalsky, malheureusement, je n'ai plus l'ancien site et quand j'essaye de ré-installer l'ancienne version de Pluxml, dès que je tente d'accéder à l'interface d'utilisation je déclanche l'upgrade qui finit par planter cf

    https://www.dropbox.com/s/6xc37a8p3gzwlt1/Capture d’écran 2021-01-09 à 11.53.44.png

  • Quelle version de PluXml utilisait ton ancien site ?
    As tu bien un fichier /www/data/configuration/statiques.xml ?
    Que contient-il ?
    Côté administrateur, peux-tu éditer une page statique et la sauvegarder ? Voir si elle s'affiche après la sauvegarde.

    Tant que cela ne marche pas, il faut faire les essais sans ré-écriture d'urls, sans plugin et avec le thème par défaut.

  • lbmhlbmh Member

    @bazooka07 Mon site utilisait précédemment la 5.6

    J'ai bien un fichier /www/data/configuration/statiques.xml
    quand je démarre avec une configuration vierge en 5.8.4 et que le seul ajout que je fasse, c'est la création d'une page statique de test, celle-ci apparait bien dans la back office et on peut la voir sur http://autaut.fr/index.php?static1/test-statique.

    Si je copie mon précédent fichier statiques.xml, alors BINGO ! les pages statiques sont bien présentes, dans le back office, comme sur le site.

    Reste la question du thème. A suivre... Un énorme merci à tous.

  • lbmhlbmh Member

    Maintenant, le thème se ré-installe bien, après une mise à jour de 5.7 en 5.8.4....

    Vive Pluxml et bravo à l'entraide !

  • @lbmh c'est pas toujours évident mais on fini toujours par trouver une solution.

  • @lbmh
    Bonjour,
    ton site autaut.fr utilise le thème Cleanlook qui date de la nuit des temps. Il n'est absolument pas responsive design et j'imagine mal quelqu'un tapoter sur son smartphone dans un hall de gare pour visiter ton site.

    J'ai repris ce thème, enfin je n'ai repris pas chose, pour qu'il soit agréable à utiliser sur un smartphone, une tablette ou PC. C'est sensiblement la même mise en page et à peu près les mêmes couleurs.
    En bonus, il y a des gabarits (template) pour un formulaire de contact et une galerie d'images

    Télécharger le thème kzCleanlook

    Copie d'écran PC

    Copie d'écran smartphone

  • lbmhlbmh Member
    13 janv. modifié

    @bazooka07 : Super ton thème CleanLook mis à jour. Merci beaucoup.
    Je viens de le mettre et service, et, au passage, le vieux thème a disparu de la liste des thèmes.

    Comment faire, maintenant, pour
    afficher mes pages statiques Mentions légales et Plan du site dans le menu du bas,
    avoir la case de recherche en début du menu du haut,
    faire disparaitre Blog du menu du haut,
    faire remonter le footer,
    afficher les liens en orange ?

  • Pour faire apparaitre ce vieux thème Cleanlook dans la liste des thèmes, il faut ajouter un fichier infos.xml dans le dossier du thème contenant ceci :

    <?xml version="1.0" encoding="UTF-8"?>
    <document>
        <title>kzCleanlook</title>
        <author>Inconnu</author>
        <version>1.0.0</version>
        <date>2010-04-07</date>
        <site></site>
        <description><![CDATA[Thème Cleanlook]]></description>
    </document>
    

    Pour afficher les liens en orange dans les articles, il faut rajouter ceci au début des fichiers theme.css ou theme.min.css :

    article a {
        color: var(--fgcolor1);
    }
    

    theme.min.css est la version compressée de theme.css par gulp. Pour éviter d'avoir à gérer les 2 fichiers, dans header.php faire la modification suivante à la ligne 74 :

        <link rel="stylesheet" href="<?= TEMPLATE ?>/css/theme.css" />
    

    Pour faire disparaitre l'entrée blog du menu, dans la liste des pages statiques, décocher toutes les case pour "page d'accueil".
    Pour faire disparaitre les entrées mentions légales et plan du site dans la liste ci dessus mettre à "masquer" pour l'option "menu" les pages correspondantes. Pour les faire apparaitre dans le pied de page, il faut rajouter les liens correspondants dans le fichier footer.php du thème.
    Pour la case "recherche" tu utilises un plugin ? Dans ce cas, il faut rajouter un hook dans header.php ou posts.php

    Ton site sera très mal référencé par Google tant qu'il sera en http. Il faut utiliser https. Cocher la case qui va bien dans le panneau d'administration de ton hébergeur.

  • lbmhlbmh Member

    @bazooka07 merci infiniment d'avoir pris le temps de répondre à mes questions et de la pertinence de tes propos.

    Sur le https, ya un truc qui m'échappe : mes deux urls autaut.fr et www.autaut.fr ont bien chacune leur certificat SSL valide et quand on y accède en les préfixant par https:// on obtient bien l'affichage du cadenas verrouillé.

    En revanche, bien que je force le passage en https:// dans les paramètres/options/extension de tous mes navigateurs web,
    avec autaut.fr comme www.autaut.fr, ce forcage ne se produit pas et le cadenas est déverouillé.

    Faut-il modifier le .htacess ? J'ai tenté de le faire il y a 72 heures, mais, alors j'avais perdu l'accès du back office de Pluxml a mon thème Cleanlook...

  • Oui il faut modifier le .htaccess "à la main" chez OVH. Chez d'autres hébergeurs la procèdure est automatisée.
    Lise le manuel à "En pratique/étape 3" pour "Vous utilisez un site que vous avez codé vous-même (ou quelqu’un l’a fait pour vous)"
    https://docs.ovh.com/fr/hosting/passer-site-internet-https-ssl/

    Je trouve leur configuration un peu sommaire. J'utilise cela sur https://kazimentou.fr :

    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteCond %{HTTPS} !=on
        RewriteRule ^(.*)$ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
    </IfModule>
    

    Je crois que j'ai dû piqué cette config chez LWS.

    Le code 301 signifie une redirection permanente. Il mettra à jour la mémoire de tes navigateurs.

  • lbmhlbmh Member

    En effet, la modification du .htaccess règle parfaitement le sujet. Nickel !

Connectez-vous ou Inscrivez-vous pour répondre.