Problème affichage sous-menu avec safari

jol5926jol5926 Member

Hello la team,
sur mon petit site de e-commerce que je suis entrain de créer : https://maboutique.leptitcoindejoliez.fr
J'ai un menu appelé "Catégories boutique" et il y a 6 sous catégories. Les 6 sous catégories s'affichent correctement sous firefox mais sous safari on ne voit que 3 sous catégories.
Même problème avec la catégorie "aide". En allant sur le site pour tester vous comprendrez plus facilement que ces explications.
Est-ce que quelqu'un à une idée sur ce bug ?

Merci

Réponses

  • jol5926jol5926 Member
    31 janv. modifié

    Hello,
    Je viens de faire un test avec la dernière version de pluxml et sans aucun plugin, au cas ou, et toujours le même problème d'affichage du sous-menu avec safari.

    Quelqu'un a-t-il une idée ?

  • jol5926jol5926 Member

    Je viens de faire un test avec un autre thème que celui par défaut et tout fonctionne correctement, thème utilisé kzcleanlock de bazooka07.

  • Pour Safari, certaines règles CSS doivent être préfixées par -webkit-. Cela existe dans une moindre mesure pour les autres navigateurs.
    https://www.alsacreations.com/article/lire/1159-prefixes-vendeurs-css-proprietaires.html
    https://developer.mozilla.org/fr/docs/Glossaire/Préfixe_Vendeur

  • jol5926jol5926 Member
    1 févr. modifié

    Il serait bien qu'une correction soit faite sur le thème par défaut pour qu'il soit compatible avec safari !
    Je viens de faire un nouveau test avec une ancienne version du thème par défaut, version 5.6, et ça fonctionne correctement.
    C'est bien la nouvelle version du thème par défaut qui bogue.
    Mes compétences étant limités dans ce domaine, je ne peux pas faire les modifications nécessaires.

  • Il serait bien que les prix des macs baissent de façon sensible ou qu'on oublie Safari !

    voici le lien pour avoir les fichiers CSS modifiés qui devraient marcher avec Safari. Mais je ne peux pas vérifier sans Mc sous la main.
    https://github.com/kazimentou/PluXml/tree/gulp-postcss/themes/defaut/css
    Il faut prendre tous les fichiers *.css ou *.min.css

    Pour ceux qui ont un peu plus de compétences : les fichiers CSS ont été parsés avec gulp-postcss.
    Voir le dossier gulp dans le lien ci-dessus. ( nodejs et npm required comme on dit )

  • jol5926jol5926 Member

    @bazooka07
    Merci pour retour malheureusement ça ne fonctionne toujours pas et c'est vrai sans mac sous la main pas évident. Ce qui est surprenant, c'est que j'ai testé d'autres thèmes et tout est ok. C'est le thème par défaut qui bogue ??
    Pour le prix des mac, c'est vrai qu'une baisse des prix serait la bienvenue mais je ne suis qu'un utilisateur et je dois avouer que le fonctionnement du mac sans critiquer windows me convient très bien. Peut-être que safari doit être amélioré, c'est pour cela que j'utilise firefox mais il y a des personnes qui vont surfer avec safari et là il y a des erreurs dans le menu.
    En tout cas, merci pour ton aide, en espérant que tu puisses solutionner ce souci d'affichage.

Connectez-vous ou Inscrivez-vous pour répondre.