PluXml.org

Blog ou CMS à l'Xml

Vous n'êtes pas identifié(e).

#1 23/12/2017 10:54:55

jol5926
Membre
Lieu : Drôme
Inscription : 25/04/2015
Messages : 488
Site Web

Affichage blog

Hello,

Su ma page blog, j'ai cette présentation :
blog.png

Il manque les autres informations :
Auteur, commentaires, rubriques, etc..

et je ne sais pas pourquoi ?

Merci de votre aide

Jol

Hors ligne

#2 23/12/2017 13:10:29

cpalo
Membre
Lieu : Franqueville Eure
Inscription : 13/07/2011
Messages : 938

Re : Affichage blog

Bonjour,

A l'intérieur de ta balise article as-tu un footer et un header ?

                                                <header>
							<h2>
								<?php $plxShow->artTitle('link'); ?>
							</h2>
							<small>
								<span class="written-by">
									<?php $plxShow->lang('WRITTEN_BY'); ?> <?php $plxShow->artAuthor() ?>
								</span>
								<time class="art-date" datetime="<?php $plxShow->artDate('#num_year(4)-#num_month-#num_day'); ?>">
									<?php $plxShow->artDate('#num_day #month #num_year(4)'); ?>
								</time>
								<span class="art-nb-com">
									<?php $plxShow->artNbCom(); ?>
								</span>
							</small>
						</header>

						
						<?php $plxShow->artThumbnail(); ?>
						<?php $plxShow->artChapo(); ?>
						

						<footer>
							<small>
								<span class="classified-in">
									<?php $plxShow->lang('CLASSIFIED_IN') ?> : <?php $plxShow->artCat() ?>
								</span>
								<span class="tags">
									<?php $plxShow->lang('TAGS') ?> : <?php $plxShow->artTags() ?>
								</span>
							</small>
						</footer>

Hors ligne

#3 23/12/2017 19:05:31

jol5926
Membre
Lieu : Drôme
Inscription : 25/04/2015
Messages : 488
Site Web

Re : Affichage blog

balise article dans quel fichier ?

Hors ligne

#4 23/12/2017 20:40:37

cpalo
Membre
Lieu : Franqueville Eure
Inscription : 13/07/2011
Messages : 938

Re : Affichage blog

Dans le template home.php :

<main class="main">

		<div class="container">

			<div class="grid">

				<div class="content col sml-12 med-8">

					<?php while($plxShow->plxMotor->plxRecord_arts->loop()): ?>

					<article class="article" id="post-<?php echo $plxShow->artId(); ?>">

						<header>
                                                        <h2>
								<?php $plxShow->artTitle('link'); ?>
							</h2>
							<small>
								<span class="written-by">
									<?php $plxShow->lang('WRITTEN_BY'); ?> <?php $plxShow->artAuthor() ?>
								</span>
								<time class="art-date" datetime="<?php $plxShow->artDate('#num_year(4)-#num_month-#num_day'); ?>">
									<?php $plxShow->artDate('#num_day #month #num_year(4)'); ?>
								</time>
								<span class="art-nb-com">
									<?php $plxShow->artNbCom(); ?>
								</span>
							</small>
						</header>

						
						<?php $plxShow->artThumbnail(); ?>
						<?php $plxShow->artChapo(); ?>
						
                                                <footer>
							<small>
								<span class="classified-in">
									<?php $plxShow->lang('CLASSIFIED_IN') ?> : <?php $plxShow->artCat() ?>
								</span>
								<span class="tags">
									<?php $plxShow->lang('TAGS') ?> : <?php $plxShow->artTags() ?>
								</span>
							</small>
						</footer>

					</article>

Dernière modification par cpalo (23/12/2017 20:42:16)

Hors ligne

#5 24/12/2017 09:41:37

jol5926
Membre
Lieu : Drôme
Inscription : 25/04/2015
Messages : 488
Site Web

Re : Affichage blog

Merci Cpalo,

Problème résolu !

Hors ligne

Pied de page des forums

A propos Nous soutenir Contact Twitter Google+
Copyright © 2006-2018 PluXml.org, tous droits réservés