PluXml.org

Blog ou CMS à l'Xml

Vous n'êtes pas identifié(e).

#1 18/10/2018 10:08:20

shaman
Membre
Inscription : 25/03/2011
Messages : 60

Sitemap et https

Bonjour,

je suis sous OVH mutualisé avec un https actif.

J'ai plusieurs pluxml installés à l'époque sans https.
Dans la console de recherche google, j'ai des problemes d'url refusées pour un probleme d'url canonique qui n'est pas celle déclarée au sitemap.

Quand je regarde le sitemap, les url sont en http simple.

Question, comment forcer le sitemap à indiquer les chemins https ? si c'est bien cela qu'il faut faire pour le référencement...

Je suis un peu perdu.

EDIT : le sitemap se modifie quand on l'execute en http ou https... donc comment forcer le https avec pluxml ? est-ce à partir du htaccess ? de l'interface OVH ?

Exemple : http://www.snack-newcampus.fr/

Dernière modification par shaman (18/10/2018 10:12:07)

Hors ligne

#2 18/10/2018 10:16:33

noogaty
Membre
Inscription : 16/07/2013
Messages : 137

Re : Sitemap et https

Salut,
Perso, j'ai mis dans mon htaccess :

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [R,L]

Et ça fonctionne ! wink
Après, ça dépend peut-être des hébergeurs ?

Hors ligne

#3 18/10/2018 13:46:26

shaman
Membre
Inscription : 25/03/2011
Messages : 60

Re : Sitemap et https

Merci pour ta réponse.

Perso, j'ai ça dans mon htaccess :

[== Indéfini ==]
# BEGIN -- Pluxml

Options -Multiviews

<IfModule mod_rewrite.c>

RewriteEngine on

RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteCond %{REQUEST_FILENAME} !-l

# Réécriture des urls

RewriteRule ^(?!feed)(.*)$ index.php?$1 [L]

RewriteRule ^feed\/(.*)$ feed.php?$1 [L]

</IfModule>
# END -- Pluxml

Si je met ton bout de code tel quel au début, j'ai une erreur 500...

Comment insérer ton instruction en gardant la réecriture d'url et autres options de pluxml ?

Hors ligne

#4 18/10/2018 16:58:31

noogaty
Membre
Inscription : 16/07/2013
Messages : 137

Re : Sitemap et https

Moi, je l'ai mis à la fin du fichier htaccess.
Mais je ne suis pas chez OVH, donc peut-être que le code diffère ?
Sinon, demande sur le forum d'OVH ?

Hors ligne

#5 18/10/2018 17:33:42

shaman
Membre
Inscription : 25/03/2011
Messages : 60

Re : Sitemap et https

J'ai essayé... à priori y'a des conflits de rewriterule qui peuvent apparaitre...

Sur le forum, personne chez OVH qui ait résolu ça ?

Merci en tout cas.

Hors ligne

Pied de page des forums

A propos Nous soutenir Contact Twitter Google+
Copyright © 2006-2019 PluXml.org, tous droits réservés