PluXml.org

Blog ou CMS à l'Xml

Vous n'êtes pas identifié(e).

#1 11/01/2016 00:38:43

mathieu
Membre
Inscription : 30/04/2015
Messages : 250

[Résolu] PluXML avec PHP 7

J'allais faire un nouveau "Pull request" quand j'ai vu que quelqu'un a déjà proposé exactement la modification que j'allais proposer :
https://github.com/pluxml/PluXml/pull/144

Après cette modification, le code fonctionne avec PHP 7 et PHP 5.6 et 5.5.

Dernière modification par mathieu (12/01/2016 15:30:19)

Hors ligne

#2 11/01/2016 01:57:32

lgnap
Membre
Inscription : 09/09/2011
Messages : 19

Re : [Résolu] PluXML avec PHP 7

Oui en effet  wink

Hors ligne

#3 12/01/2016 15:30:07

mathieu
Membre
Inscription : 30/04/2015
Messages : 250

Re : [Résolu] PluXML avec PHP 7

c'est réglé, la modification a été acceptée smile

Hors ligne

#4 12/01/2016 15:56:50

Stéphane
Responsable du projet
Lieu : pas loin de Metz
Inscription : 07/08/2007
Messages : 6 166
Site Web

Re : [Résolu] PluXML avec PHP 7

Yep. Merci pour avoir signaler le problème et avoir proposer la solution. C'est tout bon !


Mes articles et tutoriels pour PluXml
Pluxopolis mon site sur PluXml, mais pas seulement...
Twitter: @pluxopolis

Hors ligne

#5 12/01/2016 20:08:28

danielsan
Membre
Lieu : Montpellier
Inscription : 18/07/2011
Messages : 1 274

Re : [Résolu] PluXML avec PHP 7

doit-on prévoir des modifs pour les plugins ?


Que l'inspiration soit avec vous, à jamais !

Hors ligne

#6 12/01/2016 20:15:31

mathieu
Membre
Inscription : 30/04/2015
Messages : 250

Re : [Résolu] PluXML avec PHP 7

non ce problème venait juste d'un changement dans la syntaxe de PHP donc les extensions qui fonctionnaient déjà continueront de fonctionner de la même façon

Hors ligne

#7 29/04/2016 14:51:59

mathieu
Membre
Inscription : 30/04/2015
Messages : 250

Re : [Résolu] PluXML avec PHP 7

la fonction http://php.net/xml_parser_create fait partie de l'installation par défaut de PHP d'après la documentation :
http://php.net/manual/fr/xml.installation.php
donc regardez déjà la configuration de PHP pour voir s'il y a un réglage particulier pour cela

Hors ligne

#8 19/01/2017 13:00:38

brica
Membre
Inscription : 30/12/2006
Messages : 63

Re : [Résolu] PluXML avec PHP 7

Bonjour,

J'ai la 5.3 de PluXml, mon hébergeur vient de passer à la version 7.1 de PHP : concrètement, quels fichiers et quelles lignes dois-je modifier dans PluXml pour qu'il refonctionne ? (j'ai une page blanche).

Je  vous remercie.

Hors ligne

#9 19/01/2017 13:33:03

Stéphane
Responsable du projet
Lieu : pas loin de Metz
Inscription : 07/08/2007
Messages : 6 166
Site Web

Re : [Résolu] PluXML avec PHP 7

@Brica. Bonjour.
Passe à la 5.5 car il est impossible de lister les fichiers et les lignes tellement il y a de choses changées dans le core de PluXml entre la 5.3 et la 5.5.
Si tu as accès aux logs php de ton site, tu auras l'erreur en cause de la page blanche. ça donnerait éventuellement une idée sur où intervenir si tu veux garder la 5.3. Sans ça, c'est difficile de répondre à ta demande


Mes articles et tutoriels pour PluXml
Pluxopolis mon site sur PluXml, mais pas seulement...
Twitter: @pluxopolis

Hors ligne

#10 19/01/2017 15:14:54

brica
Membre
Inscription : 30/12/2006
Messages : 63

Re : [Résolu] PluXML avec PHP 7

@Stephane,

Merci pour ta réponse si rapide et bien claire. Je passe donc à la 5.5...

...et je viens à l'instant de migrer de la 5.3 vers la 5.5 : plugins, data et même les thèmes que j'avais modifiés fonctionnent sans accroc. smile  smile

Dernière modification par brica (19/01/2017 23:09:09)

Hors ligne

Pied de page des forums

A propos Nous soutenir Contact Twitter Google+
Copyright © 2006-2017 PluXml.org, tous droits réservés