parse error à l'installation chez Free.fr

Bonjour,
je rencontre cette erreur : Parse error: syntax error, unexpected T_CONST in /mnt/136/sda/3/2/aykathe/install.php on line 2
Faut-il modiier la ligne const PLX_ROOT = './';
j'ai bien ajouté un fichier ;htacess et un dossier sessions à la racine.
merci pour vos solutions.

Réponses

  • Bonjour Elisabeth,

    regarde si les informations de cette page peuvent t'aider : https://wiki.pluxml.org/installer/hebergeurs/

    Quelle est la version de PHP utilisée par Free ?

  • SudwebdesignSudwebdesign Member
    29 juil. modifié

    Bonjour @Elisabeth
    Il manque peut-être a ajouter tout en haut ds le fichier .htaccess la ligne suivante :
    php56 1

    Cela active le php 5.6 de ton l'espace, il est possible qu'il tourne en php 5.1 (voir en php4).

    Note : il est aussi possible d'activé php 7.3 chez free.fr avec la directive php73 1 au début du .htaccess ;)
    Plus d'info ici

    Quelle version de PluXml utilise tu? (au cas ou)

    NB: Il y a (encore?) besoin de créer un dossier sessions a la racine pour que l'admin tourne bien :)

    Notre temps est la seule monnaie vraie ;)

    Site, Dépôt, framagit, MyShop, Factux

  • J'ai vérifié la version php, c'est la 5.6. Merci Sudwebdesign ! en fait, dans mon htaccess, j'avais seulement mis php 1, et en remplaçant par php56 1, tout fonctionne.

Connectez-vous ou Inscrivez-vous pour répondre.