[Résolu d'une certaine façon] Les éditeurs de texte ne s'affichent pas

zatalyzzatalyz Member
18 oct. modifié dans Bogues

Bonjour,
J'ai cru que c'était lié à la nouvelle version de PluXml (j'ai déjà mis un message ici : https://forum.pluxml.org/discussion/comment/61049/#Comment_61049 ) mais visiblement non... Ça doit être quelque chose lié à mon serveur, mais je n'arrive pas à trouver quoi et où.

Le problème : les plugins d'éditeur wysiwyg ne semblent plus marcher. J'ai testé CKeditor, Cmixml, tinyeditor, TinyMCE, et avec chacun, la barre wysiwyg reste invisible sur tous les endroits où elle devrait apparaître. Je ne vois aucune erreur apparaître dans les logs Apache.

J'ai inspecté la page avec l'inspecteur de code de Firefox mais, à moins que je ne sache pas quoi chercher, il n'y a rien qui apparaît lié à l'éditeur. Je précise que j'ai laissé le thème par défaut, afin de limiter les soucis.

Mes logs apache n'ont pas une seule erreur sur ces pages (ce qui est plutôt chouette par ailleurs, mais ne m'aide pas ici).

J'ai tenté de mettre "display_errors = On" dans php.ini (et non, mon site n'est pas en local mais c'est sur un serveur dédié aux tests donc pas trop de risque). Ça marche très bien (l'affichage des erreurs) si je tente d'activer spxplugindownloader par contre (ce plugin en déclenche un paquet... ce qui n'a aucune importance ici ;) ).

Mes fichiers sont bien attribués à www-data. Dans ma configuration apache, j'ai ces autorisations :

Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
Allow from all

Je ne sais pas où chercher et ce qui fait que ces plugins ne s'affichent pas...

Réponses

  • Bonjour,

    Tu as essayé en mettant "non" pour "Activer la réécriture d'URL" dans "configuration avancée" ?

    Je vois dans la console javascript des messages d'erreurs de mon côté avec tinyMCE mais ces messages ne sont pas corrects. Il semble qu'il y a un problème de ré-écriture d'urls avec Apache.

    Dans la console javascript de Firefox, tu peux retrouver les barres de menu des éditeurs avec l'instruction javascript suivante :

    document.getElementsByClassName("mce-menubar")
    
  • Il y a effectivement un problème quand on active la redirection d'url.
    Si on demande un fichier qui n'existe pas, par exemple https://mon-server.com/themes/defaut/css/mon-style-perso.css, PluXml renvoie la page d'accueil, avec un mime-type text/html, au lieu de renvoyer une belle erreur 404.
    J'ai corrigé cela sur mon PC mais je dois vérifier quelque détail.. avant d'envoyer un PR.
    @zatalyz ,
    Mais je ne suis pas sûr que cela résoudra ton problème.

  • zatalyzzatalyz Member

    J'ai passé quelques jours à tester tout ce que je pouvais (ce qui est proposé ici, tout ce que des amis sysadmins ont pu me filer comme conseils...), ça a été sacrément compliqué, mais j'ai fini par trouver.

    C'est lié à mon serveur, Pluxml est hors de cause. Je partage la résolution ici, si d'autres rencontrent le même souci. Mon apache avait des règles CSP, assez classique. Sauf que pour une raison encore non élucidée, il ne les interprète pas correctement sur Pluxml. Probablement ailleurs aussi, mais les autres sites que j'ai en test sur cette machine sont du simple html, ça ne se voit pas...

    Ma règle CSP dans /etc/apache2/mods-enabled/headers.conf :
    Header set Content-Security-Policy "default-src 'self' ; script-src 'self' ; style-src 'self' "

    J'ai testé avec toutes les variations possibles, mais à partir du moment où la ligne commençant par "Header set Content-Security-Policy" est active, alors j'ai des blocages sur script-src et style-src sur les objets en... "self".

    Le problème est résolu en désactivant la règle complètement, ce qui n'est pas forcément idéal en terme de sécurité, mais, bon, flûte, au moins ça marche.

Connectez-vous ou Inscrivez-vous pour répondre.