Points d'interrogation dans les adresses

23 janv. modifié dans Plugins

Bonjour,

Mon blog ne fonctionne plus depuis quelques temps. Je viens de me replonger dedans, faire une mise à jour.
Le problème est que les liens mènent à une erreur 404. Et pour cause :
Voici un lien vers un article (indiqué dans l'article et affiché dans la barre de lien du navigateur) : http://teoufouwak.perozeni.com/article94/et-aller-1-litre
Il mène à une erreur 404
Pour que le lien fonctionne, il faut ajouter un ? devant article :
http://teoufouwak.perozeni.com/?article94/et-aller-1-litre

La redirection d'URL est activée. Je ne peux pas modifié le paramètre car il me dit que le fichier .htaccess est inexistant. Lorsque j'en créé un, le site plante.

Auriez-vous une idée là-dessus ? Je ne trouve pas d'infos sur le net.

Merci.

Réponses

  • JoséJosé Member

    Cette question ressemble à celle que j'ai rencontrée récemment et traitée par l'équipe :
    https://forum.pluxml.org/discussion/6908/montee-de-version-5-6-a-5-8-4#latest

  • 24 janv. modifié

    Bonjour José,
    En effet, j'ai exactement le même problème. Le titre du post n'était pas vraiment explicite (montée de version: 5-6 à 5-8-4).
    Le problème est qu'il ne donne pas ses solutions.
    J'ai mis un fichier .htaccess (chmodé à 664) à la racine de mon site (teoufouwak) et un à la racine de mon domaine (/).
    J'ai mis ça dedans pour commencer :
    Options -Indexes


    Order Allow,Deny
    Deny from all


    Order Allow,Deny
    Deny from all

    Quand je désactive la réécriture des liens, il me dit que le fichier .htaccess n'existe pas ou n'est pas modifiable.
    Je suis chez OVH, si toute fois cela avait une importance.

  • JoséJosé Member

    J'avais suivi les recommandations de l'équipe. aujourd'hui j'ai supprimé tous les ?. cela fonctionne bien sur mon site

  • Et comment as-tu fait cela ?

  • JoséJosé Member

    C'était il y a un mois : une éternité...

    j'ai ré-écrit le .htaccess selon les conseils de Bazooka .

    # BEGIN -- Pluxml
    Options -Multiviews
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f 
    RewriteCond %{REQUEST_FILENAME} !-d 
    RewriteCond %{REQUEST_FILENAME} !-l 
    # Réécriture des urls
    RewriteRule ^(?!feed)(.*)$ index.php?$1 [L] 
    RewriteRule ^feed\/(.*)$ feed.php?$1 [L] 
    </IfModule>
    # END -- Pluxml
    

    Mes liens internes étaient incomplets , je les ai ré-écrits en faisant figurer le nom de l'article en bout de lien

    <a href="article2/richard-coeur-de-lion"  >
    
  • Merci José. Ca marche. Mais parce que j'avais cette ligne : RewriteBase /pluxml/.
    J'ai changé en RewriteBase / et c'est tout bon.

    Merci encore et bonne continuation.

  • JoséJosé Member

    Super! j'ai simplement fait passer les informations que m'avait transmises Bazooka

Connectez-vous ou Inscrivez-vous pour répondre.