Ou Telecharger Anciene Version (Migration de Dotclear >> Pluxml 5.1.1)

Bonjour,

Je souhaiterai utiliser le plugin Dotclear2Pluxml, ceci dans le but de migrer mon Blog.
http://www.blogoflip.fr/?article63/plugin-dotclear2pluxml

Ce plugin étant compatible uniquement pour les version de PluXml < 5.x, je souhaiterai télécharger une anciene version de PluXml (ex : PluXml 4.3.1).

Apres avoir fait l’export en 4.3.1, je ferais les mise a jour vers la 5.1.1.

Pour la dernière version publié c'est par ici (actuellement 5.1.1), mais impossible de trouver une ancienne version < 5:
http://telechargements.pluxml.org/download.php

QUESTIONS :
1) Ou puis je télécharger les anciennes version de PluXml ?
2) Avez vous une autre méthode pour migrer de Dotclear 2 vers PluXml 5.1.1.

Bonne soirée @ Tous ;o)

Réponses

  • Oups !!! doublon

    Il faut rebondir sur ce post : http://forum.pluxml.org/viewtopic.php?id=2137

    Mais cela n'est toujours pas gagné, d’après la date du dernier post 03/12/2010 09:03:22
  • StéphaneStéphane Membres, Ancien responsable de PluXml
    Bonjour

    Les anciennes versions ne sont pas téléchargeables.
    Je t'enverrai la version 4.3.1 ce soir par email

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • StéphaneStéphane Membres, Ancien responsable de PluXml
    C'est envoyé

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Merci Stephane pour le suivit ;O)

    Pour les suivants passant par ici : le plugin de migration Dotclear >> PluXml (4.3.1) n'a pas fonctionné.
    Pour l'instant je reste en standby et n'ayant pas les capacitees pour modifier le plugin de migration je l'orgne sur le la nouvelle section "PLUGINS" du forum ;O)

    Petit clin d'oeil du forum Hardware.fr topic DockStar : http://forum.hardware.fr/hfr/OSAlternatifs/Hardware-2/seagate-dockstar-computer-sujet_71314_60.htm#t1285214

    Bonne continuation @ toute l’équipe.
  • @Stéphane, j'ai fait une migration de mon site en local de Wordpress vers Dotclear, il ne reste plus que réaliser la migration vers PluXml pour tester. :P

    Même demande que l e . n o x, si tu as une archive de PluXml < à la version 5, je suis preneur. ;)
  • Merci l e . n o x pour la 4.3.1 de PluXml par mail. ;) sympa. :)
    Le script ne semble fonctionner qu'avec des versions antérieures à 4.1. :/

    J'ai une erreur :
    Deprecated: Assigning the return value of new by reference is deprecated in C:\wamp_bis\www\dotclear\pluxml\plugins\dotclear2pluxml\prepend.php on line 42
    
    Fatal error: Class 'plxDate' not found in C:\wamp_bis\www\dotclear\pluxml\core\lib\class.plx.motor.php on line 56
    
    J'ai commenté les lignes 45 à 49 sur prepend.php, car je n'ai pas besoin d’authentification (je suis en local).
    J'ai bien le formulaire qui apparaît et je peux saisir les données. :)

    Mais le script bloque sur 3 lignes dans le fichier "dotclear2pluxml.php" en utilisation la méthode SQL :

    Ligne 97 : Ajout des catégories - Call to a member function editArticle() :
    $plxAdmin->editCategories(plxUtils::unSlash($data));
    
    Ligne 128 : Ajout des articles - Call to a member function editArticle() :
    $plxAdmin->editArticle($data, $data['artId']);
    
    Ligne 147 : Ajout des commentaires - Call to a member function addCommentaire() :
    $plxAdmin->addCommentaire($filename,$datacom['author'],$datacom['ip'],$datacom['mail'],$datacom['site'],$datacom['content']);
    
    Des idées ? :/ Je connais par les classes php de PluXml.

    Peut être avec un version plus ancienne. :|
  • Bonnes nouvelles l e . n o x !! :D

    Ne pouvant pas attendre. J'ai fait une recherche d'une version 4.1 sur Google.
    J'ai téléchargé un PluXml 4.1 (modifié en rewrite). :)

    J'ai installé cette archive sans installer le rewrite d'url (case à cocher). J'ai eu pas mal de "Deprecated: Assigning the return value of new by reference is deprecated". J'en ai pas tenu compte. :P

    Mais la migration a fonctionné.

    J'ai récupéré mes commentaires, mes catégories, mais pas les comptes des 700 utilisateurs.
    Pour les comptes users, ça ne gène pas. Je pense garder que les comptes rédacteurs (Mon Fluxbb fera les reste).
    D'ailleurs je demande si cette version 4.1 était multi-utilisateurs ? :rolleyes:

    Dernière étape, je vais tester l'upgrade vers la 5.1.2.

    @Stéphane as-tu dans tes cartons un PluXml 4.1 plus propre que celui là. ;)
  • StéphaneStéphane Membres, Ancien responsable de PluXml
    @Bloody

    - la 4.1 n'était pas multi-utilisateur
    - oui j'ai les anciennes versions de PluXml. Je t'en ai mailé quelques unes ;)
    - pour les erreurs deprecated, il suffit dans certains cas de supprimer le caractère & dans le code

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • l e . n o xl e . n o x Membres
    juillet 2011 modifié
    Chouet Chouet tout ça ;O)

    Donc si j'ai tout bien suivit :

    1) Installation version 4.1 (et non 4.3.1) + dotclear2pluxml.
    2) Migration de dotclear
    3) Upgrade de 4.1 vers 5.1.2 (la migration 4.1 > 5.1.2 sans passé par les versions intermédiaires est elle possible ?)

    Question & idée :
    Est il possible d'avoir une version 4.1 patché avec dotclear2pluxml directement ?
    Cette version "4.1ByByDotclear" devrait être castré , pas de possibilité de créer de nouveau post en manuel et n’autoriser uniquement la migration vers la version Uptodate de Pluxml.
    Cela éviterai de recréer un plugin "dotclear2pluxml V2".

    Je suis preneur de la version 4.1 si vous avez quelques minutes ;) , il me tarde de retrouver mes anciens posts sous pluxml :)


    Merci @ Bloody et Stephane.
  • C'est la bonne procédure. :)
    Après la migration, je conseille de ré-enregistrer tes paramètres de blog pour rafraîchir le fichier parametres.xml.

    L'upgrade de PluXml va te proposer de passer directement à 4.3 (même si tu es sous 4.1) et en 1 éclair tu seras sous la 5.1.2. :lol:

    Le fichier 4.1 est sur cette page (1er lien) : http://doc-css.com/urw-pluxml/categorie1/rubrique-1

    Merci Stéphane pour ton mail. ;) Mais les 4.1 étaient en béta et ça n'a pas fonctionné. :/

    Le . n o x, je te conseille de le faire en local. J'ai certain posts en ligne qui ont vus leur apostrophe transformé en ?.
    Par contre, je n'ai pas récupéré mes tags. :(

    Ta suggestion est bonne, mais je ne pense pas que Stéphane est le temps pour recoder une ancienne version. Ou si alors faire un redirection de header vers le plugin directement.

    Un truc du genre :
    header('Location: http://www.url-de-pluxml/plugins/dotclear2pluxml.php');
    
    Je ne sais si c'est possible.

    Je vous met le lien vers mon site de test pour la migration pour voir le résultat : http://www.chantdeleau.com/dotclear/pluxml/ .

    Juste pour info :
    Ma migration : WordPress 3.2.1 > Dotclear 2.3.1 > PluXml 4.1 > PluXml 5.1.2. Normal, qu'il y ait qq pertes. :)

    Donc merci à FlipFlip pour le script de migration. ;)

    @Stéphane : Il ne reste plus que la gestion des sous-catégories soit possible sous PluXml et je migre. :P
  • Ravie qu'il puisse encore servir.

    J'ai un string de l'array

  • Moi aussi. ;)
    Ça été un peu laborieux, mais le résultat est là.
    Te souviens-tu si tu avais réussi à récupérer les tags ? :)
  • A l'époque de PluXml 4.x il me semble que les tags n'existaient pas donc je me suis jamais penché sur la question.

    J'ai un string de l'array

  • Exact, je ne m'en souvenais plus. :)
  • StéphaneStéphane Membres, Ancien responsable de PluXml
    Pas de tags pour les pluxml 4.x

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • l e . n o xl e . n o x Membres
    août 2011 modifié
    Bonjour,

    Bon c'est gagné voici quelques lignes pour les prochains petits copains ;O)

    Lien pour télécharger 4.1bybyDotclear : http://dl.free.fr/fYCvPOCud
    Cette version (4.1bybyDotclear) est la version Beta 4.1 + le plugins Dotclear2pluxml

    Voici la procedure que j'ai suivi pour migrer de dotclear 2.X vers Pluxml 5.1.2 :

    1) installation sur votre serveur de pluxml 4.1bybyDotclear.

    2) Suivre ce lien pour vous identifier en mode administration :

    http://www.votresite/core/admin/

    3) Dans un autre onglet, Aller sur la page du plugin "Dotclear2pluxml" :

    http://www.votresite/plugins/dotclear2pluxmlr

    4) Suivre les indications du plugin. (NB : favoriser la migration en "localhost" cela evite en effet pas mal de problème).

    Et voila la migration de dotclear est faite, il ne reste plus qu'a mettre a jour pluxml + recréer les liens internes photo/video/etc ...


    5) Nous allons donc effectuer l' upgrade de version de pluxml maintenant, telecharger la derniere version : ICI http://telechargements.pluxml.org/download.php

    6) Suivre la procedure officielle de mise a jour durant l'upgrade choisir la version 4.2 dans le menu deroulant.
    http://wiki.pluxml.org/index.php?page=Mettre+%C3%A0+jour

    7) Maintenant vous avez un pluxml en version 5.X avec vos anciens posts Dotclear.

    8) Perso, j'ai effectué une nouvelle installation toute fraiche de pluxml "up to date" et ensuite j'ai copie/colle tous les dossiers se trouvant dans .../pluxml/data (je ne suis pas sur que cette etape soit réellement necessaire !!)

    9) J'ai du recuperer les liens brises des differentes images de dotclear, jai procedé comme ceci sous linux via un terminal :

    Dans dotclear mes photos etaient dans : \dotclear\public

    Dans pluxml les photos sont dans : \data\images

    cd .../pluxml/data

    grep -rl "/data/images" *.xml | xargs sed -i 's/\/dotclear\/public\//data\/images\/g'

    Et donc avec tout ceci me voila avec un tout nouveau PluXml ;O)

    Bonne journée @ Tous et bonne migration
  • l e . n o xl e . n o x Membres
    août 2011 modifié
    Bonjour,

    Suite à la migration dotclear/Pluxml 5.1.2,

    Je viens de me rendre compte que les liens [archives] qui ont subit l'importation ne sont pas accessible.
    Les liens Archives 2010 à 2005 ne fonctionnement pas.
    Pour les billets des 3 derniers mois ils sont accessibles, ils on été édité directement avec pluxml, peut être une piste ....


    les liens ne fonctionnant pas sont de la forme (année uniquement): http://www../blog/pluxml/index.php?archives/2010

    les liens qui fonctionnent sont de la forme (année + mois): http://www../blog/pluxml/index.php?archives/2011/04

    1313161947.png

    voici le message erreur :

    Une erreur a été détectée :
    Aucun article pour cette page !



    Bonne continuation.
  • BloodyBloody Membres
    Idem pour moi. ;) Ce n'est pas un problème dû à la migration; mais un bug PluXml.
    Les archives mensuelles fonctionnent mais pas les annuelles.
    Je devais remonter le bug depuis 15 jours, mais je ne l'avais tjrs pas fait. :P

    J'ai ouvert une discussion : http://forum.pluxml.org/viewtopic.php?pid=19812#p19812

    Je vois sur ton screenshot que tu as aussi des articles qui datent. :D
Connectez-vous ou Inscrivez-vous pour répondre.