Sortie de PluXml 5.3

2»

Réponses

  • Kristen a écrit:
    Bonjour
    Parmi les nouveautés, je vois
    Parmi les nouveautés, vous trouverez au niveau de la gestion des thèmes:
    une meilleure gestion de l'affichage des groupes des pages statiques pour permettre de faire des menus déroulants plus facilement (via jquery par exemple) : fonction staticList()
    vu ici
    Ça veut dire quoi? Je ne comprends pas trop :rolleyes:
    Qu'on peut avoir un menu déroulant en "natif"? Si oui, on fait comment, je plane?
    Merci

    Voilà pour répondre. Le code html généré pour hiérarchiser les pages statiques par groupe a été revu pour pouvoir l'utiliser avec jQuery et faire des menus déroulants plus facilement: http://goo.gl/IQcQp5

    Consultant PluXml

    Ancien responsable du projet

  • Jos a écrit:
    cpalo a écrit:
    Bonjour

    Le nouveau pluxml me plait bien.. et pas de bug pour le moment.

    Juste un tout petit détail dans le theme par défaut ( ce qui ne me pose pas pb puisque dans le mien j'ai corrigé), la balise blockquote n'a pas été définie. Et si on va en bas d ela page statique 1, on verra que la citation d eHal n'est pas en italique.

    Cordialement

    En effet, la balise blockquote est définie dans reset.css, mais elle n'estpas en italique. Un oublie de ma part. Je me le ,ote pour la prochaine version.

    Noté ici: issue #45

    Consultant PluXml

    Ancien responsable du projet

  • KristenKristen Membres
    janvier 2014 modifié
    Stéphane a écrit:
    Voilà pour répondre. Le code html généré pour hiérarchiser les pages statiques par groupe a été revu pour pouvoir l'utiliser avec jQuery et faire des menus déroulants plus facilement: http://goo.gl/IQcQp5
    Bonjour
    je viensd'essayer et ça me donne
        <nav role="navigation">
    
            <ul id="static-nav">
    
    <?li id="static-home"><?a href="http://lafouleefolgoatienne.site50.net/" class="active" title="Accueil">Accueil<?/a><?/li>
    <li>
    	<?a href="javascript:void(0)" class="static group">Le club<?/a>
    	<ul id="static-le-club">		
    		<?li id="static-1"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static1/entrainement" class="noactive" title="Entraînement">Entraînement<?/a><?/li>
    		<?li id="static-2"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static2/historique" class="noactive" title="Historique">Historique<?/a><?/li>
    		<?li id="static-3"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static3/conseil-dadministration" class="noactive" title="Conseil d’administration">Conseil d’administration<?/a><?/li>
    		<?li id="static-15"><?a href="http://lafouleefolgoatienne.site50.net/data/documents/fiche_renseignement.pdf" class="noactive" title="Adhésion">Adhésion<?/a><?/li>
    	</ul>
    </li>
    
    <li>
    	<?a href="javascript:void(0)" class="static group">La course<?/a>
    	<ul id="static-la-course">		
    		<?li id="static-4"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static4/presentation" class="noactive" title="Présentation">Présentation<?/a><?/li>
    		<?li id="static-5"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static5/reglement" class="noactive" title="Règlement">Règlement<?/a><?/li>
    		<?li id="static-6"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static6/inscription" class="noactive" title="Inscription">Inscription<?/a><?/li>
    		<?li id="static-7"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static7/programme" class="noactive" title="Programme">Programme<?/a><?/li>
    	</ul>
    </li>
    
    <?li id="static-14"><?a href="http://lafouleefolgoatienne.site50.net/piwigo/" class="noactive" title="Photos">Photos<?/a><?/li>
    <?li id="static-11"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static11/presse" class="noactive" title="Presse">Presse<?/a><?/li>
    <?li id="static-8"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static8/regles-d-or" class="noactive" title="Règles d&#039;or">Règles d&#039;or<?/a><?/li>
    <?li id="static-13"><?a href="http://lafouleefolgoatienne.site50.net/index.php?contact" class="noactive" title="Contact">Contact<?/a><?/li>
       
                        </ul>
    
        </nav>
    
    ?????
  • @Kristen: y a une coquille dans le code à remplacer dans le fichier header.php

    voilà le bon
    <?php 
        $plxShow->staticList(
            $plxShow->getLang('HOME'),
            '<li id="#static_id"><?a href="#static_url" class="#static_status" title="#static_name">#static_name<?/a></li>', 
            '<a href="javascript:void(0)" class="#group_class">#group_name</a>'
        ); 
    ?> 
    

    Désolé, c'est ma faute

    Consultant PluXml

    Ancien responsable du projet

  • pas la peine d'être désolé avec le boulot que tu nous fournis, tu es excusé d'avance.
    Maintenant
    [== Indéfini ==]
    <nav role="navigation">
    
            <ul id="static-nav">	
    			
    <li id="static-home"><?a href="http://lafouleefolgoatienne.site50.net/" class="active" title="Accueil">Accueil<?/a></li>
    <li>
    	<a href="javascript:void(0)" class="static group">Le club</a>
    	<ul id="static-le-club">		
    		<li id="static-1"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static1/entrainement" class="noactive" title="Entraînement">Entraînement<?/a></li>
    		<li id="static-2"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static2/historique" class="noactive" title="Historique">Historique<?/a></li>
    		<li id="static-3"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static3/conseil-dadministration" class="noactive" title="Conseil d’administration">Conseil d’administration<?/a></li>
    		<li id="static-15"><?a href="http://lafouleefolgoatienne.site50.net/data/documents/fiche_renseignement.pdf" class="noactive" title="Adhésion">Adhésion<?/a></li>
    	</ul>
    </li>
    
    <li>
    	<a href="javascript:void(0)" class="static group">La course</a>
    	<ul id="static-la-course">		
    		<li id="static-4"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static4/presentation" class="noactive" title="Présentation">Présentation<?/a></li>
    		<li id="static-5"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static5/reglement" class="noactive" title="Règlement">Règlement<?/a></li>
    		<li id="static-6"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static6/inscription" class="noactive" title="Inscription">Inscription<?/a></li>
    		<li id="static-7"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static7/programme" class="noactive" title="Programme">Programme<?/a></li>
    	</ul>
    </li>
    
    <li id="static-14"><?a href="http://lafouleefolgoatienne.site50.net/piwigo/" class="noactive" title="Photos">Photos<?/a></li>
    <li id="static-11"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static11/presse" class="noactive" title="Presse">Presse<?/a></li>
    <li id="static-8"><?a href="http://lafouleefolgoatienne.site50.net/index.php?static8/regles-d-or" class="noactive" title="Règles d&#039;or">Règles d&#039;or<?/a></li>
    <li id="static-13"><?a href="http://lafouleefolgoatienne.site50.net/index.php?contact" class="noactive" title="Contact">Contact<?/a></li>
     
                        </ul>
    
        </nav>
    
  • KristenKristen Membres
    janvier 2014 modifié
    j'ai trouvé en regardant ton nouveau code pour voir cequi avait changé. Donc ça marche avec
    ?php 
    	$plxShow->staticList(
    	$plxShow->getLang('HOME'),
    		'<li id="#static_id"><a href="#static_url" class="#static_status" title="#static_name">#static_name</a></li>', 
    		'<a href="javascript:void(0)" class="#group_class">#group_name</a>'
    	); 
    ?> 
    
    Grand merci :)
  • Super merci. ça me rassure que cela fonctionne :p

    Consultant PluXml

    Ancien responsable du projet

  • Bonjour à tous,

    Tout d'abord merci pour votre CMS, ça fait maintenant un petit moment que je le pratique pour mon site perso et il correspond parfaitement à mes attentes.

    Par contre, je ne sais pas si c'est un problème ou si c'est normal mais, lors d'une nouvelle installation, il y a un article par défaut avec un commentaire.
    Quand je désactive les commentaires dans "paramètres" => "Configuration de base", je n'arrive plus à accéder à la page d'administration des commentaires et donc à supprimer ce dernier. Est ce un fonctionnement normal ?!?

    Merci encore
  • @ReSpAwN: Il y a bien dans le code de PluXml une restriction sur l'accès à l'écran d'administration des commentaires si les commentaires sont désactivés. Je vais creuser pour voir pourquoi ça a été mis en place. Peux-être un reliquat d'une ancienne version qui n'aurait plus lieu d'être maintenant car effectivement c'est un peu gênant de ne pas pouvoir accèder à cet écran.

    issue 51

    Consultant PluXml

    Ancien responsable du projet

  • iGoriGor Membres
    mars 2014 modifié
    De mon côté j'ai un problème pour la mise à jour :
    Aucun utilisateur présent dans le fichier data/configuration/passwords.xm
    

    Ce fichier n'existe pas. Et je n'en ai aucune trace dans mes backups.

    Pour la mise à jour, j'ai tout supprimé sauf /data /themes et aussi /plugins (j'en utilise deux). Après la copie des fichiers de la nouvelle version, je vais sur mon site, ce qui ouvre la page /update/index.php, je choisis l'ancienne version (5.2), lance le script, et obtiens l'erreur ci-dessus.

    J'ai trouvé la trace d'un problème similaire en 2011, pour une mise à jour vers la 5.1.3., mais il n'y a pas beaucoup d'informations : http://forum.pluxml.org/viewtopic.php?pid=21438

    Faut-il désactiver les plugins pour la mise à jour ?

    [edit] Même comportement avec les plugins désactivés avant la mise à jour.
  • @iGor
    Peux-tu essayer ceci: si ton PluXml avant mise à jour est une version 5.2 édite le fichier data/configuration/parametres.xml , recherche la ligne <version>....</version> et modifie la de manière à avoir <version>5.2</version> et vérifie que dans le fichier /version il y ait bien écrit dedans 5.2

    Consultant PluXml

    Ancien responsable du projet

  • iGoriGor Membres
    Le fichier /version indique bien 5.2

    Dans le fichier /data/configuration/parametres.xml j'ai à la ligne 39
    <parametre name="version"><![CDATA[5.2]]></parametre>
    
    . En réalité, il y avait un retour à la ligne après le 5.2, mais ça ne devrait pas être le problème, non ?

    Et il faudrait que je modifie cette ligne pour obtenir
    <parametre name="version">5.2</parametre>
    
    c'est ça ? Parce que de passer carrément à
    <version>5.2</version>
    
    me met dans le doute. :)
  • oui oui pardon c'est bien
    <parametre name="version">5.2</parametre>
    

    qu'il faut mettre. Désolé

    Consultant PluXml

    Ancien responsable du projet

  • iGoriGor Membres
    Ok, tout a effectivement bien fonctionné cette fois. Merci beaucoup ! Et bon dimanche ! :)
Connectez-vous ou Inscrivez-vous pour répondre.