[Thème] Responsee

flipflipflipflip Membre
octobre 2017 modifié dans Vos créations
Bonjour à tous,

Je me suis basé sur le thème de base proposé par http://www.myresponsee.com/ et tant qu'à faire j'ai utilisé leurs framework css.

header_responsee.jpg

theme-responsee-small-medium.jpg

Démo : http://www.blogoflip.fr
Dépôt : https://github.com/Philippe-M/responsee/
Télécharger : https://github.com/Philippe-M/responsee/releases ou http://ressources.pluxml.org/?theme159/theme-responsee

Les photos fourni dans le thème sont ma propriété, vous pouvez les utiliser sur votre site mais vous ne pouvez pas supprimer la signature ni même modifier ou ré-utiliser les photos pour autre chose.

Plugin BlogRoll
Afin de pouvoir afficher une icône spécifique devant chaque liens gérés par le plugin BlogRoll j'ai apporté une modification à ce dernier. J'ai ajouté un paramètre supplémentaire : class. Il permet de donner le nom de l'icône qui sera utilisé, voir liste ici : https://www.myresponsee.com/responsive-framework-doc/font-icon-set/. L'installation se passe comme tout plugin. Copier le répertoire Blogroll du thème dans le répertoire plugins de votre pluxml.
Changelog a écrit:
18/10/2017 - 7.1
[UPDATE] Mise à jour pour PluXml 5.6 https://github.com/Philippe-M/responsee/issues/28
[ADD] Bouton pour remonter en haut de la page https://github.com/Philippe-M/responsee/issues/18
[ADD] Ajout des balises og:type https://github.com/Philippe-M/responsee/issues/20
[ADD] Ajout de la balis og:images Fixes https://github.com/Philippe-M/responsee/issues/21
[ADD] minification css Fixes https://github.com/Philippe-M/responsee/issues/22
[ADD] Ajout des balises title et alt au slideshow https://github.com/Philippe-M/responsee/issues/23
[ADD] Ajout des balises title et alt au background https://github.com/Philippe-M/responsee/issues/24
[BUG] Ajout de la traduction "ARTICLES_DATE_UPDATE", merci ouafnico, https://github.com/Philippe-M/responsee/issues/25
[BUG] Erreur de redirection http vers https https://github.com/Philippe-M/responsee/issues/27
[BUG] MIse à jour du @ https://github.com/Philippe-M/responsee/issues/29

13/09/2016 - 7.0
[ADD] Migration du framework css Myresponsee 2 vers la version 4 https://github.com/Philippe-M/responsee/issues/2
[ADD] Ajout d'un menu repliable pour les écrans small et medium https://github.com/Philippe-M/responsee/issues/14
[BUG] Correction de l'affichage des articles sur une page categorie https://github.com/Philippe-M/responsee/issues/15
[BUG] Correction de l'affichage des tags dans la sidebar https://github.com/Philippe-M/responsee/issues/16
[ADD] Integration du plugin Blogroll https://github.com/Philippe-M/responsee/issues/17

24/07/2016 - 6.4
[ADD] Ajout de la fonction de réponse aux commentaires depuis un article https://github.com/Philippe-M/responsee/issues/9
[ADD] Lien pour accéder directement aux commentaires depuis l'entête des articles https://github.com/Philippe-M/responsee/issues/10
[ADD] Le titre de l'article non cliquable lorsqu'on est sur un article https://github.com/Philippe-M/responsee/issues/11
[ADD] Ajout d'icônes dans les commentaires pour les informations (date, auteur...) https://github.com/Philippe-M/responsee/issues/12

09/06/2016 - 6.3
[BUG] Affichage de l'auteur deux fois sur la page archives https://github.com/Philippe-M/responsee/issues/4
[BUG] Ajout pour de vrai des fichiers infos.xml et preview.png https://github.com/Philippe-M/responsee/issues/3
[UPDATE] Mise à jour du fichier infos.xml https://github.com/Philippe-M/responsee/issues/1

15/05/2016 - 6.2
[UPDATE] la taglist passe du trie alpha à random http://forum.pluxml.org/viewtopic.php?pid=48859#p48859
[UPDATE] affichage de 30 tags au lieu de 20 dans la sidebar
[UPDATE] intégration de la police Abel et suppression de @import dans css/template-styles.css
[UPDATE] ajout du fichier preview.jpg et infos.xml

12/04/2016 - Version 6.1
[BUG] Couleur de la tagline

03/04/2016 - Version 6
[UPDATE] Update to pluxml 5.5
[UPDATE] Update Owl-caroussell
[BUG] Liste des tags après clic sur un tag dans le menu de gauche
[ADD] Marqueur AMP (google) pour le référencement

13/11/2014 - Version 5
Ajout du retour à la ligne automatique pour le texte entre les balises pre
Affichage des mots clés (tags) en liste en ligne dans la barre de menu à gauche avec une gestion de la taille suivant l'importance du tag

03/10/2014 - Version 4
Ajout de l'ancre pour accéder directement aux commentaires d'un article depuis la page d'accueil
Ajout de line-height: 1.8em dans le blockquote des commentaires

30/10/2014 - Version 3
Ajout du template pour le plugin plxMyContact
Mise à jour de la documentation

28/10/2014 - Version 2
Ajout d'icônes tags, commentaires, catégories dans les articles;
Ajout d'images pour le slideshow;
Quelques petites corrections.

20/10/2014 - Version 1 :
Adaptation du thème pour PluXml 5.3

J'ai un string de l'array

«13

Réponses

  • Beau travail, un de plus dans la collection des thèmes PluXml
  • Bien joué, très jolie.
  • J'aime bien. Petite correction : le lien vers la galerie devrait pointer vers galerie/albums plutôt que galerie où rien ne s'affiche.
  • Merci à vous.

    J'ai fais quelques corrections mais je n'ai pas encore eu le temps de les packager. Je m'en occupe ce soir.

    @Jerry Wham: la galerie est une page static qui renvoie vers une autre appli... Etonnant que t'est une page blanche toi car pour moi ça marche bien ce matin.

    J'ai un string de l'array

  • JosJos Membre
    Très jolie thème, bravo :)
  • tres bien ;)
    jolie integration bravo FlipFlip
  • superbe !!!
    :)
  • Sortie de la version 2

    J'ai un string de l'array

  • DenDen Membre
    octobre 2014 modifié
    Bonjour tout le monde,

    @flipflip

    Quand je clique sur aucun commentaire (sur mon téléphone cellulaire), tout le site prend la largeur du sidebar et il y a une grosse marge à droite.
    Avec la page 2 commentaires tout s'affiche bien. Avec la page contact, tout prend la largeur du sidebar plus marge à droite et (form) dépasse à droite.

    906454screen1.jpg

    318920screen2.jpg

    Pour le reste, tout est parfait. :)

    Merci!
  • @Den: j'ai fais le test avec mon téléphone android et firefox. Je n'ai pas le 1er problème mais avec chrome le problème est présent. En fait chrome affiche la totalité de la ligne entre le < pre > ce qui créé le débordement. Faut que je regarde comment activer le retour à la ligne automatiquement dans les balises pre.

    Pour le second problème, la page contact est un plugin. Pour mon site je vais pouvoir créer une version adapté du template pour le plugin que je pourrais inclure mais je ne sais pas trop si il y a un moyen de surcharger un template de plugin ?

    Merci pour tes retours.

    J'ai un string de l'array

  • DenDen Membre
    octobre 2014 modifié
    @flipflip

    J'ai le même problème avec le plugin plxMyContact qui ne s'adapte pas (responsive).
    Même chose avec le thème par défaut (partie aucun commentaire).

    J'ai changé la largeur de (form), pour l'instant...

    Les auteurs ont une suggestion?

    Merci!
  • Den : je te propose de continuer la discution du problème de template / plugin ici : http://forum.pluxml.org/viewtopic.php?pid=40467

    J'ai un string de l'array

  • Version 3 sortie ;)

    J'ai un string de l'array

  • @Den: pour faire suite à tes questions posées dans un autre post (http://forum.pluxml.org/viewtopic.php?pid=40503#p40503)
    Le problème de responsive me semble résolu. Pourrais-tu nous expliquer ce que tu as fait?
    J'ai tout simplement créé la version du template pour la page du formulaire adapté à mon thème. Je te laisse regarder sur la page https://github.com/Philippe-M/responsee/ qui explique comment faire.
    Pour ce qui est du dépassement quand tu ne cliques sur aucun commentaire (form) dans le premier article,
    Ce n'est pas lié au clic sur "Aucun commentaire", tu pourrais très bien cliquer sur le titre de l'article que tu arriverais au même résultat. Le dépassement est provoqué par le contenue de la balise pre que j'utilise pour afficher du code ou le changelog de mon thème. Je n'ai eu le temps de regarder comment activer le retour à la ligne automatique sur cette partie.

    Philippe.

    J'ai un string de l'array

  • Version 4 publié

    J'ai un string de l'array

  • J'aime beaucoup aussi ;)
  • Version 5.

    Merci Gwen :)

    J'ai un string de l'array

  • bonjour,
    Joli thème.
    Mais j'obtiens un merveilleux
    responsee a écrit:
    Le fichier cible de PluXml est introuvable (./themes/responsee/article-full-width.php) !

    Merci pour ton travail.
  • Merci doume, c'est normal que le fichier soit introuvable car il n'existe pas. Tu doit avoir un article ou une page statique qui utilise le fichier article-full-width.php. Le plus simple est de copier le fichier article.php en article-full-width.php, le plus compliqué modifier tes articles/pages concernées.

    De mon côté je vais ajouter dans la liste des bugs ton problème.

    J'ai un string de l'array

  • Regarde dans ton thème précédent s'il n'existe pas. Si c'est le cas; copie le dans le nouveau. Il est peut-être nécessaire au fonctionnement d'un plugin ?
  • Sortie de la version 6.0 pour pluxml 5.5

    J'ai un string de l'array

  • Mise à jour en 6.1

    J'ai un string de l'array

  • jmglzjmglz Membre
    Bonjour à tous,

    Je teste ce thème de @flipflip mise à jour en 6.1 pour la dernière version de PluXml et constate un problème quand je clic sur "mots clefs" j'ai l'alerte :
    [== Indéfini ==]
    arning: array_multisort(): Array sizes are inconsistent in /home/u180145288/public_html/core/lib/class.plx.show.php on line 1685
    
    

    Est-ce un bug ou que dois-je faire pour corriger l'anomalie ?

    Site test :

    http://www.uncoupdoeil.eu

    Merci
  • jmglzjmglz Membre
    avril 2016 modifié
    Code de lalerte semble incomplet (sur ipad) le voici à nouveau ci-dessous :

    "
    Warning: array_multisort(): Array sizes are inconsistent in /home/u180145288/public_html/core/lib/class.plx.show.php on line 1685
    "
  • flipflipflipflip Membre
    avril 2016 modifié
    [del]Je rencontre la même erreur que toi et c'est bien lié au thème, j'ai fais le test de passer sur le thème par défaut et l'erreur disparait.[/del]

    Je regarde ça rapidement.

    Après recherche c'est lié au mode de tri des tags fait par PluXml, dans le thème j'utilise alpha. Dans le thème par défaut il n'y a pas de contrainte de trie donc pas d'erreur. Je remonte le bug aux dev.

    J'ai un string de l'array

  • jmglzjmglz Membre
    avril 2016 modifié
    @flipflip

    Merci pour la réponse rapide et félicitations pour ce thème sympa (premier thème ancien à être mis à jour pour la nouvelle version de PluXml avec images d'accroches !)

    Je ne vois pas cette erreur sur ton site, tu n'es pas encore passé à la version PluXml 5.5 ?

    Une nouvelle version PluXml 5.5 corrigée sera t'elle mise en ligne ou la correction de ce bug sera faite à la prochaine version de PluXml 5.6 ?
  • J'ai désactivé l'affichage des erreurs sur mon serveur c'est pour ça que tu le vois pas... l'avantage d'avoir son propre serveur ;)

    Pour le moment on cherche la cause avec la team de PluXml, ensuite ça sera à eux de choisir le quand et comment corriger. Si tu veux suivre l'évolution du peut-être bug : http://forum.pluxml.org/viewtopic.php?id=5509

    Merci pour ton retour sur le thème :)

    J'ai un string de l'array

  • jmglzjmglz Membre
    Ok Merci :)

    Je vais suivre pour corriger l'anomalie de présentation du thème des que possible.
  • En attendant tu peux contourner le problème en modifiant le fichier sidebar.php du thème de cette manière :

    Remplace
    <?php $plxShow->tagList('<li class="tags #tag_size"><a href="#tag_url" title="#tag_name">#tag_name</a></li>', 30, 'alpha'); ?>
    

    Par
    <?php $plxShow->tagList('<li class="tags #tag_size"><a href="#tag_url" title="#tag_name">#tag_name</a></li>', 30, 'random'); ?>
    

    J'ai un string de l'array

  • jmglzjmglz Membre
    C'est fait, le site présente mieux et j'adopte ton thème !

    Merci
Connectez-vous ou Inscrivez-vous pour répondre.