Histoire de cache ?

Hola à tous, :)

Normalement, la modification d'un article ou page statique apparaît immédiatement à l'affichage, mais depuis quelques temps, je rencontre un problème qui ne m'est pas familier.

Même après plusieurs rafraîchissement de ma page, il faut attendre quelquefois quelques secondes ou minutes avant que mes modifications apparaissent.

Cela pourrait-il venir de mes navigateurs sous Ubuntu (Firefox et Chrome) ou faut-il aller chercher ailleurs la délivrance ?

Réponses

  • Je suis quasiment toujours sous Ubuntu et je n'ai jamais trop constaté ce phénomème
    Quelques fois des scripts ou des images un peu longs à télécharger sur des serveurs perdus au fin fond du net.

    Avec l'explorateur de code (touche F12 du navigateur), tu as l'onglet réseau pour voir l'url qui met "un temps de dingue" à télécharger.

    Sinon le lien vers ton site s'il est en ligne.
  • Merci pour ta réponse bazooka07.

    Ce qui est surprenant, c’est que le phénomène ne se produit pas systématiquement et toujours à la modification des pages et j'en soupçonnerais presque la vétusté de mon PC qui a tendance quelquefois à friser l'Alzheimer.

    L'URL de ce site est http://reseauk.info/eco-luchon/
  • Perso, je trouve que 5 erreurs 404, c'est un peu abusé :
    qb9L5e7.jpg
  • Fusionner les fichiers
    * site.css (375 octets)
    * style.css (295 octets)
    * avec defaut.css
    améliorera les choses

    nav.js : à insérer directement dans un des fichiers du thème (footer.php par ex.)
    idem wk.js
  • bazooka07bazooka07 Membres
    septembre 2018 modifié
    Le mime-type application/x-jjavascript pour http://reseauk.info/eco-luchon/plugins/gutuma/news/js/gadgets.js.php n'est pas correct
    il y une balise fermante </div> orpheline. Quelqu'un pour l'adopter ?

    lignes 4 et 24 téléchargent le même script. C'est beaucoup pour des gadgets
  • Hum !

    Je ne sais pas à quelle heure tu y a été mais j'avais "pour voir" désactivé plusieurs plugins il y a maintenant quelques heures.

    Il semble que quelques trucs m***dent et je vais éradiquer le maximum en particulier le thème blablaoo qui, quoi que bien sympathique, semble générer quelques erreurs.


  • Fusionner les fichiers
    * site.css (375 octets)
    * style.css (295 octets)
    * avec defaut.css
    améliorera les choses

    nav.js : à insérer directement dans un des fichiers du thème (footer.php par ex.)
    idem wk.js

    Houps ! C'est du Mandarin pour moi. Tu peux préciser . :)
    Le mime-type application/x-jjavascript pour http://reseauk.info/eco-luchon/plugins/ … ets.js.php n'est pas correct
    il y une balise fermante </div> orpheline. Quelqu'un pour l'adopter ?

    Point trouvé </div> l'orpheline ni sa sœur mais je n'ai pas encore bien cherché.

    Je vais travailler à cela ce soir.
  • Bon, j'ai activé le thème par défaut, désactivé le maximum de plugins et ne retrouve plus les erreurs du F12 mais ne sais toujours pas vraiment m'en servir. :8

    En tous cas, la modification d'une page apparaît tout de suite ou pas sans comprendre pourquoi et, je ne voudrais pas dire de bêtises mais il semble que que mon bug se produise sur les pages statiques.
  • Je pense avoir trouvé la cause de mon problème. Il semble que ce soit une histoire de cookies.

    Quand l'effet se produit (cela ne semble pas avoir enregistré ou a retardement), je vais voir les cookies de mon navigateur et vire celui correspondant à mon NDD.

    Et pof ! Cela revient.

    Une explication à ce phénomène et comment le contourner ?
Connectez-vous ou Inscrivez-vous pour répondre.