[5.1.7 et +]Boldy Thème avec Backend

FrédéricFrédéric Membres
mars 2013 modifié dans Vos créations
boldyplugin.png
[del]Voici un premier thème pour la 5.1 Bêta avec son Admin géré via Plugins.
je vous propose ce jolie thème "Boldy" de chez site5.com.[/del]


Edit du 15/02/2013:

Après quelques années, voici une belle mise à jour de ce fabuleux thème de Site5.com . ainsi que son plugin qui l'accompagne pour le personnaliser.
Le thème passe en version 1.2 et à complètement étais revu en html5.

Le plugin peux aussi vous servir sur d'autre thème (voir l'aide du plugin)

Niveau du plugin, vous pourrais :
- Modifier le logo en ayant au préalable envoyer celui-ci depuis le Gestionnaire de Médias.
- Donner un Nom à la balise ALT de ce logo.
- Afficher le Nom du site si aucun logo d'inséré.
- Afficher ou non du formulaire de contact + derniers tweets par défaut au pied de la page.
- Afficher des icônes des réseaux sociaux (Twitter, Facebook & LinkedIn).
- Ajouter ou non le dernier tweet de votre compte.
- Être contacter par le formulaire de contact,en fournissant une adresse Email en config.
- Ajouter ou non un texte de copyright à coté de celui de PluXml.
- Et enfin ajouter ou non l'ID de votre compte Google Analytics.


Mise à jour du 03/03/2013
- Modification de l'aide avec tout les hooks disponible à insérer dans votre thème


Comme vous pouvez le constater, l'affichage à été repensé pour une meilleur visibilité.


Téléchargement:

Boldy theme + admin plugin.zip <--> Infos + Démonstration
A+
«1

Réponses

  • Un aperçu du thème original ici.
    Un très beau thème bien adapté pour PluXml. Merci Fred

    Consultant PluXml

    Ancien responsable du projet

  • MichelMichel Membres
    février 2011 modifié
    Bonsoir,

    Est-il possible de mettre facilement un carousel sur la page d'accueil?

    Car malgré le téléchargement du thème le carousel ne s'affiche pas :
    http://www.mangazine-fr.com/

    L'idéal serait de pouvoir tout modifier depuis l'admin (images et texte).

    Merci pour votre travail!
  • mayonmayon Membres
    mai 2011 modifié
    Bonjour à tous,

    Ce thème convient parfaitement à mes besoins, c'est super ! Merci :)

    J'ai juste quelques petits soucis que je n'arrive pas à régler :
    - la zone de recherche ne fonctionne pas, pourtant j'ai bien intégré un formulaire de recherche dans la page static4
    - pour la rubrique catégories : le dernier article de chaque catégorie ne s'affiche pas, comment dois-je m'y prendre ?
    - pour le flux rss : ça ne fonctionne pas non plus et je ne sais pas où aller...
    - j'ai aussi ajouté un lien tumblr pour les liens réseaux sociaux mais quand je le survole j'ai "L_JOIN_TUMBLR" qui s'affiche et je souhaiterais "Suivez-nous sur Tumblr" comme pour Twitter mais je ne sais pas où changer ce paramètre !

    Quelqu'un pourrait-il m'éclairer ?

    => voir le site ici
  • AirWAirW Membres
    Bonsoir,

    Impossible de télécharger l'archive. Pourtant j'aimerais essayer ! Quelqu'un s'en occupe-t-il ?

    Merci !
  • bg62bg62 Membres
    Frédéric a écrit:
    Voici un premier thème pour la 5.1 Bêta avec son Admin géré via Plugins.
    je vous propose ce jolie thème "Boldy" de chez site5.com.[/url]
    A+
    salut
    les liens sont HS :)
  • AirWAirW Membres
    bg62 a écrit:
    Frédéric a écrit:
    Voici un premier thème pour la 5.1 Bêta avec son Admin géré via Plugins.
    je vous propose ce jolie thème "Boldy" de chez site5.com.[/url]
    A+
    salut
    les liens sont HS :)
    C'est bien qu'est-ce que que je dis !
    :(
  • SemosSemos Membres
    Merci bien :)
  • BloodyBloody Membres
    mai 2011 modifié
    mayon a écrit:
    - la zone de recherche ne fonctionne pas, pourtant j'ai bien intégré un formulaire de recherche dans la page static4
    - pour la rubrique catégories : le dernier article de chaque catégorie ne s'affiche pas, comment dois-je m'y prendre ?
    - pour le flux rss : ça ne fonctionne pas non plus et je ne sais pas où aller...
    Salut chère compatriote, ;)

    Le formulaire en header effectivement ne fonctionne pas. J'ai pour l'instant mis un en sidebar (cf wiki) et il fonctionne parfaitement.

    Idem que pour toi pour les catégories, je ne comprend en il affiche n-1 articles. J'ai testé avec une catégorie vide, le message est bon. Je ne comprend pas. :/

    Par contre, le RSS fonctionne parfaitement. :)

    Pour ton lien lien tumblr, je me poserai la question quand je placerai mon lien Viadeo. :)

    Je te donne le lien du site (en GROS CHANTIER de modifications de thème). :P, c'est .
  • HamtaroHamtaro Membres
    mayon a écrit:
    Je vous le mets à disposition "chez moi" => ici
    Chose qui n'a aucun rapport :
    Faudrait voir à ne pas s'approprier le travail des autres...
    cf http://boudermarion.fr/yon/

    En bas... Je te rappelle que le design n'est pas de toi (ni de moi)... Belle utilisation du travail des autres...

    Je suppose qu'il s'agit d'une erreur de ta part. ;)
  • mayonmayon Membres
    Hamtaro a écrit:
    chose qui n'a aucun rapport :
    Faudrait voir à ne pas s'approprier le travail des autres...
    cf http://boudermarion.fr/yon/

    En bas... Je te rappelle que le design n'est pas de toi (ni de moi)... Belle utilisation du travail des autres...

    Je suppose qu'il s'agit d'une erreur de ta part. ;)
    ah oui autant pour moi j'ai buggé, j'avais fait un copié/collé d'un autre footer, je vais changer ça tout de suite ! Merci pour la remarque judicieuse ;)
  • mayonmayon Membres
    Bloody a écrit:
    Salut chère compatriote, ;)

    Le formulaire en header effectivement ne fonctionne pas. J'ai pour l'instant mis un en sidebar (cf wiki) et il fonctionne parfaitement.

    Idem que pour toi pour les catégories, je ne comprend en il affiche n-1 articles. J'ai testé avec une catégorie vide, le message est bon. Je ne comprend pas. :/

    Par contre, le RSS fonctionne parfaitement. :)

    Pour ton lien lien tumblr, je me poserai la question quand je placerai mon lien Viadeo. :)

    Je te donne le lien du site (en GROS CHANTIER de modifications de thème). :P, c'est .
    Salut voisin,

    Pour le formulaire je vais le désactiver pour l'instant !

    Pour les articles ça me le fait sous d'autres thèmes (adaptés ou créés), je ne vois pas pourquoi non plus ;)

    Pour les flux ça fonctionne ! Et pour le lien Tumblr, je continuerais mes recherches ultérieurement !

    Pas mal les couleurs de ton portfolio, bonne adaptation ! Pour info tu as des liens qui sont toujours en bleu tu devrais changer avec le vert, ça serait plus harmonieux ;)
  • BloodyBloody Membres
    Pour le formulaire de recherche en header, voici le code a placé.
    <div id="topSearch">
    				<form method="post" id="searchform" action="<?php $plxShow->urlRewrite('?static7/rechercher') ?>">
    					<input type="hidden" name="search" value="search"  />
    					<input type="text" class="searchfield" name="searchfield" value="Rechercher..." onblur="if(this.value=='') this.value='Rechercher...';" onfocus="if(this.value=='Rechercher...') this.value='';" /> 
    				</form>
    </div>
    
    "static7/rechercher" étant ma page d'affichage des résultats.
    Pour info tu as des liens qui sont toujours en bleu tu devrais changer avec le vert, ça serait plus harmonieux
    Merci, j'avais vu. ;) Mais une couleur de lien, c'est vite réglé. Comme, je l'ai dis c'est un chantier. :D C'est déjà réglé. :P

    Pour les articles, j'ai essayer avec la technique du wiki et j'ai aussi le même résultat. Peut être un problème dans cette version de Pluxml. :/
  • BloodyBloody Membres
    Petite contribution. :)

    Sur le thème original Boldy, il existe une page "Portfolio" (la partie CSS est déjà existante dans l’adaptation).

    Je vous met le code de la page categorie-porfolio.php que vous devez créer.
    <?php include(dirname(__FILE__).'/header.php'); # On insere le header ?>
    	<div id="colFull">
    
    		<h1>Portfolio</h1>
    		<ul class="portfolioCategs">
    			<?php $plxShow->pageBlog('<li><a href="#page_url" title="#page_name">Tout projets</a>'); ?>
    			<?php $plxShow->catList('','<li><a href="#cat_url" title="#cat_name">#cat_name</a></li>'); ?>
    		</ul>
    
    	<div style="clear:both"></div>
    			<div class="gallery">
    					<?php while($plxShow->plxMotor->plxRecord_arts->loop()): # On boucle sur les articles ?>
    					<div class="portfolioItem">
    						<h2><?php $plxShow->artTitle('link'); ?></h2>
    							<?php ob_start(); 
    							$plxShow->artContent($chapo=true);
    							$content = ob_get_clean();
    							$masque = '#<img.+src="(.+?)"#i'; preg_match($masque, $content, $resultats);
    							$extension = pathinfo($resultats[1], PATHINFO_EXTENSION); ?>
                        
    							<?php if($extension['extension'] == ('jpg'||'jpeg'||'png'||'gif')) : ?>
    							
    							<a href="/<?php echo $resultats[1]; ?>" rel="prettyPhoto" title="<?php $plxShow->artTitle(''); ?>">        
    							<img src="<?php $plxShow->template(); ?>/timthumb.php?src=<?php echo $resultats[1]; ?>&w=300&h=200&zc=1&q=100" alt="<?php $plxShow->artTitle(''); ?>" width="300px" height="200px" class="img_border" />
    							</a>
    						
    							<?php else : ?>
    							<a href="<?php $plxShow->template(); ?>/images/nothumb.jpg" rel="prettyPhoto" title="<?php $plxShow->artTitle(''); ?>">        
    							<img src="<?php $plxShow->template(); ?>/timthumb.php?src=<?php $plxShow->template(); ?>/images/nothumb.jpg&w=300&h=200&zc=1&q=100" alt="<?php $plxShow->artTitle(''); ?>" width="300px" height="200px" class="img_border" /></a>
    							</a>
    							
    							<?php endif; ?>							
    							<p><?php $plxShow->artChapo(); ?></p>
    					</div>
    		<!-- End .gallery -->
    		<?php endwhile; # Fin de la boucle sur les articles ?>
    		</div>
    		<div style="clear:both"></div>
    <?php # On affiche la pagination ?>
    		<p id="pagination"><?php $plxShow->pagination(); ?></p>
    <?php include(dirname(__FILE__).'/footer.php'); # On insere le footer ?>
    
    Requis :
    - Il vous faut placer à la racine de votre thème le fichier timthumb.php (téléchargeable : http://timthumb.googlecode.com/svn/trunk/timthumb.php).
    - En l'absence d'image dans votre article, il est faut mettre dans le répertoire "images" de votre thème un fichier nommé "nothumb.jpg" ou tout nom mais modifier la fin du script dans ce cas. :)

    Merci à Hamtaro pour son aide sur l'usage de timthumb. :P

    Faites en bonne usage. ;)

    J'oubliai la page de démo du thème original : http://wordpress.site5.net/boldy/?cat=24
  • neFASTneFAST Membres
    Bonjour, est-ce qu'un lien de télécharment valide existe quelque part ?
    Merci !
  • BloodyBloody Membres
    @neFAST : Mail bien reçu. Merci pour tes commentaires. ;)
    Pour le thème de mon portfolio est en partie une adaptation du Boldy de Michel. Le reste est totalement perso. :P

    J'ai posté un article sur mon blog pour que tout le monde puisse télécharger ce thème. :)
    C'est là : http://portfolio.chantdeleau.com/article33/theme-boldy-pour-pluxml
  • neFASTneFAST Membres
    Mes plus vifs remerciements ! :)
  • Bonjour à tous !
    Michel a écrit:
    Car malgré le téléchargement du thème le carousel ne s'affiche pas :
    mayon a écrit:
    - pour la rubrique catégories : le dernier article de chaque catégorie ne s'affiche pas, comment dois-je m'y prendre ?
    Ces 2 questions ont peut-être été résolues en dehors du forum : quelqu'un aurait-il une ou des réponses ? (Où trouver le Nivo Slider et comment le mettre en oeuvre ? (est-ce un plugin ?) par exemple...)

    Merci !
  • 2ème salve :

    Quels sont les droits concernant ce thème ? Jusqu'à quel point peut-on le modifier ? Quelles mentions doivent rester apparentes? (Site5, j'imagine...)
  • Le carrousel s'affiche très bien. Bien lire la doc. :)
    Pour trouver Nivo Slider, Google existe. Attention, la version 2 est sous licence pour un usage commercial.

    Pour les droits, tu as ta réponse car il a été adapté pour PluXml. ;) Pour ma part, je l'ai mis dans ma [url= http://portfolio.chantdeleau.com/static16/credits ]page de crédits[/url].
  • Bloody a écrit:
    Le carrousel s'affiche très bien. Bien lire la doc. :)
    Pour trouver Nivo Slider, Google existe. Attention, la version 2 est sous licence pour un usage commercial.
    Voilà donc le problème ! Effectivement, je n'ai pas lu la doc... mais je ne l'ai pas non plus trouvée ! Je ne l'ai pas vue dans l'archive...
  • Bloody a écrit:
    Le carrousel s'affiche très bien. Bien lire la doc. :)
    Pour trouver Nivo Slider, Google existe.
    problème : malgré tout son efficacité "portfolio.chantdeleau.com/index.php"
    tu as une idée du 'comment' du 'pourquoi' ... ? ;)
  • @bg62 : Je ne comprend pas ce que tu veux demander. :/

    Nivo Slider 2 : http://nivo.dev7studios.com

    Pour le slider, la doc du slider est ici : http://nivo.dev7studios.com/support/jquery-plugin-usage/

    @AirW : Quel est ton problème exactement ? Peux-tu faire un C/C du code que tu as placé pour le slider ? :)
  • Je vous donne le code à adapter à votre thème. :)
    <!-- BEGIN SLIDER -->
    	<div id="slider">
    	  	<a href="http://votre-lien-vers-votre-article-1"><img class="alignnone size-full wp-image-254" "Titre caption 1" src="<?php $plxShow->template(); ?>/images/samples/sample1.png" alt="" width="960" height="370" /></a>
    	  	
    	  	<a href="http://portfolio.chantdeleau.com/article10/communaute-chantdeleau-com-version-4"><img class="alignnone size-full wp-image-255" title="Refonte du site Chantdeleau.com et intégration sous Wordpress/Fluxbb." src="<?php $plxShow->template(); ?>/images/samples/sample2.png" alt="" width="960" height="370" /></a>
    
    	  	<a href="http://votre-lien-vers-votre-article-2"><img class="alignnone size-full wp-image-256" title="Titre caption2" src="<?php $plxShow->template(); ?>/images/samples/sample3.png" alt="" width="960" height="370" /></a>
    
    	  	<a href="http://votre-lien-vers-votre article-3"><img class="alignnone size-full wp-image-256" title="Titre caption 3" src="<?php $plxShow->template(); ?>/images/samples/sample4.png" alt="" width="960" height="370" /></a>		
    	</div>
    
    	   <div style="width:960px; margin:0 auto; background:url(<?php $plxShow->template(); ?>/images/bk_shadow_slider.png) 0 0 no-repeat; height:50px;"></div>
    <!-- END SLIDER -->
    
  • Bloody a écrit:
    @bg62 : Je ne comprend pas ce que tu veux demander. :/
    ben je voudrais savoir ... si tu cherches des claques !!! ;)
    - ton url principale :
    dans le code source :
    "<meta name="googlebot" content="noindex,noarchive,follow,noodp" />
    ...
    <meta name="robots" content="noindex,follow" />

    <meta name="msnbot" content="noindex,follow" />"
    dans le 'wordpress ...
    1650 pages dans google ... et résultat : un PR = inconnu (même pas '0')
    ton 'portfolio', s'il est bien déclaré en sous domaine, ne comportant pas de changement de balises en est au même point , 343 dans google et le PR est bloqué ... !!!
    cherches ici :
    http://www.google.fr/#hl=fr&sugexp=gsis%2Ci18n%3Dtrue&cp=14&gs_id=37&xhr=t&q=le+chant+de+l%27eau&pq=site%3Aportfolio.chantdeleau.com&pf=p&sclient=psy&source=hp&pbx=1&oq=le+chant+de+l%27&aq=0&aqi=g5&aql=&gs_sm=&gs_upl=&bav=on.2,or.r_gc.r_pw.&fp=63bf063c9eb94920&biw=1366&bih=636
    tu es où résultat ???
    tu en as quelques unes qui passent au travers, relayées par feedburner, oou les pings de wordpress qui sont passés au traveers ou ton 'annuaire' et quelques babioles, mais ton site devrait être beaucoup lieux positionné et "référencé" que ça, avec au moins un PR de 3 voire 4 ....
    à moins que cette série de 'noindex' ne soit volontaire ????
    m'étonnerait quand même
    @+
  • Merci bg62. ;)

    Un C/C malheureux. :/

    Sur pagerank.fr, je suis en PR3 sur le site principal. Mais j'ai baissé, j'étais à 4 à cause de ce C/C, il y a 1 mois. Ça aurait pu être pire. J'ai été sauvé, car au-dessus j'avais : :)
    <meta name="googlebot" content="all,index,follow" />
    <meta name="robots" content="all,index,follow" />
    <meta name="msnbot" content="all,index,follow" />
    
    Pour le sous-domaine sous PluXml, je suis en PR2. Je ne sais pas où tu as eu un PR inconnu.
    Je viens de mettre les mêmes méta que ci-dessus en Head. Espérons que ça change.

    Eh non, ce n'était pas volontaire. :P

    Encore merci pour avoir fait ton curieux en regardant le code généré. ;)
  • pas de problèmes ça arrive, mais les balises en double ont mis un certain petit baZard dans les datacenters de google ... il va te falloir en 'remettre' un p'tit coup pour faire remonter tout cela ;)
    il reste quand même parfois des problèmes d'accés directement liés au serveur ... va falloir que tu vérifies et que tu suives ... (un coup oui, un coup non ...)
    c'est pour ce genre de problèmes que je voulais faire un "post" ou une rubrique 'référencement' car il peut arriver tellement de choses ...
    bon, enfin le principal est que tu as pu corriger, ça reviendra ensuite dans l'ordre
    @+
  • bg62 a écrit:
    il reste quand même parfois des problèmes d'accés directement liés au serveur ... va falloir que tu vérifies et que tu suives ... (un coup oui, un coup non ...
    A quoi, tu vois ça. Ou plutôt, quels outils tu utilises ? :)
  • Bloody a écrit:
    bg62 a écrit:
    il reste quand même parfois des problèmes d'accés directement liés au serveur ... va falloir que tu vérifies et que tu suives ... (un coup oui, un coup non ...
    A quoi, tu vois ça. Ou plutôt, quels outils tu utilises ? :)
    nettoies un bon coup ton cache et revérifies ton PR sur le même site par exemple ... il rame avant de le trouver ;)
    sur pas mal d'outils de recherche du PR, rien n'apparaît ... donc il y a un bug qq part ...
    essaies simplement pour voir "seobook" plugin pour ff tu verras, ce n'est pas le top mais ... pour ton PR lui aussi a des problèmes ...
    testes ici également:
    http://www.unesourisetmoi.info/pages/multiple_PR_datas_centers.php
    pas normal que ça rame comme ça ....
    @+
  • Je vide le cache tjrs après une modif de thème. :P

    Je dois totalement refondre tout ça. :) Suppression des plugins par du code dans un fichier function.

    Encore merci Bg62. ;)
  • Bloody a écrit:
    Je vide le cache tjrs après une modif de thème. :P

    Je dois totalement refondre tout ça. :) Suppression des plugins par du code dans un fichier function.

    Encore merci Bg62. ;)
    bon courage alors ... ;)
    mais après ça reviendra rapidement ....
Connectez-vous ou Inscrivez-vous pour répondre.