Sortie PluXml 5.1.1

StéphaneStéphane Membre, Ancien responsable de PluXml
La version 5.1.1 de PluXml est disponible.

PluXml passe directement de la version 5.1 beta à la version 5.1.1

Télécharger la nouvelle version ici

Beaucoup de nouveautés et de corrections diverses. Le détail dans le changelog

Les plugins suivants sont à mettre à jour:

plxToolbar : barre d'outils pour la saisie du code html dans les articles
plxEditor (beta) : éditeur wysiwyg avec gestionnaire de fichiers

Sur la page de téléchargement également disponible sous forme de plugin:
CKeditor + CKFinder : éditeur wysiwyg + gestionnaires de fichiers

Toute l'équipe vous souhaite une bonne installation ou mise à jour

Consultant PluXml

Ancien responsable du projet (2010 à 2018)

«1

Réponses

  • Bonne nouvelle Stéphane, félicitations.... :)

    Tite question, on fait comment pour la mettre à jour ?
    On pousse directement le répertoire dans l'installation courante ?

    Je teste de suite !
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    Johan a écrit:
    Tite question, on fait comment pour la mettre à jour ?
    On pousse directement le répertoire dans l'installation courante ?
    c'est expliqué sur la page de téléchargement

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Stéphane a écrit:
    La version 5.1.1 de PluXml est disponible.
    :cool: Je m'en vais de suite la télécharger !

    Merci à vous pour votre travail !
  • JohanJohan Membre
    juillet 2011 modifié
    Stéphane a écrit:
    Johan a écrit:
    Tite question, on fait comment pour la mettre à jour ?
    On pousse directement le répertoire dans l'installation courante ?
    c'est expliqué sur la page de téléchargement
    Je plaide coupable et vient de le découvrir...
    Toutes mes excuses :o


    WAHOU !
    Quelle belle surprise ce thème d'administration !!!
    Encore bravo... :)
    Et l'apercu en live sur le site :)
    Et un méga article sur mon blog pro pour PluXml...
    You made my day !
  • Énorme !!! MERCI à toute l'équipe, je vais pouvoir entamer la migration ce weekend de mon blog ;) Et refondre rapidement le thème ..... Yaaaaaaaaaaaooooooooooooooo

    Bon weekend
  • Super boulot ! :D
  • Mise à jour OK ! Merci pour à toute l'équipe !
  • super!
    merci d'avoir tenu la date, c'est un beau boulot!
    rien a voir avec la 5.1 beta.
    ca ressemble de +en + à du wordpress, cf l'admin.
    le plugin plx editor semble marcher parfaitement, il faut que je le test + en profondeur.
    Pour l'apercu d'un article, ca ouvre un nouvel onglet à chaque fois, il doit y avoir moyen de l'avoir dans une lightbox,non?
    je vais etudier ca.
    merci en tout cas pour ce chouette cms!
    Daniel
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    plxEditor est surement encore perfectible (surtout en fonction des navigateurs), mais pour un 1er essai qui fait moins de 25Ko l'éditeur, ça nous laisse de quoi faire comparé aux éditeurs super lourds (ckeditor, tinymce, etc...)

    pour l'aperçu, oui ça doit etre jouable dans une fenetre modale genre lightbox. on a fait simple sans ajout de librairie extérieure pour pas alourdir.

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Haaaaaaaa je m'en vais télécharger la bête.
  • Stéphane a écrit:
    pour l'aperçu, oui ça doit etre jouable dans une fenetre modale genre lightbox. on a fait simple sans ajout de librairie extérieure pour pas alourdir.
    Je n'avais pas encore eu le temps de voir cela...
    Dommage, il faudrait voir comment WordPress fait pour rester dans l'onglet courant de prévisualisation.
  • bankaibankai Membre
    juillet 2011 modifié
    Question pour les tags ? toujours sous forme de liste, pas envisageable en nuage ?
    Sinon niveau administration, super boulot les amis.
    PS: le changlog n'est pas le bon ^^
  • Stéphane a écrit:
    on a fait simple sans ajout de librairie extérieure pour pas alourdir.
    C'est tout ce qu'on aime chez PluXml !

    Ainsi, au besoin, nous somme libres d'ajouter nos librairies favorites.
    Stéphane a écrit:
    pour l'aperçu, oui ça doit etre jouable dans une fenetre modale genre lightbox.
    Ma librairie favorite (Ne nécessite aucun Framework) : iBox.
  • Merci pour l'info Ibox
    du coup j'utilise maintenant Ibox, bien plus leger que iightbox pour les galeries d'image!
    a+
  • Merci pour cette version. J'aime beaucoup la gestion des médias et notamment la possibilité de forcer la taille de l'image et de sa miniature. :)

    Pas mal du tout plxEditor !

    Bravo pour le boulot accompli. ;)
  • Bravo pour ce beau bébé !

    Quelques remarques pour chez moi :
    - Pour que mon installation en local fonctionne, j'ai dû supprimer 3 fichiers .htacces (dans /Themes, /Core et /Plugins).
    - Le plxeditor ne fonctionne pas : il apparaît comme activé dans le gestionnaire de plugins mais rien ne change dans l'éditeur d'articles.
    - Voici les informations qui apparaissent dans la partie "Informations" (!) (2 fichiers ne sont pas accessibles en écriture) :
    Pluxml version 5.1.1 (encodage UTF-8)
    Version de php : 5.3.5-1ubuntu7.2
    Etat des "magic quotes" : 0
    ✔../../data/configuration/parametres.xml est accessible en écriture
    ✗../../data/configuration/categories.xml n'est pas accessible en écriture
    ✗../../data/configuration/statiques.xml n'est pas accessible en écriture
    ✔../../data/configuration/users.xml est accessible en écriture
    ✔../../data/configuration/tags.xml est accessible en écriture
    ✔../../data/articles/ est accessible en écriture
    ✔../../data/commentaires/ est accessible en écriture
    ✔../../data/statiques/ est accessible en écriture
    ✔../../data/images/ est accessible en écriture
    ✔../../data/documents/ est accessible en écriture
    ✗Module apache de réécriture d'url mod_rewrite non disponible
    ✔Bibliothèque GD installée
    ✔Fonction d'envoi de mail disponible
    Nombre de catégories : 6
    Nombre de pages statiques : 2
    Nom du rédacteur en session : admin

    Voilà, voilà, qu'en pensez-vous ?
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    Bonjour AirW

    peut etre un problème de droits en lecture sur le dossier plxeditor et sur les fichiers qu'il contient.
    Quel navigateur utilises-tu ?

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Beau travail, cette nouvelle version. Surtout les traductions, ça c'est une amélioration énorme. Je vais pouvoir commencer à empaqueter ça pour Debian, maintenant. :-)

    En revanche, je n'aime pas du tout le nouveau thème par défaut, alors que j'aimais beaucoup le précédent. Est-il prévu de rendre cet ancien thème disponible pour la 5.1 ?
  • Super travail ! Un grand bravo et un grand merci à toute l'équipe pour cette nouvelle version !
  • Voilà un petit moment que je n'ai plus posté sur ce forum. Pour tout dire, j'attendais de pied ferme la version 5.1.1 ! La voici enfin, du pain béni ! Pluxml n'en fini pas de m'étonner (ainsi que sa communauté).

    Pour ma part, avant de basculer vers cette nouvelle version, il m'est nécessaire de reprendre totalement mon thème. En effet, ayant pas mal bidouillé le corps (Core) beaucoup de choses sont à revoir. C'est également un conseil que je donne à tous ceux qui sont dans mon cas... Re-bidouillez vos thèmes, n'importez pas, (avis personnel) pour pouvoir profiter pleinement et sans encombre de cette nouvelle version. Cela peut prendre du temps, mais le résultat, bien adapté, n'en sera que meilleur.

    Beau travail en tous cas !!! Merci à toute l'équipe...
  • @ Stéphane

    Trouvé, merci ! C'était effectivement un problème de droits sur /plxeditor/plxeditor (le 2ème... il y en a bien 2, non ? Ou c'est une erreur d'installation ?)

    Je précise que je n'ai pas eu de problème pour l'installation en ligne (chez OVH).

    100 000 fois merci pour l'éditeur qui est exactement comme il faut : simple et efficace. L'insertion de documents est hyper-simple et hyper-rapide. Bravo !

    Devant tant de cadeaux j'ose (mais en rougissant très fort) en demander encore plus : pourra-t-on avoir en plus le petit bouton de la plxtoolbar qui permet d'insérer un lecteur audio ou vidéo ?

    Encore une fois bravo !
  • antistressantistress Membre
    juillet 2011 modifié
    Je passe de la 5.1beta à la nouvelle, sauf que je ne peux aller à l'administration : 403 - Forbidden
    Une idée ?

    J'ai supprimé les répertoires existants (sauf /data et mon thème modifié) avant de copier les nouveaux fichiers, j'aurais peut être pas dû ?
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    antistress a écrit:
    J'ai supprimé les répertoires existants (sauf /data et mon thème modifié) avant de copier les nouveaux fichiers, j'aurais peut être pas dû ?
    si, c'est exactement la façon la plus propre pour mettre à jour

    ton message d'erreur est-il en local ou sur ton hébergeur ?
    pour certains hébergeurs, les fichiers htaccess avec la directive Options -Indexes pose problème. En supprimant la directive ça remarche. dans pluxml il a plusieurs fichiers avec la ligne en question. a essayer...

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Le blogue est sur toile-libre qui tourne avec lightppd
  • antistressantistress Membre
    juillet 2011 modifié
    J'ai laissé les fichiers htaccess de /core, /data, /plugins et /themes en supprimant la ligne en question (du coup ils sont vides) sans succès... help : http://libre-ouvert.toile-libre.org/
  • antistressantistress Membre
    juillet 2011 modifié
    en plus les flux rss ont l'air de déconner

    normalement j'envoie sur le planet libre les billets de ces catégories :
    http://libre-ouvert.toile-libre.org/feed.php?rss/categorie4
    http://libre-ouvert.toile-libre.org/feed.php?rss/categorie6

    et là il y a le dernier commentaire posté plus le 1er article ("Ceci est un article créé lors de l'installation de PluXml. Editez-le depuis la zone d'administration.") et le 1er commentaire ("Ceci est un premier commentaire !") automatiquement créés par pluxml !
  • Elessar a écrit:
    Beau travail, cette nouvelle version. Surtout les traductions, ça c'est une amélioration énorme. Je vais pouvoir commencer à empaqueter ça pour Debian, maintenant. :-)

    En revanche, je n'aime pas du tout le nouveau thème par défaut, alors que j'aimais beaucoup le précédent. Est-il prévu de rendre cet ancien thème disponible pour la 5.1 ?
    Rectification, je retire ma question,et je la remplace par une affirmation : je suis en train de porter l'ancien thème pour la 5.1, en l'améliorant un peu.
  • j'ai pitet pas mis le bon identifiant au redémarrage du blogue, car il indique que les articles sont écrits par "ftp.toile-libre.org" et non par "antistress" comme avant ?
  • Bien joué pour cette nouvelle version Stephane. ;)

    Je vais le tester sur un environment local avant de migrer mon blog, histoire de vérifier ce qu'on peut faire avec et tester des ajouts.

    Antistress : Peut-on voir la configuration de ton lighttpd ? Peut-être que l'ancienne conf allait bien avec l'ancienne version de PluXml, mais que la nouvelle inclue certains changements ?
    En ce qui concerne les .htaccess, ils ne sont pas traités par lighttpd (il n'y a que apache qui s'en sert, voir IIS). Peut-être que certaines regles de ré-écriture doivent être chargés à même la conf de lighttpd.

    Si ça peut t'inspirer, j'avais écris cet article à l'occasion de mes tests avec Lighttpd.

    Besoin d'idées d'évasion en France et ailleurs ? C'est ici, sur frenchvadrouilleur.fr !

  • StéphaneStéphane Membre, Ancien responsable de PluXml
    Elessar a écrit:
    Elessar a écrit:
    Beau travail, cette nouvelle version. Surtout les traductions, ça c'est une amélioration énorme. Je vais pouvoir commencer à empaqueter ça pour Debian, maintenant. :-)

    En revanche, je n'aime pas du tout le nouveau thème par défaut, alors que j'aimais beaucoup le précédent. Est-il prévu de rendre cet ancien thème disponible pour la 5.1 ?
    Rectification, je retire ma question,et je la remplace par une affirmation : je suis en train de porter l'ancien thème pour la 5.1, en l'améliorant un peu.
    l'ancien thème par défaut et complètement compatible avec la 5.1.1

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

Connectez-vous ou Inscrivez-vous pour répondre.