PlxCoinSlider (slideshow)

13»

Réponses

  • Je ne sais pas pourquoi ma version ne fonctionne pas chez toi :( Faudrait vraiment que je me replonge dans ce plugin pour le finir :(

    J'ai un string de l'array

  • Bonjour !

    Suite à la mise à jour de la 5.1.4, je n'ai plus qu'un rectangle blanc à la pace de mon diaporama... Une idée de là où chercher ?
  • P3terP3ter PluXml Project Manager
    décembre 2011 modifié
    Bonjour,

    J'ai eu le même problème.
    Depuis la 5.1.4 les appels de hook ont changés, il faut que tu remplaces :
    <?php $plxShow->callHook('plxDisplayCoinSlider'); ?>
    
    par
    <?php eval($plxShow->callHook('plxDisplayCoinSlider')); ?>
    
    http://www.pluxml.org/article57/sortie-de-pluxml-5-1-4
  • Merci P3ter d'avoir répondu.

    J'ai un string de l'array

  • Et merci à tous les deux de ma part !
  • JeremmmJeremmm Member
    décembre 2011 modifié
    Merci pour ce plugin.

    Je l'ai un peu modifier pour choisir les images que je veux mettre directement dans la partie configuration (ajout de nouveau champs + nouveau champs dans le xml), par contre impossible de faire fonctionner le href.

    Tu ne l'as pas encore implémenté?

    Jérémy
  • Il y a quelque temps j'ai fais une version qui intègre la gestion des images depuis l'a configuration mais aussi la possibilité de créer plusieurs slide pour les intégrer ensuite dans des articles, pages ou même thème. Je bloque sur la gestion des images, je n'arrive pas à faire en sorte d'avoir plusieurs images enregistré dans le fichier xml et puis par manque de temps je n'ai pas retravaillé dessus.

    Comment à tu fais pour la partie image ?

    J'ai un string de l'array

  • JeremmmJeremmm Member
    décembre 2011 modifié
    Tu pourra regarder directement voici les sources

    www.jeremy-mouton.fr/plxcoinslider.zip

    Et je viens de résoudre mon problème de lien.

    Par contre c'est pas optimal, je pense qu'il y a possibilité d'avoir deux boutons dans la partie de config pour ajouter et supprimer des sliders
  • Je viens de modifier ton plugin pour le faire fonctionner avec la nouvelle version de pluxml.

    Envoi moi un mail, je te transmettrai le plugin, après tu pourra le diffuser.
  • Ok, j'ai regardé rapidement ta gestion des images, c'est une piste mais pas très souple car limité à trois images, si tu veux en ajouter plus il faut modifier le code... pas très sexy ;) L'idée que j'essaie de mettre en place est de faire un peu comme la gestion des catégories de PluXml, pour ajouter/supprimer autant d'images que l'on veut. Il me manque pas grand chose et hier j'ai peut être trouvé la solution à mon problème mais pour le moment je garde le post sous le coude et dès que j'ai un moment je t'écris.

    J'ai un string de l'array

  • Tu utilise un fichier xml différent pour ajouter les images?
  • J'utilise un fichier xml par slideshow qui contient les paramètres et les images pour le slide.

    J'ai un string de l'array

  • C'est à quoi je pensais aussi, mais avoir deux fichiers distinct, un pour les paramètres et un autre pour les slides, comme ça tu peux faire une page d'admin qui permet de modifier les slides et pas les paramètres.

    Et là tu peux gérer les accès au plugin. Par contre la partie admin (admin.php) comme indiquer dans le manuel de développement des plugins, j'ai pas réussi à le faire fonctionner.
  • J'ai découpé en deux, il y a la partie configuration accessible uniquement aux admins qui sera pour un slideshow pour le thème et qui définit les paramètres par défaut des nouveaux slide. Et une autre accessible aux autres (j'ai pas encore définit les rôles), je vais voir si je peux limiter l'affichage des slide à uniquement ceux que l'utilisateur à créé.
    comme ça tu peux faire une page d'admin qui permet de modifier les slides et pas les paramètres.
    Oui mais si pour un slide tu a besoin qu'il soit plus petit ou plus grand ou encore qu'il ai d'autres options... donc plus logique de créer un xml par slide qui contient son paramétrage et la liste des images qu'il utilise.

    J'ai un string de l'array

  • Bonjour à tous,

    J'ai un petit soucis avec ce plugin j'ai beau chercher je ne trouve pas de réponse et/ou je ne sais pas où chercher !
    Je m'explique : dans mon dossier plxcoinslider j'ai 4 images et sur mon site il y'a 5 boutons de navigations qui s'affichent alors quand je clique sur le premier bouton il ne m'affiche aucune image seulement du vide !
    Pour plus de compréhension voir ici
    PS : au premier tour de carrousel pas de soucis c'est à partir du deuxième tour que ça coince

    Merci de vos retours
  • Bonjour,

    tu a un fichier Thumbs.db qui traine dans le répertoire plxcoinslider. Merci le mode vignette de Windows ;)

    J'ai un string de l'array

  • Ah ce n'était que ça pourtant ce n'est pas faute d'avoir cherché !
    Merci bien ça m'enlève un bon tronc du pieds ;)
  • Tu as aussi un petit problème d’accent en bas de ta page ;-)
    « Tél&eacutephone »
  • Ah bon ?
    Dans mon footer ?
  • JAmes-LeeJAmes-Lee Member
    mars 2012 modifié
    BOnjour à tous .

    J4ai essayé d'installer le plugin , mais il ne s'affiche pas ...

    Quelqu'un pourrait il me donner la demarche a suivre pour l'installer sur le theme graffiti ?

    JE ne sais pas ou coller les lignes suivantes :

    <?php $plxShow->callHook('ThemeStartBody') ?>

    Et

    <div id="pitch">
    <div id='coin-slider'>
    <?php $plxShow->callHook('plxDisplayCoinSlider'); ?>
    </div>
    </div>

    Dans votre thème il faut ajouter :

    <?php $plxShow->callHook('plxDisplayCoinSlider'); ?>

    Merci bien
  • Bonsoir,
    <?php $plxShow->callHook('ThemeStartBody') ?>
    
    C'est l'appel du plugin pour la partie javascript, attention la méthode d'appel a changé dans PluXml 5.1.5 voir soit sur le blog de pluxml soit directement dans ce post la solution a été donnée plusieurs fois. Tu doit le placer après la balise < body > de ton thème.
    <?php $plxShow->callHook('plxDisplayCoinSlider'); ?>
    
    C'est la partie affichage, tu dois le placer à l'endroit ou tu veux afficher le slideshow dans ton thème. Pareil que l'autre code, l'appel à changé.

    J'ai un string de l'array

  • D'accord , je te remercie , mais c'est bien ce que j'ai fait , mais cela ne s'affiche pas !
  • Voici le code de mon theme.php *


    <?php if(!defined('PLX_ROOT')) exit; ?>
    <!DOCTYPE html>
    <html xmlns="http://www.w3.org/1999/xhtml"; xml:lang="<?php $plxShow->defaultLang() ?>" lang="<?php $plxShow->defaultLang() ?>">
    <?php $plxShow->callHook('plxDisplayCoinSlider'); ?>
    <head>
    <title><?php $plxShow->pageTitle(); ?></title>

    <meta http-equiv="Content-Type" content="text/html; charset=<?php $plxShow->charset(); ?>" />
    <?php $plxShow->meta('description') ?>
    <?php $plxShow->meta('keywords') ?>
    <?php $plxShow->meta('author') ?>

    <link rel="icon" href="<?php $plxShow->template(); ?>/img/favicon.png" />
    <link rel="stylesheet" type="text/css" href="<?php $plxShow->template(); ?>/style.css" media="screen" />
    <!--[if IE]>
    <link rel="stylesheet" type="text/css" href="<?php $plxShow->template(); ?>/ie.css" media="screen" />
    <![endif]-->
    <!--[if IE]>
    <script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>;
    <![endif]-->

    <link rel="alternate" type="application/rss+xml" title="<?php $plxShow->lang('ARTICLES_RSS_FEEDS') ?>" href="<?php $plxShow->urlRewrite('feed.php?rss') ?>" />
    <link rel="alternate" type="application/rss+xml" title="<?php $plxShow->lang('COMMENTS_RSS_FEEDS') ?>" href="<?php $plxShow->urlRewrite('feed.php?rss/commentaires') ?>" />

    <!--Bouton haut de page -->
    <script type="text/javascript" src="http://www.google.com/jsapi"></script>;
    <script type="text/javascript">google.load('jquery', '1.4.2');</script>

    </head>


    <body role="document" id="top">
    <?php $plxShow->callHook('ThemeStartBody') ?>

    <header role="banner" id="entete">

    <nav id="skip">
    <ul>
    <li><a href="<?php $plxShow->urlRewrite('#menu') ?>" title="<?php $plxShow->lang('GOTO_MENU') ?>"><?php $plxShow->lang('GOTO_MENU') ?></a></li>
    <li><a href="<?php $plxShow->urlRewrite('#main') ?>" title="<?php $plxShow->lang('GOTO_CONTENT') ?>"><?php $plxShow->lang('GOTO_CONTENT') ?></a></li>
    </ul>
    </nav>

    <hgroup id="title">
    <h1><?php $plxShow->mainTitle('link'); ?></h1>
    <h2><?php $plxShow->subTitle(); ?></h2>
    </hgroup>

    </header>

    <nav role="navigation" id="menu">
    <ul>
    <?php $plxShow->pageBlog('<li id="#page_id"><a class="#page_status" href="#page_url" title="#page_name">#page_name</a></li>'); ?>
    <?php $plxShow->staticList($plxShow->getLang('HOME'),'<li id="#static_id"><a href="#static_url" class="#static_status" title="#static_name">#static_name</a></li>'); ?>
    </ul>
    </nav>
  • Bonjour, si tu es sur PluXml 5.1.5 il y a eu un changement dans la méthode d'appel des hook pour les plugins, regarde dans ce post la réponse à été donnée... une piste "eval" :)

    J'ai un string de l'array

  • Ok super , ca marche enfin , mais comme tout , y'a toujours quelque chose qui cloche ...

    Les image sont "taillés" les unes au dessus des autres ... elle coupe ma bannière jusqu'au reste , je ne pense pas que le coinslider fasse cet effet la ...

    www.gourmetz.fr , une idée d'ou ca viens ?
  • C'est parce que le plugin jquery ce charge après le plugin PlxCoinSlider donc du coups il ne trouve pas jquery et ne démarre pas, dans ton header.php
    <script type="text/javascript" src="./plugins/plxcoinslider/coin-slider.min.js"></script>
    	<script type="text/javascript" src="./plugins/jquery/jquery.min.js"></script>
    

    La solution a été donné mais je n'arrive pas à remettre la main dessus. La solution barbare serait d'éditer le fichier pluxml.xml pour modifier l'ordre de chargement.

    J'ai un string de l'array

  • joebartjoebart Member
    mai 2012 modifié
    Merci pour ce plugin mais une grande mise à jour du post serait utile :)

    1/ Télécharger la version 0.6 ==>plxcoinslider-0.6.zip
    (Le lien du post n'est plus à jour et chez flipflip, on arrive sur le lien de la 0.3.


    2/ Dans votre template (header.php pour ma part) :

    Après :
    </ul>
    </div>

    Ajouter :
    <?php eval($plxShow->callHook('plxDisplayCoinSlider')); ?>
    
    Et PLUS
    <?php $plxShow->callHook('plxDisplayCoinSlider'); ?>
    

    Voilà, je crois que c'est OK comme ça :)

    Ha non, c'est assez pénible de gérer avec CKEditor qui rajoute à chaque changement d'URL des balises indésirables. Aucun problème par contre avec PLX editor. ^^
  • AirWAirW Member
    joebart a écrit:
    1/ Télécharger la version 0.5 ==>plxcoinslider-0.5.zip

    Plutôt 0.6, non ?
  • joebartjoebart Member
    mai 2012 modifié
    AirW a écrit:
    joebart a écrit:
    1/ Télécharger la version 0.5 ==>plxcoinslider-0.5.zip

    Plutôt 0.6, non ?

    Bien vu, j'avais même pas fait gaffe :) J'ai corrigé mon post (comme quoi, une MaJ du thread s'impose ^^)
  • flipflipflipflip Member
    mai 2012 modifié
    Bonjour,

    Les versions au dessus de la 0.3 de mon site ont été modifié par Jerry Wham, il a fait diverse correction (voir page 2 de ce post).

    Il est prévue une grosse mise à jour du plugin mais pour le moment je suis sur un autre projet donc pas le temps de le mettre à jour.

    Pour la modification de l'appel du hook (eval...) j'en parle deux messages au dessus du tiens joebart ;) et il me semble en avoir parlé plusieurs fois dans ce post.

    J'ai un string de l'array

Connectez-vous ou Inscrivez-vous pour répondre.