PlxYoxView une fancybox

Bonjour à tous,

PlxYoxView permet d'afficher une image dans un cadre à la façon d'un fancybox. Pour l'utilisation j'ai ajouté une page de paramétrage et un bouton qui s'ajoute automatiquement à plxtoolbar.

Le plugin se base sur http://www.yoxigen.com/yoxview .

Pour le télécharger : http://www.blogoflip.fr/?static8/mes-plugins-pluxml
Pour son utilisation regarder dans l'aide.

ChangeLog
---- Version 0.1 - 26/07/2011 ----
- Version initial pour PluXml 5.1.2

J'ai un string de l'array

«1

Réponses

  • StéphaneStéphane Membre, Ancien responsable de PluXml
    Excellent !

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Je teste car très utile. :D
    Merci FlipFlip. ;)
  • Super merci !
    j'ai eu un petit temps de latence sur le fait qu'il faut modifier son thème mais maintenant ça roule !

    :)
  • leolleol Membre
    Bonjour,
    Je débute avec PluXml et j'essaye de faire fonctionner le plugin PlxYoxView.

    J'ai les plugins suivants activés:
    jquery 1.4.4 version 1.0
    plxtoolbar version 1.2
    plxyoxview version 1.0

    Dans le fichier themes/defaut/header.php j'ai le code suivant:
    <?php if(!defined('PLX_ROOT')) exit; ?>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="<?php $plxShow->defaultLang() ?>" lang="<?php $plxShow->defaultLang() ?>">
    
    <head>
    
    	<title><?php $plxShow->pageTitle(); ?></title>
    
    	<meta http-equiv="Content-Type" content="text/html; charset=<?php $plxShow->charset(); ?>" />
    	<?php $plxShow->meta('description') ?>
    	<?php $plxShow->meta('keywords') ?>
    	<?php $plxShow->meta('author') ?>
    
    	<link rel="icon" href="<?php $plxShow->template(); ?>/img/favicon.png" />
    	<link rel="stylesheet" type="text/css" href="<?php $plxShow->template(); ?>/css/screen.css" media="screen" />
    	<!--[if IE]>
    		<link rel="stylesheet" type="text/css" href="<?php $plxShow->template(); ?>/css/ie.css" media="screen" />
    	<![endif]-->
    	<?php $plxShow->templateCss() ?>
    
    	<link rel="alternate" type="application/rss+xml" title="<?php $plxShow->lang('ARTICLES_RSS_FEEDS') ?>" href="<?php $plxShow->urlRewrite('feed.php?rss') ?>" />
    	<link rel="alternate" type="application/rss+xml" title="<?php $plxShow->lang('COMMENTS_RSS_FEEDS') ?>" href="<?php $plxShow->urlRewrite('feed.php?rss/commentaires') ?>" />
    
    </head>
    
    <body id="top">
    
    <?php $plxShow->callHook('ThemeStartBody') ?>
    
    	<div id="header">
    
    		<ul id="skip">
    			<li><a href="<?php $plxShow->urlRewrite('#nav') ?>" title="<?php $plxShow->lang('GOTO_MENU') ?>"><?php $plxShow->lang('GOTO_MENU') ?></a></li>
    			<li><a href="<?php $plxShow->urlRewrite('#section') ?>" title="<?php $plxShow->lang('GOTO_CONTENT') ?>"><?php $plxShow->lang('GOTO_CONTENT') ?></a></li>
    		</ul>
    
    		<h1><?php $plxShow->mainTitle('link'); ?></h1>
    		<p><?php $plxShow->subTitle(); ?></p>
    
    		<ul id="nav">
    			<?php $plxShow->staticList($plxShow->getLang('HOME'),'<li id="#static_id"><a href="#static_url" class="#static_status" title="#static_name">#static_name</a></li>'); ?>
    			<?php $plxShow->pageBlog('<li id="#page_id"><a class="#page_status" href="#page_url" title="#page_name">#page_name</a></li>'); ?>
    			<li class="feed">
    				<ul>
    					<li><a href="<?php $plxShow->urlRewrite('feed.php?rss') ?>" title="<?php $plxShow->lang('ARTICLES_RSS_FEEDS') ?>"><?php $plxShow->lang('ARTICLES') ?></a></li>
    					<li><a href="<?php $plxShow->urlRewrite('feed.php?rss/commentaires') ?>" title="<?php $plxShow->lang('COMMENTS_RSS_FEEDS') ?>"><?php $plxShow->lang('COMMENTS') ?></a></li>
    				</ul>
    			</li>
    		</ul>
    
    	</div>
    
    Et pour utiliser le plugin dans un article, j'ai le code suivant:
    <div id="plxyoxview" class="plxyoxview"><a href="data/images/biblio/nekomix8.jpg"><img src="data/images/biblio/nekomix8.tb.jpg" alt="" /></a></div>
    
    Voila ce que ça donne:
    http://capuchman.free.fr/pluxml/index.php?article5/nouvel-article

    Qu'est-ce que j'ai oublié de faire ?

    Merci
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    Bonjour

    l'auteur du plugin confirmera...

    Faut-il le plugin jquery pour utiliser PlxYoxView ?

    car dans ton cas jquery est chargé après
    <script type="text/javascript" src="./plugins/plxyoxview/yoxview/yoxview-init.js"></script>
    	<script type="text/javascript" src="./plugins/jquery/jquery.min.js"></script>
    
    Si c'est toi qui a rajouté manuellement jquery, utilise le plugin jquery (http://pluxml.org/static7/download#plugins)
    sinon arrange toi pour avoir dans le fichier header.php du theme
    <script type="text/javascript" src="./plugins/jquery/jquery.min.js"></script>
    	<script type="text/javascript" src="./plugins/plxyoxview/yoxview/yoxview-init.js"></script>
    

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • leolleol Membre
    Merci pour ton aide Stéphane.
    J'ai édité le fichier /data/configuration/plugins.xml et j'ai changé l'ordre de chargement des plugins. J'ai mis le plugin jquery avant plxyoview et ça marche nickel.
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    ok super

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Bonjour, je confirme le plugin jquery doit être activé.

    J'ai un string de l'array

  • WiksaWiksa Membre
    Bonjour,

    Merci pour ce plugin et cette lightbox que je découvre, elle est vraiment super. Par contre je n'arrive pas à la faire marcher avec des liens texte pointant vers une page web à afficher dans la lightbox. C'est normal ?
  • Bonjour, pour le moment il est juste prévu l'affichage des images. Lors de mes tests je n'ai pas réussi ni compris comment faire pour que ça fonctionne avec d'autres format.

    J'ai un string de l'array

  • bg62bg62 Membre
    août 2011 modifié
    une seule réponse : superbe !
    et bravo pour ce bon travail ;)
    j'ai testé avec une galerie dans une page statique, avec une image (miniature) dans un post, c'est superbe !!!
    ps : quid d'une gestion de 'multi-galeries' ?
    @+
  • Merci, j'ai découvert un peu plus le fonctionnement de YoxView en écrivant le plugin plxgalerie. En fait si tu mets des images dans le même div tu aura le diaporama activé pour ces images. Pour le moment je n'ai pas testé le cas de plusieurs images mais dans des div différents...

    J'ai un string de l'array

  • bg62bg62 Membre
    flipflip a écrit:
    Merci, j'ai découvert un peu plus le fonctionnement de YoxView en écrivant le plugin plxgalerie. En fait si tu mets des images dans le même div tu aura le diaporama activé pour ces images. Pour le moment je n'ai pas testé le cas de plusieurs images mais dans des div différents...
    ok je vais tester .... j'ai déjà essayé ici :
    http://unesourisetmoi.free.fr/pluxml5.14/
    ça rend bien !!!
    super :)
    par contre j'ai 3 images dans la galerie ... en local ok , en ligne 2 seulement apparaissent dans la page .. ???
  • flipflipflipflip Membre
    août 2011 modifié
    par contre j'ai 3 images dans la galerie ... en local ok , en ligne 2 seulement apparaissent dans la page .. ???
    Pas compris ???? T'a un exemple visible ? Tu parle de plxyoxview ou de plxgalerie ? Si c'est du second merci d'utiliser le post dédié à ce plugin.

    J'ai un string de l'array

  • bg62bg62 Membre
    flipflip a écrit:
    par contre j'ai 3 images dans la galerie ... en local ok , en ligne 2 seulement apparaissent dans la page .. ???
    Pas compris ???? T'a un exemple visible ? Tu parle de plxyoxview ou de plxgalerie ? Si c'est du second merci d'utiliser le post dédié à ce plugin.
    le premier :
    http://unesourisetmoi.free.fr/pluxml5.14/index.php?article6/une-image-dans-un-post
    nickel
    le second :
    http://unesourisetmoi.free.fr/pluxml5.14/index.php?static3/statique-3 est effectivement avec plxgalerie et c'est lui qui pose problème en ligne
    @+
  • bg62bg62 Membre
    il semblerait que l'on ne peut pas mettre 2 'vignettes' dans un même post j'ai essayé en local, ça foire, en ligne :
    http://unesourisetmoi.free.fr/pluxml5.14/index.php?article6/une-image-dans-un-post
    de même ...
    tu peux regarder si tu veux et si besoin : login pas changé ;)
    @+
  • Ah oui effectivement c'est un problème. Pour le moment je suis sur la re-écriture de plxcoinslider mais après de je regarde.

    J'ai un string de l'array

  • bg62bg62 Membre
    flipflip a écrit:
    Ah oui effectivement c'est un problème. Pour le moment je suis sur la re-écriture de plxcoinslider mais après de je regarde.
    ok
    @+ alors ;)
  • leol a écrit:
    Merci pour ton aide Stéphane.
    J'ai édité le fichier /data/configuration/plugins.xml et j'ai changé l'ordre de chargement des plugins. J'ai mis le plugin jquery avant plxyoview et ça marche nickel.
    merci pour le tuyau ;)
    j'ai un peu galleré avec le plugin plxyoxview.
    rien dans l'aide ne parlai de faire cela......

    maintenant , ca marche mieux c'est sur !
  • décembre 2011 modifié
    Bonsoir, suite à une erreur d'inattention de ma part sur la MAJ vers la version 5.1.4, j'ai perdu les paramètres pour faire fonctionner PlxYoxView. Je pense qu'i faut insérer un code dans le header.php de mon thème mais je ne sais plus lequel. Dans la nouvelle version du plugin, je ne retrouve pas l'aide.

    Donc, je m'en remets à la votre...

    Merci d'avance pour vos éventuels éclaircissements :)
  • Pour le moment je n'ai pas fais de test avec pluxml 5.1.4. Etonnant que l'aide ai disparu, pour ajouter le plugin à ton thème tu doit ajouter
    <?php eval($plxShow->callHook('ThemeStartBody')) ?>
    

    J'ai un string de l'array

  • décembre 2011 modifié
    Salut flipflip et merci ! ça marche...
    Pour l'aide (je ne sais pas si c'est dû à mes manips), je n'ai vu que le lien 'configuration'
  • bdube30bdube30 Membre
    janvier 2012 modifié
    Bonjour,

    J'essaie de faire fonctionner plxoview depuis ce matin sans aucun résultat.

    - jquery est installé et fonctionne(je l'utilise pour mon bouton de «retour vers le haut»)
    - J'ai bien inséré la ligne de code indiqué dans la partie «aide» du plugin.
    - Sinon dans quel ID de div faut-il mettre l'image ? j'ai tenté <div id="plxyoxview"> ...

    Merci de m'aider !

    Mon blog : http://bdube.legtux.org

    Benjamin
  • Je viens de me rendre compte que j'ai le même problème avec le thème par défaut de PluXml, j'essaie de regarder ça ce week-end.

    J'ai un string de l'array

  • Cette lightbox est très sympas, mais malheureusement elle marche mal avec chrome et IE9: avec ces navigateurs, lorsqu'on ouvre une image elle est floue. A cause de ça je me suis rabattu sur Fancybox et Zoombox qui me semblent plus simple à utiliser au passage.
  • mais malheureusement elle marche mal avec chrome et IE9: avec ces navigateurs, lorsqu'on ouvre une image elle est floue.
    Je viens de faire le test avec IE9 et les photos sont net, si t'a un exemple sous la main je veux bien voir.

    Pour ce qui est de la configuration elles fonctionnent toute sur le même principe. Tu doit donner un id à ton élément et ensuite dire au javascript quel id traité et de ce que j'ai regardé pour les options c'est le même principe aussi donc pour moi c'est pareil l'un ou l'autre. L'intérêt de Fancybox ou Zoombox est peut être d'être plus suivi niveau dev.

    J'ai un string de l'array

  • Sur le site officiel de Yoxview, les exemples ne marchent pas très bien de mon côté. Par exemple, la miniature apparait dans la lightbox au lieu de la vidéo Youtube avec IE9 (dernière vignette). Le format des photos n'est pas toujours respecté, mais c'est assez aléatoire. Sous chrome je n'ai reproduit le flou qu'une seule fois, la première fois que j'ai cliqué sur une miniature, après tout était fonctionnel.


    Des liens qui recensent les bugs de Yoxview:

    - http://drupal.org/node/1141068
    - http://forum.phpfrance.com/javascript-ajax/jquery-yoxview-ie9-t261695.html


    Au final, je préfère m'orienter vers d'autres solutions au moins jusqu'à ce que ces problèmes soient définitivement réglés. Je dis au moins parce que je suis vraiment en train d'adopter Fancybox V3 (non-commercial) et Zoombox (commercial).


    Quant à son fonctionnement, j'ai quand même mis plus de temps à la prendre en main que d'autres, mais son fonctionnement est pas super compliqué non plus.
  • Bonjour,

    je viens de relire ce post qui m'avait servi pour l'ordre des plugins (jquery et les autres plugins) et je vois maintenant qu'un deuxième soucis était exposé : la deuxième image qui ne marche pas.

    Y-a-t-il une solution à ce jour ? ou faut-il changer de système de fancybox ?

    Quoi qu'il en soit, merci aux développeur de plugins. Lorsque j'aurais le temps, je ferai des "tutos pour les nuls" car souvent les aides intégrées sont faites par des "experts" et les erreurs soulevées sont souvent les mêmes et dues à un manque de savoir...
  • flipflipflipflip Membre
    février 2012 modifié
    bonjour,

    shaman, pour le problème de plusieurs images dans un même article pluxml mais dans des éléments html différent je n'ai pas trouvé de solution et je pense que tu rencontrera le même problème avec d'autres scripts. J'ai repris l'écriture d'un autre plugin (coinslider), ensuite il y en aura un autre (pas publié encore) et promis je me plonge sur le cas plxyoxview.

    J'ai un string de l'array

  • ;) merci quand même

    Pourtant quand je fais un site en HTML avec une lightbox, je peux appeler autant de photo que je veux sur une page...

    Qu'elle différence avec pluxml ?
Connectez-vous ou Inscrivez-vous pour répondre.