[plugin]syntaxhighlighter

2»

Réponses

  • P3terP3ter Responsable de PluXml
    @Jerry c'est nickel avec l'archive, merci
  • danielsan a écrit:
    Hello Jerry,
    j'en profite pour un ptit truc, ça marche comment avec un code PHP+HTML ?
    exemple avec la class :php et ce code:
    <h2><?php echo plxUtils::strCheck($plxShow->plxMotor->aCats[$plxShow->plxMotor->cible]['name']) ?></h2>
    <div class="cat_description"><?php echo plxUtils::strCheck($plxShow->catDescription()) ?></div>
    
    ça me rajoute des trucs au niveau des <?php ... ?> je suis obligé de passer les "<" en ">" en ;lt / ;gt ...
    Merci.

    Pour que ça fonctionne correctement, il faut d'abord sélectionner la balise pre dans le menu déroulant, copier le code (ou l'écrire) dans le cadre gris qui s'est affiché.
    Il faut ensuite visionner le code généré (en cliquant sur le bouton html) pour que la classe soit prise en compte.
    En effet, plxEditor utilise la fonction "formatBlock" qui d'après ce que j'ai compris est native à javascript et qui ne réagit qu'avec les balises de type block (mais pas toutes) sans argument c'est à dire que l'on ne peut pas passer ni classe ni index.

    Je n'ai pas d'autre solution à vous proposer. Désolé.
    Si quelqu'un à une idée, je suis preneur.
  • rauminraumin Membres
    Bonjour,

    Merci pour ce plugin.

    J'essaye de modifier "expand code" en "Afficher le code" dans ../src/shCore.js .
    En faisant un grep de "expand code", cette chaine ne ressort que dans shCore.js mais j'ai beau vider mon cache, changer de navigateur, il y a toujours marquer expand code...

    Quelqu'un a une idée svp ?
  • J'ai expandSource dans le code mais pas expand code...
  • rauminraumin Membres
    Oui expand source pardon !!

    J'ai remplacé "expand source" par autre chose mais ça ne fait rien.
  • Hum, le lien pour télécharger le plugin est down =/.
  • Jeoffrey a écrit:
    Hum, le lien pour télécharger le plugin est down =/.

    C'est corrigé. Désolé !
  • Bonjour

    Je voulais faire quelques petites modifications et j'ai donc trouvé dans scr le fichier shCore avant qu'il ne soit minifié.
    Pour tester, j'ai remplacé le shCore.js du dossier scripts par le shCore.js du dossier scr ( sans aucune modification) et là ça ne fonctionne plus.

    A quoi sert le fichier legacy.js

    Cordialement
  • cpalocpalo Membres
    mars 2014 modifié
    Bonjour

    Le fichier legacy.js sert à assurer la compatibilité entre l'usage d'éléments rédigés avec la version 1.5 tout en travaillant avec la version 3
    L'utilisation de ce fichier
    Vu que la page du script n'est plus active, les liens de navigation vers les diverses rubriques ne sont pas toujours très simples à trouver.
  • cpalocpalo Membres
    mars 2014 modifié
    Pour retrouver les liens de la documentation: documentation syntaxHighLighter
    ainsi qu'un article sur comment rendre modifiable un script js avant qu'il ne soit minifié, avec l'exemple de syntaxHighLighter Un Callback pour vos fonctions JS

    Et la navigation, en fait est facile... sidebar bleue à droite

    Cordialement
Connectez-vous ou Inscrivez-vous pour répondre.