[plugin] lockArticles, un mot de passe à vos articles

24

Réponses

  • Hello, il marche sous PluXML 5.2, je m'en sers mais il n'a pas été mis à jour ;)
  • reprenant mon allusion et mon idée du 30/10/2013, je viens de constater que :
    - lorsqu'une page statique est activée dans l'admin, son contenu s'affiche côté client
    - lorsqu'elle est n'est pas activée, la page est blanche

    question :
    - serait-il possible de déterminer à l'avance des durées paramétrables des temps en mode actif et non actif d'une page ?
    - plus globalement, de jouer sur le caractère paramétrable des modes actif/non actif des statiques ?
    - quels autres choix pourraient être - théoriquement - proposés, en plus de "oui/non" dans la colonne active ?
  • rockyhorrorrockyhorror Member
    février 2015 modifié
    Bonjour à tous,

    Voici une nouvelle version du plugin.
    Les nouveautés:
    [list=*]
    [*]Gestion sécurisé des mots de passe[/*]
    [*]possibilité de mettre un mot de passe aux pages statiques (désolé Stéphane, je marche sur tes plates bandes)[/*]
    [*]Optimisations et corrections de code[/*]
    [/list]

    Téléchargeable par ici
  • rockyhorror a écrit:
    Bonjour à tous,

    Voici une nouvelle version du plugin.
    Les nouveautés:
    [list=*]
    [*]Gestion sécurisé des mots de passe[/*]
    [*]possibilité de mettre un mot de passe aux pages statiques (désolé Stéphane, je marche sur tes plates bandes)[/*]
    [*]Optimisations et corrections de code[/*]
    [/list]

    Téléchargeable par ici
    Votre connexion n'est pas privée

    Il se peut que des pirates soient en train d'essayer de dérober vos informations sur le site thepoulpe.net (par exemple, des mots de passe, des messages ou des informations sur vos cartes de paiement).
  • Bonjour,

    Juste un Warning un peu alarmiste, pour indiquer que c'est du https, avec un certificat auto-signé. Rien de grave.
    J'ai corrigé le lien pour qu'il passe en http.
  • joebartjoebart Member
    février 2015 modifié
    Thanks :)

    Petit décalage du "OK" qui vient en dessous du champ de saisie du mot de passe par contre.

    mini_165426Capture.jpg
  • Bonjour,

    Nouvelle version, qui corrige un bug avec la partie administration.

    version 1.1
  • Toujours ce petit défaut d'affichage lais ce mod est super utile pour mon site, 1000 mercis :) :)
  • Tu peux le changer facilement en editant le fichier "form.article_password.php" dans le répertoire du plugin. Rien de bien compliqué c'est du html.
  • Bonjour,

    J'ai tenté d'utiliser votre plugin, je l'ai transféré dans mon ftp (pageperso Free) mais un fois que je ne rends dans mon admin pluxml au niveau des plugin j'ai ce message :

    Parse error: syntax error, unexpected T_SL in /mnt/109/sda/3/7/ :) /pluxml/plugins/lockArticles/lockArticles.php on line 101

    Je ne sais pas comment le résoudre, j'ai cherché au niveau des espaces/tabs mais rien trouvé (PS : je suis loin d'être un expert en php)

    Pouvez-vous m'aider ?

    Merci
  • StéphaneStéphane Member, PluXml Former Project Manager
    Y a des notices à corriger également dès l'activation du plugin
    Notice: Undefined index: password in \www\pluxml-latest\core\lib\class.plx.motor.php(450) : eval()'d code on line 1
    
    Notice: Undefined index: password in \www\pluxml-latest\core\lib\class.plx.motor.php(510) : eval()'d code on line 1
    

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Bonjour,

    je regarde ça.

    @mcguyver25: quel est la version de php sur l'hébergement Free ?

    Merci,
  • Bonjour,

    Pour la pagesperso free avec Pluxml, j'ai du créer un fichier .htaccess avec PHP 1 qui correspond à du PHP 5.

    Dois-je modifier quelque chose la dedans ?
  • Pour être plus précis j'ai lancé un php info est la version de free est

    PHP Version 5.1.3RC4-dev
  • StéphaneStéphane Member, PluXml Former Project Manager
    mcguyver25 a écrit:
    Bonjour,

    Pour la pagesperso free avec Pluxml, j'ai du créer un fichier .htaccess avec PHP 1 qui correspond à du PHP 5.

    Dois-je modifier quelque chose la dedans ?

    Non.

    http://wiki.pluxml.org/index.php?page=Activer+PHP5+sur+votre+h%C3%A9bergement

    http://wiki.pluxml.org/index.php?page=Faire+fonctionner+PluXml+chez+vos+h%C3%A9bergeurs

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Bonjour,

    C'est bien un pb de compatibilité avec la version de php. J'ai utilisé une syntaxe 'nowdoc' qui n'est apparu que dans la version 5.3 de php.

    J'ai mis à dispo une nouvelle version qui corrige le pb, et les warnings remontés par Stéphane.

    dispo ici
  • Bonsoir,

    Merci pour votre action, alors y'a du mieux je n'ai plus l'erreur par contre lorsque je mets un mot de passe sur un article et que j'enregistre la page devient blanche, je dois rafraichir et me reconnecter ? Aussi le plugin laisse apparaitre les vidéos type iframe et le preview du texte ?

    Est-ce normal ?
  • Bonjour,

    As tu des logs ? quels version de pluxml tu utilises ?

    Pour les articles avec un mot de passe, il faut mettre un chapo, sinon le contenu s'affiche sur la page d'accueil.
  • Salut,

    Merci pour le chapeau j'ai vu après, (PS : je suis toujours en train de chercher pour ajouter le cadenas lol, mais c'est comme ça qu'on apprend).

    La version pluxml est le 5.3.1 et pour les logs, je ne sais pas faire, je suis en train de chercher comment
  • Bonjour,

    Voici une version avec quelques corrections mineures de warning php.
    Version testée avec php 5.1.1

    @mcguyver25: essaye cette version voir si ça corrige ton pb. Sinon, est-ce que tu peux m'envoyer par mail, l'intégralité du phpinfo(), et si tu trouves les logs php/apaches quand tu as l'erreur.
    Pour le cadenas, regarde dans l'aide du plugin, c'est expliqué.

    Par ici
  • Bonjour Rocky,

    Alors j'ai toujours l'erreur et je te confirme que quand je désactive ton plugin elle n'arrive plus. L'erreur exact c'est qu'a chaque enregistrement d'un article la page devient blanche et je dois recharger la page par contre les modifications sont bien prises en compte et le mot de passe bien activé. Je ne sais pas récupérer les logs, si tu as un petit tuto je suis preneur sinon faut attendre que j'y arrive par mes recherches... Pour le php info je te transferts un lien pour free ça n'a pas changé depuis.

    version php free

    Merci pour ton aide
  • mcguyver25,

    Peux tu éditer le fichier "core/lib/config.php", et remplacer la ligne suivante:
    [== PHP ==]
    # Gestion des erreurs PHP
    error_reporting(E_ALL ^ E_NOTICE ^ E_WARNING);
    

    par
    [== PHP ==]
    # Gestion des erreurs PHP
    error_reporting(E_ALL | E_STRICT);
    ini_set('log_errors', 'On');
    ini_set("error_log", PLX_ROOT."php-error.log");
    

    Ensuite tu reproduis l'erreur.
    Tu dois maintenant avoir un fichier "php-error.log" à la racine de ton pluxml. Est-ce que tu peux me l'envoyer.

    Merci.
  • Salut,

    J'ai effectué ta manip je n'ai pas de fichier php-error.log à la racine mais lorsque j'ai effectué la manip j'ai eu ce message :

    PS : j'ai juste modifé le nom de mon site par "rockyhorrorshow"

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /mnt/109/sda/3/7/rockyhorrorshow/pluxml/core/lib/config.php:1) in /mnt/109/sda/3/7/rockyhorrorshow/pluxml/core/admin/prepend.php on line 26

    Warning: Cannot modify header information - headers already sent by (output started at /mnt/109/sda/3/7/rockyhorrorshow/pluxml/core/lib/config.php:1) in /mnt/109/sda/3/7/rockyhorrorshow/pluxml/core/admin/prepend.php on line 55

    Notice: Use of undefined constant PLX_CONF - assumed 'PLX_CONF' in /mnt/109/sda/3/7/rockyhorrorshow/pluxml/plugins/plxMyCoinSlider/lib/class.plx.coinslider.php on line 9

    Warning: is_readable() [function.is-readable]: open_basedir restriction in effect. File(/dev/urandom) is not within the allowed path(s): (/mnt/109/sda/3/7/rockyhorrorshow) in /mnt/109/sda/3/7/rockyhorrorshow/pluxml/plugins/lockArticles/PasswordHash.php on line 51

    Warning: Cannot modify header information - headers already sent by (output started at /mnt/109/sda/3/7/rockyhorrorshow/pluxml/core/lib/config.php:1) in /mnt/109/sda/3/7/rockyhorrorshow/pluxml/core/admin/article.php on line 114
  • Bonjour,

    Je ne vois là rien qui puisse justifier une page blanche. Le warning lié au plugin lockArticle, Warning: is_readable() [function.is-readable]: open_basedir restriction in effect est inhérent à la fonction is_readable, mais c'est le fonctionnement normal, rien de bloquant.

    Dans ce que je vois, il semble y avoir un pb avec la gestion des sessions, et des en-tetes. c'est lié à la configuration php. En général ce sont des erreurs liées au paramètre "output_buffering" qui n'est pas actif.

    Peux tu essayer la chose suivante (bon là je navigue un peu en eau trouble):
    dans ton fichier .htaccess (celui où tu as activé le php5) ajouter la ligne suivante:
    [== Indéfini ==]
    php_flag output_buffering  on
    

    regarde également ici

    Sinon, si quelqu'un à une idée
  • Trouvé !!

    Oublis le barratin précédent. c'est un mauvais contournement.
    Nouvelle version dispo

    C'est vicieux, mais je commençais mes "echo" avec une ligne vide.
  • mcguyver25mcguyver25 Member
    mars 2015 modifié
    Merci je te confirme que tout fonctionne normalement, je crois que tu peux demander l'officialisation de ton plugin maintenant :) .

    Bonne journée à toi.
  • jol5926jol5926 Member
    Bonjour,
    je viens d'installer ce plugin pour le tester sur un pluxml vierge et il ne fonctionne pas. Impossible d'activer un mot de passe pour un article ou une catégorie.
    Ai-je zapper quelque chose ? L'installation m'a l'air toute simple.
    Merci de ton aide

    Jol5926
  • joebartjoebart Member
    jol5926 a écrit:
    Bonjour,
    je viens d'installer ce plugin pour le tester sur un pluxml vierge et il ne fonctionne pas. Impossible d'activer un mot de passe pour un article ou une catégorie.
    Ai-je zapper quelque chose ? L'installation m'a l'air toute simple.
    Merci de ton aide

    Jol5926

    Ce pluggin buggue, je confirme, notamment si on supprime un mot de passe et si on veut ensuite en remettre un. le mot de passe n'est pas pris en compte.
  • Bonjour,

    Pouvez vous me donner plus de détail sur les bugs que vous rencontrez ? Le mot de passe est bien enregistré ? il n'est jamais demandé ? Avez vous des messages d'erreurs, ou des logs ?
    Quels sont vos hébergement ? liste des plugins installé sur vos pluxml ?
    J'ai pas mal tester, sur différente version de pluxml et de serveur web, et je n'ai pas rencontré de soucis.

    Merci pour vos retour.
  • Bonjour,

    Je viens de tester lockArticles avec Pluxml 5.3.1, sur des pages statiques pour l'instant.
    Tout fonctionne parfaitement, même avec des mots de passe très très très compliqués.

    Une suggestion d'amélioration : lorsqu'on affiche le formulaire de mot de passe d'une page avec le template static-full-width.php, faire en sorte de conserver le template static-full-width.php.
    En effet, dans mes tests, le formulaire apparaît dans une page avec le template static.php. Mais peut-être est-ce du à mes nombreuses bidouilles...
    En attendant je me suis permis de modifier dans plugins/lockArticles/lockArticles.php :
    [== PHP ==]
    562                                 $plxMotor->template = 'static-full-width.php';
    

    Mer-ci-beau-coup-pour-ce-plu-gin!
Connectez-vous ou Inscrivez-vous pour répondre.