[plugin] plxMyPager : modifie et améliore les liens de navigations

StéphaneStéphane Membre, Ancien responsable de PluXml
MyPager est un plugin qui vient modifier l'apparence des liens de navigations offrant des nouvelles options pour accèder plus rapidement aux pages.

Plugin disponible ici (pour pluxml 5.1.6 et >)

plxMyPager.png

Historique
## Version 1.2.3 (11/03/2016) ##
BUG Erreur pagination au delà de la page 9 (contribution gegeweb)

## Version 1.2.2 (13/05/2015) ##
[+] Compatibilité PluXml 5.4

## Version 1.2.1 (28/08/2014) ##
[+] Ajout de rel="prev" et rel="next" dans les liens précédent et suivant (contribution Etienne R.)
[+] Ajout traduction en occitant (contribution Rubén)

## Version 1.2 (04/08/2013) ##
BUG Mauvais url de pagination avec la réécriture d'url

## Version 1.1 (15/02/2013) ##
BUG Suppression du duplicate content pour l'url de la page 1

## Version 1.0 (17/04/2012) ##
version initiale

Consultant PluXml

Ancien responsable du projet (2010 à 2018)

«13

Réponses

  • k610ik610i Membre
    Cool !!
  • bien .........bonne continuation
  • marche pas chez moi sur 5.1.5
    plugin activé et tout coché.
    resultat:
    page 1 sur 0

    alors que j'ai 2 pages...
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    plugin pour la 5.1.6

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • ça marche sur la version 5.1.6
  • bg62bg62 Membre
    bonjour ;)
    ce "code" s'affiche ... en bas des quelle(S) page(S) ???
    et ceci automatiquement ou bien y a-t-il une ligne de code à insérer quelque part ?
    @+
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    Partie public du site, partout où il y a une navigation, c'est à dire où l'instruction
    $plxShow->pagination() est utilisée

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • bg62bg62 Membre
    mai 2012 modifié
    Stéphane a écrit:
    Partie public du site, partout où il y a une navigation, c'est à dire où l'instruction
    $plxShow->pagination() est utilisée
    j'ai bien plusieurs 'pages' dans lesquelles j'ai ceci :
    <p id="pagination"><?php $plxShow->pagination(); ?></p>

    et rien ne s'affiche ....

    dans la css j'ai ceci :
    #pagination {
    text-align : center;
    }
    #pagination span {
    margin-right : 0.5em;
    }
    #pagination a {
    color : #555555;
    }
    #pagination a:hover {
    color : #777;
    }

    le problème vient-il de là ???
  • bg62bg62 Membre
    j'ai pris le code d'origine dans le thème par défaut pour repartir sur une bonne base ;)
    merci
    @+
  • juin 2012 modifié
    Bonjour,

    Je suis en version 5.1.6 et les boutons n'apparaissent pas. serait-ce dû à mon thème ? Yallow_blue ?
    J'ai observé des petits bug d'affichage avec certains plugin comme plxMySearch ou plxMyContact. Les dimensions ne sont pas bonnes.

    Merci pour vos réponses.
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    Bonjour
    Il y a de forte chance que cela vienne du css de ton thème.
    Dans ce cas il faut y faire les réajustements nécessaires.
    Pour la pagniation regarde déjà si par exemple dans le fichier home.php tu as la ligne
    <p id="pagination"><?php $plxShow->pagination(); ?></p>
    

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Dommage, c'était un beau thème.
    Suis pas assez calé pour modifier moi-même ce qui ne va pas...
    Merci quand même.
  • Faut pas abandonner comme ça. Tu as un lien vers ton site pour qu'on puisse t'aider ?
  • C'est sur que pour un pro ça doit pas poser de problème.

    Si tu as un peu le temps, voici l'adresse : http://teoufouwak.com

    Quant aux petits problèmes, ils sont les suivants :

    - Les boutons de MyPager n'apparaissent pas du tout sur la page principale, donc je n'ai pas de possibilités de navigation entre les articles.
    - Après c'est juste une question de présentation mais dans la page statique "contact", les boutons sont coupés, ainsi que dans la page recherche.

    Je peux te créer un accès. je te donnerai les codes par MP.

    Merci de me consacrer un peu de temps.

    Arno.
  • Combien as-tu d'articles au total qui ont sont dans la catégorie "page d'accueil". Actuellement je n'en vois que 5. Dans la partie administration, met le chiffre à 2 et dis nous ce qui se passe.

    Pour les mots de passe, je t'enverrai un mail.
  • J'ai 24 articles. La visu est réglée sur 5
  • Est-ce qu'ils ont tous la case cochée "page d'accueil" quand tu es dans le formulaire de modification de l'article ?
  • Alors effectivement, non ! je viens de la cocher sur tous les articles en plus de la catégorie voulue. J'ai réglé la visu sur 2. J'ai désactivé et réactivé le plugin !
    Ca ne change rien.
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    Bonjour
    2 choses à savoir
    - si au moins 1 article est affecté à la catégorie "page d'accueil", seuls les articles de cette catégorie seront affichés sur la page d'accueil.
    - dans la gestion des catégories on peut aussi régler le n° d'articles à afficher par page. Ce paramètrage est prioritaire à celui qu'on trouve dans les paramètres du site dans les options d'affichage.

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Oui Stéphane.

    J'ai remarqué également autre chose. J'ai installé le plugin CKEditor. La barre d'outils apparaît bien dans l'éditeur des articles. La mise en forme fonctionne lorsque j’écris un article. Mais sur le site, il manque des choses comme l'italique, les puces, ...
    J'utilise firefox mais c'est pareil avec IE.
  • Comment puis-je faire pour éviter qu'il ne comptabilise les articles qui sont en planification ? ^^
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    chritchan a écrit:
    Comment puis-je faire pour éviter qu'il ne comptabilise les articles qui sont en planification ? ^^
    Bonjour
    Je vais regarder si c'est un bug (ou pas)

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • StéphaneStéphane Membre, Ancien responsable de PluXml
    ## Version 1.1 (15/02/2013) ##
    BUG Suppression du duplicate content pour l'url de la page 1


    nb: Le problème de pagination avec les articles ayant une date de publication future est un bug de PluXml (Issue 7)

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • ClydClyd Membre
    avril 2013 modifié
    Je constate un dysfonctionnement sur Mypager avec plux5.1.
    Lorsque l'on se trouve sur une categorie ou sur les archives, les liens sur les numeros de page sont corrompus.

    Par: exemple sur les archives 2010, ou sur les catégories.
    sur les numéros de page j'obtiens les liens suivants
    http://www.monsite.com/index.php?archives/2010page2 "et suivantes"
    

    ça ne fonctionne pas lorsque l'on se trouve dans les catégories, impossible de se déplacer vers une page donné.


    Sur le lien "suivante" j'obtiens des liens de cette forme.
    http://www.monsite.com/index.php?archives/2010/page2  "ça fonctionne correctement"
    
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    Bonjour Clyd
    Je vais vérifier tout ça

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Bonjour,
    Je confirme le problème rencontré par Clyd, concernant également les tags.
    Le numéro de page 2 donne :
    http://www.monsite.com/tag/montagamoipage2 
    
    au lieu de
    http://www.monsite.com/tag/montagamoi/page2
    
  • Bonjour,
    J'ai modifié le code pour contourner le bug dans plxMyPager.php :
    [== PHP ==]
    		for($i=$start;$i<=$stop;$i++) {
    			$url = $this->plxMotor->urlRewrite("?".$arg_url."page".$i);
    			$url = str_replace("index.php?page1", "",$url);
    			$url = str_replace("page1", "",$url);
    			$PosPage = strrpos($url, "/page");
    			if($PosPage==FALSE) 
    			    {
    			      $PosPage = strrpos($url, "page");
    			      $url = substr($url, 0, $PosPage)."/".substr($url, $PosPage);
    			    }
    			if($i==$this->plxMotor->page)
    				echo "<span class=\"p_current\">".$i."</span>";
    			else
    				echo "<span class=\"p_page\"><a href=\"".$url."\" title=\"".$i."\">".$i."</a></span>";
    		}
    
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    @Suricat: ça tombe bien je suis en train de mettre à jour certains plugins. Je vais faire le nécessaire pour corriger plxMyPager. Merci

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Si ça peut aider à corriger des bugs, j'ai aussi un problème avec ce plugin.

    Lorsque je suis à cette page : «http://www.carnetb.com/c6/hockey», je vais en bas de page, je clique sur «Page Suivante», j'arrive correctement à la page «http://www.carnetb.com/c6/hockey/page2», puis ensuite, si je clique sur page précédente, ça me mène à cette adresse «http://www.carnetb.com/c6/hockey/page2/», qui créé alors l'erreur de page non trouvée.
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    ## Version 1.2 (04/08/2013) ##
    BUG Mauvais url de pagination avec la réécriture d'url

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

Connectez-vous ou Inscrivez-vous pour répondre.