[plugin] MyMultiLingue

123468

Réponses

  • cfdev a écrit:
    Salut tout le monde :)

    @Stéphane est-ce normal que lorsque l'on passe dans une autre langues dans l'administration pour avoir la liste des articles correspondant,
    toute l'administration prend ce langage... Pourquoi ne pas garder les préférences utilisateur pour le langage de l'administration ?

    Pluxml 5.5 avec plxMyMultiLingue 0.7.2

    Amicalement :)

    Bonjour,

    J'ai exactement le même problème (Pluxml 5.5 avec plxMyMultiLingue 0.7.2). Ce n'est pas très logique comme fonctionnement, on devrait pouvoir choisir la langue au niveau des paramètres de la page ou de l'article. ;-)

    @+

    Fred
  • Bonjour,

    Je rencontre toujours le problème de compatibilité entre le multilingue et betterurls (PluxXML 5.5, MyBetterUrls 1.5.1, MultiLingue 0.7.2) .
    J'ai une erreur 404 sur les pages statiques alors que ça fonctionne sur les articles.

    Y'a-t'il une solution ?

    @+

    Fred
  • Fredouille91 a écrit:
    Bonjour,

    Je rencontre toujours le problème de compatibilité entre le multilingue et betterurls (PluxXML 5.5, MyBetterUrls 1.5.1, MultiLingue 0.7.2) .
    J'ai une erreur 404 sur les pages statiques alors que ça fonctionne sur les articles.

    Y'a-t'il une solution ?

    @+

    Fred

    Finalement, il semble que cela fonctionne, mais la seule manip que j'ai faite, c'est de créer une page dans une autre langue.
  • Promis, c'est mon dernier message de la journée ; je viens de trouver un bug lorsque l'on modifie la configuration du plugin MultiLingue, la langue est ajoutée aux dossiers des articles, pages,... :

    Voici ce que ça donne dans les informations :
    ✔ ../../ est accessible en écriture
    ✔ ../../data/configuration/ est accessible en écriture
    ✔ ../../data/configuration/plugins/ est accessible en écriture
    ✔ ../../data/articles/fr/ est accessible en écriture
    ✔ ../../data/commentaires/fr/ est accessible en écriture
    ✔ ../../data/statiques/fr/ est accessible en écriture
    ✔ ../../data/medias/ est accessible en écriture
    ✔ ../../plugins/ est accessible en écriture
  • StéphaneStéphane Member, PluXml Former Project Manager
    PPmarcel a écrit:
    Bonjour Stéphane,

    Si je suis sur le site dans une langue A et que je vais sur un lien de la langue B, l'interface est bien modifiée.
    En revanche si je clique sur un autre lien de navigation (par exemple une catégorie), je me retrouve de nouveau dans la langue A.

    Est-ce une limitation ou bien un effet de bord ?

    Salut.

    J'ai essayé de reproduire ce que tu décris. Je n'ai pas le problème.
    Quand je clique sur un catégorie après être passé de A vers B en tapant directement le lien d'un article de B à partir de A, je reste bien sur la langue B.

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • StéphaneStéphane Member, PluXml Former Project Manager
    Fredouille91 a écrit:
    Promis, c'est mon dernier message de la journée ; je viens de trouver un bug lorsque l'on modifie la configuration du plugin MultiLingue, la langue est ajoutée aux dossiers des articles, pages,... :

    Voici ce que ça donne dans les informations :
    ✔ ../../ est accessible en écriture
    ✔ ../../data/configuration/ est accessible en écriture
    ✔ ../../data/configuration/plugins/ est accessible en écriture
    ✔ ../../data/articles/fr/ est accessible en écriture
    ✔ ../../data/commentaires/fr/ est accessible en écriture
    ✔ ../../data/statiques/fr/ est accessible en écriture
    ✔ ../../data/medias/ est accessible en écriture
    ✔ ../../plugins/ est accessible en écriture

    C'est normal, ce n'est pas un bug.
    Les articles, commentaires et pages statiques d'une langue ne sont plus stockés dans data/articles/, data/commentaires et data/statiques, mais bien dans un sous-dossier dédié à la langue. data/xxxx/fr/ ou data/xxxx/en, etc...

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Stéphane a écrit:
    C'est normal, ce n'est pas un bug.
    Les articles, commentaires et pages statiques d'une langue ne sont plus stockés dans data/articles/, data/commentaires et data/statiques, mais bien dans un sous-dossier dédié à la langue. data/xxxx/fr/ ou data/xxxx/en, etc...

    Oui, c'est ce que j'ai vu, sauf que du coup, il essaye de lire et écrire les pages dans data/xxxx/fr/en, par ex
    Le plugin ne devrait pas ajouter la langue au chemin de base quand on le configure.
  • StéphaneStéphane Member, PluXml Former Project Manager
    version 0.7.3 (25/10/2016)
    Mise à jour traduction occitane (contribution Quent-in)
    BUG Non prise en compte de langue dans les liens Voir les pages statiques à partir de l'administration

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • StéphaneStéphane Member, PluXml Former Project Manager
    version 0.7.4 (09/11/2016)
    BUG Mauvais chemin vers le dossier des articles sur l'écran: Administration > Configuration avancée

    nb: problème suite à la version 0.7.3. Si vous aviez fait la mise à jour en 0.7.3, la version 0.7.4 est fortement conseillée

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Stéphane a écrit:
    version 0.7.4 (09/11/2016)
    BUG Mauvais chemin vers le dossier des articles sur l'écran: Administration > Configuration avancée

    Super, merci, ça fonctionne :-)
  • Salut Stéphane,

    Je ne sais pas si tu as pris en compte le bug relevé sur le site de Deevad (https://github.com/Pluxopolis/plxMyMultiLingue/issues/5). Grosso modo, si l'envoi du referer est désactivé sur le navigateur, on ne peut pas changer de langue (page introuvable). Le lien généré est du style http://www.peppercarrot.com/lang=xx (avec xx la langue choisie).
    Tu peux tester sur son site en page d'accueil en cliquant sur les boutons de langue après avoir désactivé l'envoi du referer comme indiqué sur github.
  • StéphaneStéphane Member, PluXml Former Project Manager
    @Jerry Wham: j'ai regardé mais je n'ai pas trouvé de solution viable. As-tu une idée ?

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Euh non, j'ai pas eu le temps de regarder. Je viens à l'instant d'en prendre connaissance...
  • StéphaneStéphane Member, PluXml Former Project Manager
    Je viens de me rappeler qu'avec les dernieres modifs en cours j'ai supprimé l'utilisation de $_SERVER["HTTP_REFERER"] donc il ne devrait plus avoir le bug

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Jerry WhamJerry Wham Member
    février 2017 modifié
    Le bug est toujours présent. Désolé.
    Plugin 0.7.4 chargé sur Pluxopolis. Version de PluXml 5.6

    Dans les logs, j'ai :
    [== Indéfini ==]
    Notice:  Undefined index: HTTP_REFERER in /Volumes/Sites/SITES/PLUGIN-THEMES-PLUXML/PluXml5.6/core/lib/class.plx.motor.php(109) : eval()'d code on line 32
    
    
    [== Indéfini ==]
    [18-Feb-2017 12:31:03 Europe/Paris] PHP Stack trace:
    [18-Feb-2017 12:31:03 Europe/Paris] PHP   1. {main}() /Volumes/Sites/SITES/PLUGIN-THEMES-PLUXML/PluXml5.6/index.php:0
    [18-Feb-2017 12:31:03 Europe/Paris] PHP   2. plxMotor::getInstance() /Volumes/Sites/SITES/PLUGIN-THEMES-PLUXML/PluXml5.6/index.php:30
    [18-Feb-2017 12:31:03 Europe/Paris] PHP   3. plxMotor->__construct() /Volumes/Sites/SITES/PLUGIN-THEMES-PLUXML/PluXml5.6/core/lib/class.plx.motor.php:53
    [18-Feb-2017 12:31:03 Europe/Paris] PHP   4. eval() /Volumes/Sites/SITES/PLUGIN-THEMES-PLUXML/PluXml5.6/core/lib/class.plx.motor.php:109
    
    
  • StéphaneStéphane Member, PluXml Former Project Manager
    $_SERVER["HTTP_REFERER"] a été supprimé sur la 0.8
    rien n'a été changé avec la 0.7.4 du multilingue. donc normal que ça bug toujours ;)
    faut prendre la version en cours de dev

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Sorry, j'ai téléchargé le plugin depuis pluxopolis et pas github.
  • NaBiSsNaBiSs Member
    février 2017 modifié
    Je rencontre un conflit de fonctionnement entre plxMyMultilingue et ckeditor.

    Config :
    [list=*]
    [*]Pluxml 5.6 pre 2a[/*]
    [*]ckeditor-4.5.11[/*]
    [*]plxMyMultiLingue-0.7.4[/*]
    [/list]

    Reproduire le défaut :
    - Installer Pluxml
    - Installer les 2 plugins :
    PlxMyMultiLingue => Utiliser un dossier medias différent pour chaque langue : NON & activer English & Français
    ckeditor => Dossier de stockage des fichiers : data/medias/
    - Activer l' URL rewriting
    - Dans un article, insérer une image, puis enregistrer.

    --> Dans le back-office, rien d'anormal, tout fonctionne.
    Par contre en front-office, le lien vers l'image est erroné, la langue (/fr/; /en/) est rajoutée devant le lien du fichier, alors que j'ai activé l'option d'utiliser le même répertoire médias entre les langues.
  • StéphaneStéphane Member, PluXml Former Project Manager
    version 0.8 pre2 dispo

    https://github.com/Pluxopolis/plxMyMultiLingue/releases/tag/0.8pre2

    - suppression du cookie qui posait probleme dans la bascule des langues
    - bug sur l'affichage de l'image d'accroche corrigé (et sur les images + généralement)

    utiliser la version de PluXml 5.6 pre3 car il y avait aussi un bug propre à PluXml dans la réécriture d'url sur les images

    https://github.com/pluxml/PluXml/releases/tag/5.6pre3


    Nouvelle fonctionnalité ajoutée dans la 0.8pre2 de plxMyMultiLingue : utiliser un thème différent pour chaque langue

    1. Dans la configuration du plugin, sélectionner : Utiliser un thème différent pour chaque langue
    2. Basculer sur une langue
    3. Aller dans Paramètres > Themes et choisir le theme à appliquer pour la langue en cours, cliquer sur le bouton "Modifier le thème" pour enregistrer
    4. Refaire les étapes 2 et 3 pour les autres langues

    nb: ne pas oublier de mettre l'appel des différents hooks dans chaque thème

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • J'ai des erreurs PHP qui s'affichent lors d'une installation fraîche PluXML 5.6pre3 + plxMyMultiLingue 0.8pre2 en back-office.

    Les erreurs disparaissent une fois que plxMyMultiLingue est configuré et les langues sélectionnées.
  • StéphaneStéphane Member, PluXml Former Project Manager
    @NaBiSs: peux-tu stp tester avec la pre-release de ce matin et éventuellement me faire un copier/coller des erreurs php
    https://github.com/Pluxopolis/plxMyMultiLingue/releases/tag/0.8pre2b

    Merci

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • @Stéphane : Problème réglé sur PluXML 5.6pre3 + plxMyMultilingue 0.8pre2b, cool !
  • StéphaneStéphane Member, PluXml Former Project Manager
    NaBiSs a écrit:
    @Stéphane : Problème réglé sur PluXML 5.6pre3 + plxMyMultilingue 0.8pre2b, cool !
    merci pour le retour

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Idée au passage, pour éviter de l'oublier.

    Ce serait intéressant de pouvoir traduire les fichiers langues directement dans l'administration de PluXML. Cela permettrait d'en rajouter une sans retourner dans le code pour modifier le tableau PHP.

    Dans l'idée on sélectionne la langue, et toutes les clés sont affichées ('MENU'; 'HOME'; 'CONTENT'...) , suffit ensuite de documenter celles manquantes, avec la possibilité d'en ajouter soit-même.

    Pour avoir mis en place un site multilingue sur Prestashop, j'avais trouvé cette fonctionnalité assez intéressante car elle évite d'aller mettre les mains dans le code (et c'est tant mieux vu l'usine à gaz qu'est ce CMS).
  • StéphaneStéphane Member, PluXml Former Project Manager
    MyMultiLingue 0.8 rc1
    https://github.com/Pluxopolis/plxMyMultiLingue/releases/tag/0.8rc1

    /!\ Nécessite PluXml 5.6 rc1

    PluXml 5.6 rc1
    https://github.com/pluxml/PluXml/releases/tag/5.6rc1

    /!\ Si le plugin MyBetterUrls est utilisé, il doit également être mis à jour pour fonctionner

    MyBetterUrls 1.5.4 rc1
    https://github.com/Pluxopolis/plxMyBetterUrls/releases/tag/1.5.4rc1

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • StéphaneStéphane Member, PluXml Former Project Manager
    MyMultiLingue 0.8 rc2a
    https://github.com/Pluxopolis/plxMyMultiLingue/releases/tag/0.8rc2a

    Corrections:
    - bug: dossier médias différent pour chaque langue
    - bug: hreflang de la page statique mise comme page d'accueil
    - bug: lien dans les dépendances des pages statiques vers une page statique correspondant à une page d'accueil

    /!\ Nécessite PluXml 5.6 rc1

    PluXml 5.6 rc1
    https://github.com/pluxml/PluXml/releases/tag/5.6rc1

    /!\ Si le plugin MyBetterUrls est utilisé, il doit également être mis à jour pour fonctionner

    MyBetterUrls 1.5.4 rc1
    https://github.com/Pluxopolis/plxMyBetterUrls/releases/tag/1.5.4rc1

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • StéphaneStéphane Member, PluXml Former Project Manager
    MyMultiLingue 0.8 rc3
    https://github.com/Pluxopolis/plxMyMultiLingue/releases/tag/0.8rc3

    Corrections:
    - redirection 301 à partir d'url incomplète ex: http://localhost/fr/article1/

    /!\ Nécessite PluXml 5.6 rc2

    PluXml 5.6 rc2
    https://github.com/pluxml/PluXml/releases/tag/5.6rc2

    /!\ Si le plugin MyBetterUrls est utilisé, il doit également être mis à jour pour fonctionner

    MyBetterUrls 1.5.4 rc1
    https://github.com/Pluxopolis/plxMyBetterUrls/releases/tag/1.5.4rc1

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • StéphaneStéphane Member, PluXml Former Project Manager
    MyMultiLingue 0.8 rc4

    https://github.com/Pluxopolis/plxMyMultiLingue/releases/tag/0.8rc4

    - bug perte langue par défaut dans l'administration si modification du paramétrage
    - mauvaise prise en compte des langues dans les flux rss <link>


    /!\ Nécessite PluXml 5.6 rc2

    PluXml 5.6 rc2
    https://github.com/pluxml/PluXml/releases/tag/5.6rc2

    /!\ Si le plugin MyBetterUrls est utilisé, il doit également être mis à jour pour fonctionner

    MyBetterUrls 1.5.4 rc1
    https://github.com/Pluxopolis/plxMyBetterUrls/releases/tag/1.5.4rc1

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • StéphaneStéphane Member, PluXml Former Project Manager
    MyMultiLingue 0.8 rc5

    https://github.com/Pluxopolis/plxMyMultiLingue/releases/tag/0.8rc5

    - bug réécriture des liens sur la page d'édition des pages statiques (administration)

    /!\ Nécessite PluXml 5.6 rc3

    PluXml 5.6 rc3
    https://github.com/pluxml/PluXml/releases/tag/5.6rc3

    /!\ Si le plugin MyBetterUrls est utilisé, il doit également être mis à jour pour fonctionner

    MyBetterUrls 1.5.4 rc1
    https://github.com/Pluxopolis/plxMyBetterUrls/releases/tag/1.5.4rc1

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • StéphaneStéphane Member, PluXml Former Project Manager
    version 0.8 (27/03/2017)
    [+] Compatibilité PluXml 5.6
    [+] Gestion des dépendances entre articles rédigés dans des langues différentes
    [+] Gestion des dépendances entre les pages statiques rédigées dans des langues différentes
    [+] Amélioration de la gestion des liens lors de la bascule des langues
    [+] Langue occitane (contribution Quentin)
    [+] Langue affichée dans les urls sauf pour la langue par défaut
    [+] Message d'information pour activer la réécriture d'url à l'activation du plugin
    [+] (ajout) Configuration plugin > Utiliser un thème différent pour chaque langue
    [+] (ajout) Configuration plugin > Préserver l'affichage de l'interface d'administration avec la langue du profil utilisateur connecté
    [-] (suppr) Configuration plugin > Bascule sur l'article, catégorie ou page statique avec le même identifiant lors du changement de langue.
    [-] (suppr) cookie plxMyMultiLingue pour la sauvegarde de la langue du site visité
    BUG Pas d'affichage des drapeaux coté visiteurs si PluXml installé dans un dossier
    BUG Warning à la création d'une page statique si paramètre "Page d'accueil" non renseigné

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

Connectez-vous ou Inscrivez-vous pour répondre.