[plugin] MyBetterUrls

StéphaneStéphane Membre, Ancien responsable de PluXml
Plugin qui améliore l'écriture des urls de PluXml pour les avoir sous la forme:

Exemples:
http*//monsite.com/mon-premier-article

http*//monsite.com/ma-page-statique

http*//monsite.com/ma-categorie

Possibilité de spécifier une extension pour les pages réécrites: voir écran de configuration du plugin

Exemple:
http*//monsite.com/mon-premier-article.htm

/!\ Requiert la réécriture d'url activée pour fonctionner

Téléchargement

HISTORIQUE
## Version 1.5.5 (10/04/2017) ##
BUG tableau PLX_MYMULTILINGUE non géré avec php 5.x+

## Version 1.5.4 (10/03/2017) ##
[+] Compatibilité plxMyMultiLingue 0.8
Bug flux rss des articles d'une catégorie

## Version 1.5.3 (13/02/2017) ##
BUG Mauvaise prise en compte de la pagination

## Version 1.5.2 (25/10/2016) ##
[+] traduction occitane (contribution Quent-in)
BUG Administration > Pages Statiques : Impossible d'accéder à la page statique à partir du lien Voir

## Version 1.5.1 (12/02/2016) ##
BUG Mauvaise gestion de l'extension dans l'administration du plugin

## Version 1.5 (04/02/2016) ##
[+] Compatibilité PluXml 5.5
[+] Personnalisation du format d'url (voir écran de config du plugin)
BUG mauvaise compatibilité avec le plugin MultiLingue
BUG mauvaise redirection apres envoi d'un commentaire

## Version 1.4.3 (15/12/2015) ##
[+] Gestion des liens http://server.com/?contenu avec redirection 301 vers http://server.com/contenu

## Version 1.4.2 (13/05/2015) ##
+ Compatibilité PluXml 5.4

## Version 1.4.1 (17/03/2015) ##
BUG Pagination avec le plugin plxMyMultiLingue

## Version 1.4 (27/04/2014) ##
[+] Compatibilité avec le plugin plxMyMultiLingue
BUG Pagination

## Version 1.2 (29/08/2013) ##
[+] Redirection 301 si accès à partir des anciennes urls pour favoriser le référencement

## Version 1.1 (29/08/2013) ##
BUG: pas de prise en compte de la pagination en mode categorie

## Version 1.0 (01/05/2013) ##
version initiale

Consultant PluXml

Ancien responsable du projet (2010 à 2018)

«13456

Réponses

  • Je vais tester tout ça cher ami :)
  • Ce plugin assure-t-il la rétro-compatibilité avec les URL existants ?
  • Je pense que oui, je l'ai activé sur mon site et je n'ai pas de problème avec la compatibilité des URL.
  • k610ik610i Membre
    Awesome !

    Stéphane, tu réalises mes rêves les plus fous (on ne se moque pas de mes rêves, je suis quelqu'un de simple ! :D) !
    J'ai hate de tester sur mon site.

    ça marche aussi avec les catégories ?
    http*//monsite.com/ma-catégorie ?
  • k610ik610i Membre
    J'ai craqué, j'ai basculé et ça marche super bien (et sur les catégories aussi).

    Merci beaucoup !
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    you're welcome ;)

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Euh, je ne voudrai pas casser l’ambiance mais j'ai un truc en + , les adresses sont du types avec le plugin activer:
    8.(
    http://<DNS>/index.php?nom-de-l-article

    http://edzeronk.redirectme.net/
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    @EdzeronK: il te faut activer la réécriture d'url

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • J'ai des 404 partout ! :)
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    est-ce que la réécriture d'url est possible sur ton hébergeur ?

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • EdzeronKEdzeronK Membre
    août 2013 modifié
    oui puisse que c'est moi ! :) et j'ai active le mod_rewrite dans Apache2
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    Tu utilises un service de redirection: redirectme ? Si oui je le sens pas trop bien avec ça. Qu'as tu dans le fichier .htaccess au niveau de baserewrite ?

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • non, c'est mon dns, je suis derrière une connexion adsl...

    .htaccess racine :
    # BEGIN -- Pluxml
    Options -Multiviews
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
    # Réécriture des urls
    RewriteRule ^(?!feed)(.*)$ index.php?$1 [L]
    RewriteRule ^feed\/(.*)$ feed.php?$1 [L]
    </IfModule>
    <Files "version">
        Order allow,deny
        Deny from all
    </Files>
    # END -- Pluxml
    

    VirtualHost :
    <Directory "/var/www/blog/">
    Options -Indexes
    AllowOverride None
    Order allow,deny
    Allow from all
    </Directory>
    
  • Au pire, s'avez-vous où es-ce que l'on peut debugé ?
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    @EdzeronK: as-tu essayé sans passer par ton dns

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Oui, je suis en local chez moi (sur une ip).
  • fppfpp Membre
    Bon, celui-ci, quand je l'installe sur mon site hébergé (Lautre.net) et que j'active la réécriture d'URL, j'ai un magnifique "Internal Server Error" et plus d'accès du tout :-)

    Là ça sent la configuration Apache et/ou PHP...
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    @fpp: vérifie d'abord que la réécriture d'url fonctionne avant d'utiliser ce plugin. des pistes: le module d'apache mod_rewrite doit être installé. La directive Options -Indexes dans les fichiers .htaccess ne fonctionne pas sur tous les hébergeurs. Il faut supprimer cette ligne dans tous les fichiers .htaccess que l'on peut trouver dans les différents dossiers de PluXml

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • fppfpp Membre
    août 2013 modifié
    A distance j'ai supprimé le dossier du plugin, récupéré /data/configuration/parametres.xml, remis le paramètre "urlrewriting" à zéro et renvoyé, mais ça n'a pas suffi à rétablir la situation... Il y aurait d'autres modifs dans d'autres fichiers ?...

    Edit: nos posts se sont croisés... merci pour la piste, je vais regarder les htaccess...

    Edit2 : ayé, ça a marché, merci :-)
  • Le plugin est super mais il ne prend pas en compte le plugin plxMyContact dont l'adresse est du style http://monsite.com/contact.
    Je n'ai pas testé mais il faudrait voir si ça le fait aussi avec le plugin d'archives...
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    Jerry Wham a écrit:
    Le plugin est super mais il ne prend pas en compte le plugin plxMyContact dont l'adresse est du style http://monsite.com/contact.
    Je n'ai pas testé mais il faudrait voir si ça le fait aussi avec le plugin d'archives...
    Je viens de tester et je n'ai pas de problème avec le plugin MyContact
    Peux-tu me donner plus d'infos pour que j'arrive à reproduire ton problème. Merci

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Tu peux aller voir là.

    PluXml est en version 5.2. Le plugin MyContact est celui de la Version 1.5.4 (13/06/2013). Le plugin MyBetterUrls est celui de la version 1.0 (01/05/2013).

    S'il te faut plus de renseignements, fais moi signe.
  • JosJos Membre
    Je suis bien content d'avoir ce genre d'url maintenant. Merci Stéphane.
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    @Jerry Wham: ok je viens de voir et comprendre le problème. Tu as ajouter l'extension .html à tes pages
    et tu as http*//site.fr/contact au lieu de http*//site.fr/contact.html
    Je vais voir si y a moyen de résoudre ça

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • Super plugin qui fonctionne très bien.

    Il manque cependant un truc essentiel pour le référencement :
    - Il faudrait une redirection 301 pour chaque URL existante avant la mise en place du plugin afin que google ne trouve pas plusieurs URL pour une même page, ce qui peut être mauvais pour le référencement.

    Je vais tenter de trouver ce qu'il faut mettre dans le htaccess pour automatiser les redirections 301...
  • zetraderzetrader Membre
    août 2013 modifié
    Bonjour, moi j'ai un problème avec le plugin, tout marche bien, sauf un bug que je viens de voir : quand je suis sur une catégorie, quand je passe d'une page à une autre des articles de la catégorie, ça reste sur la 1ère page.
    Vous pouvez voir le problème là :
    http://fr.zetrader.info/paiporta-valencia-espagne (nom d'une catégorie en url raccourcie)
    2ème page de la catégorie en cliquant sur suivant, le contenu reste celui de la 1ère, ça reste en page 1 :
    http://fr.zetrader.info/paiporta-valencia-espagne/page2
    Si je mets page3 à la fin de l'url idem, c'est comme si le paramètre page de l'url ne rentrait pas en compte.
    En revanche, sans être dans une rubrique, depuis la page d'accueil toutes catégories confondues, faire défiler les pages marche bien, le bug se produit quand on veut parcourir les pages d'une catégorie.


    Version de Pluxml : 5.2
    Réécriture d'urls : activé
    Version du plugin : celle du 4 août (téléchargé le 5 août)
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    @zetrader. Merci. j'ai noté le problème et je vais vérifier tout ça

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • @Stéphane : c'est exactement ça. Je n'ai pas de temps actuellement pour essayer de voir d'où ça vient. Si tu peux t'y pencher...
  • zetraderzetrader Membre
    août 2013 modifié
    Bonjour, pas de news au sujet du bug du défilement de pages sur les catégories ? une piste ? Le défilement des pages pour les articles de la page d'accueil n'est pas touché, ainsi que le défilement des pages pour les articles pour un tag donné n'est pas touché non plus, le bug ne touche que les catégories.
  • Je regarde dès que possible
Connectez-vous ou Inscrivez-vous pour répondre.