Sortie de PluXml 5.3.1

La version 5.3.1 de PluXml est disponible.

L'annonce est à lire sur le blog

Télécharger la nouvelle version ici

Le détail dans le changelog

Toute l'équipe vous souhaite une bonne installation ou mise à jour

Consultant PluXml

Ancien responsable du projet

Réponses

  • Merci stef !
  • DenDen Membres
    J'ai mis mon site Web à jour sans problèmes.

    UN TRÈS GROS MERCI À TOUTE L'ÉQUIPE ! {)

    Den
    www.denclout.com
  • joebartjoebart Membres
    mars 2014 modifié
    Bonjour. Bon ben j'ai un souci en essayant de faire la mise à jour : "Security error : invalid or expired token"

    Je suis chez OVH et j'ai tenté de rafraîchir, ça ne change rien.

    Edit : OK, je me suis servi de ce fix trouvé sur le site ICI
    Dany3d a écrit:
    bon je vous dis le secret!...
    Edite le fichier core/lib/class.plx.token.php et remplace toute la fonction la fonction validateFormToken par le code ci dessous:
    /**
    * Méthode qui valide la durée de vide d'un token
    *
    * @parm $request (deprecated)
    * @return stdio/null
    * @author Stephane F
    **/
    public static function validateFormToken($request='') {

    if($_SERVER=='POST' AND isset($_SESSION)) {

    if(isset($_POST) AND !empty($_POST)) {
    if($_SESSION[$_POST] < time() - 3600) { # 3600 seconds
    unset($_SESSION);
    die('Security error : invalid or expired token');
    }

    }
    unset($_SESSION[$_POST]);
    }
    }

    Je suis étonné que ce problème perdure avec cette nouvelle version...
  • @joebart: il ne faut pas rafraichir mais recharger la page. petite nuance qui a son importance au niveau de la sécurité. ouvre une nouvelle fenetre de ton navigateur et accède normalement à ton site.

    Consultant PluXml

    Ancien responsable du projet

  • joebartjoebart Membres
    mars 2014 modifié
    Bonsoir Stéphane,

    J'ai édité mon post précédent en appliquant un fix qui avait été donné, et ça semble avoir marché ;)
    J'avais toujours ce message d'erreur, même en ouvrant une nouvelle page d'accès à mon site...
  • joebart a écrit:
    Je suis étonné que ce problème perdure avec cette nouvelle version...

    Tu es le seul qui semble être bloquer de façon permanente avec le controle des tokens. Je connais plusieurs utilisateurs sur ovh qui n'ont pas de problème. Je ne nie pas que de temps en temps on peut avoir le message "Security error : invalid or expired token", mais il suffit de recharge la page et ça passe.
    Je garde dans un coin ton fix (que je ne connaissais pas ou en tout cas pas souvenir) et je vais l'étudier et le tester.
    Bon tant mieux que ça fonctionne

    Consultant PluXml

    Ancien responsable du projet

  • Site mis à jour depuis quelques minutes également. ;)

    Merci ! :)
  • cpalocpalo Membres
    Bonjour

    Je viens de faire la mise à jour sur une version en local ( refonte de mon site perso) donc ça tombe bien. J'ai installé la nouvelle version et j'ai récupéré mes data et thème.
    Et là il m'a redemandé de faire une mise à jour.
    Aucun problème.

    Par contre j'ai deux sites en ligne. Pour la mise à jour j'envoie par ftp la nouvelle version qui écrasera celle qui est en ligne? ( naturellement je sauvegarde mon dossier data). Est-ce que les fichiers du thème par défaut ont été modifiés?

    Cordialement
  • cpalo a écrit:
    Par contre j'ai deux sites en ligne. Pour la mise à jour j'envoie par ftp la nouvelle version qui écrasera celle qui est en ligne? ( naturellement je sauvegarde mon dossier data). Est-ce que les fichiers du thème par défaut ont été modifiés?

    Cordialement

    Oui les fichiers du theme par défaut ont été modifiés (cf le changelog de la 5.3.1)

    N'uploade pas les dossiers data, plugins et themes pour faire la mise à jour de tes sites.

    Consultant PluXml

    Ancien responsable du projet

  • JosJos Membres
    J'ai très peu modifié le thème par défaut, j'ai juste corrigé quelques bugs qui trainaient. La 5.3.1 étant une version intermédiaire, pas de gros changement de ce coté là. Un nouveau thème est prévu pour la 5.4.
  • Stéphane a écrit:
    La version 5.3.1 de PluXml est disponible.

    L'annonce est à lire sur le blog

    Télécharger la nouvelle version ici

    Le détail dans le changelog

    Toute l'équipe vous souhaite une bonne installation ou mise à jour

    OMG Thanks so much!! :). I have just updated my blog. Everything went perfect. ;)
  • StephenTaylor a écrit:

    OMG Thanks so much!! :). I have just updated my blog. Everything went perfect. ;)

    You're welcome!

    Consultant PluXml

    Ancien responsable du projet

  • 'jour !

    J'ai fait deux mises à jour : depuis une 5.2 et depuis une 5.3
    Aucun souci !
    Merci :)
  • fanyfany Membres
    Bon(jour/soir),
    Hier, j'ai effectué la mise à jour (première mise à jour depuis mon installation) dans ma version du site en local pour m'entraîner.
    J'ai juste du remettre ma feuille de style.
    Par contre les tags des articles ont disparus sauf celui du dernier article (je ne comprend pas comment cela a pu arriver, j'ai du faire une fausse manipulation). J'imagine qu'en les rajoutant à la main cela devrait régler le problème sinon je les rajouterai dans tags.xml directement.

    Ce soir, je voulais mettre à jour la version du site en ligne. Via ftp, je me suis dis que je remplacerai les dossiers /configurations /statiques et index.html.
    Et quand je me rends sur l'url de mon site, cela me propose d'effectuer la mise à jour depuis le backoffice (première surprise) et ensuite cela m'indique une erreure (je ne l'ai pas noté mais de mémoire il s'agissait d'un problème de mot de passe manquant).

    J'ai remis le bakcup en ligne en attendant de comprendre le soucis.

    Quelle serait la procédure pour mettre à jour un pluxml sachant que j'ai une version locale que je balance via ftp (et que ma version locale est nickel, elle). Est-il préférable d'envoyer tout mon site local plutôt que certains dossiers (mal choisis peut être) ?
  • Bonjour,

    Avant de faire la mise à jour, vérifie que tu as supprimé les dossiers update sur ton site local et sur ton site en ligne.
    S'il y a des modifs sur ton site en ligne rapatrie le dossier data sur ton site local pour avoir les 2 sites synchronisés
    Fais la mise à jour sur ton site local. Vérifie que tout baigne.
    Supprime le dossier update.
    Synchronise ton site en ligne par ftp.
    Evidemment on fait des sauvegardes avant au cas où cela tourne mal.

    P.S. : le fond vert sur ton site est assez fatigant à voir. Si tu tiens au vert, une couleur plus froide serait plus supportable. Par exemple, DarkSeaGreen ou #8FBC8F en ligne 116 de main.css. Avec Firefox, l'add-on ColorZilla fournit une palette de couleurs pour aider au choix.

    Cordialement
  • JosJos Membres
    Bon c'est vrai que c'est un peu hors sujet, mais il est vrai que le fond vert fait mal aux yeux ;).

    Après avoir suivi les explications complètes de @bazooka07, n'hésite pas à nous faire une remontée pour nous dire si tous vas bien ou si tu rencontre d'autres soucis concernant la mise à jour de PluXml.
  • j'ai fait une mise à jour depuis une version 5.1.6 vers 5.3.1 (oui, c'est pas bien !) , sans problèmes particuliers
  • JosJos Membres
    Rohirrim a écrit:
    j'ai fait une mise à jour depuis une version 5.1.6 vers 5.3.1 (oui, c'est pas bien !) , sans problèmes particuliers

    La mise à jour est prévu pour les versions antérieures donc pas de soucis ;).
  • fanyfany Membres
    bazooka07 a écrit:
    Bonjour,

    Avant de faire la mise à jour, vérifie que tu as supprimé les dossiers update sur ton site local et sur ton site en ligne.
    Jos a écrit:
    Après avoir suivi les explications complètes de @bazooka07, n'hésite pas à nous faire une remontée pour nous dire si tous vas bien ou si tu rencontre d'autres soucis concernant la mise à jour de PluXml.

    Bonjour,
    Je viens de réaliser à nouveau la manip. Aucun problème cette fois-ci. J'ai fait un peu différemment mais je ne suis pas certaine de la raison qui a provoquée mon erreure la première fois. Pas grave...

    PS : Devant les critiques sur le fond vert, j'ai modifié le fond et du coup cela m'a amené à modifier aussi le reste...

    Merci encore pour votre aide (et soutient) !
  • Ce n'était pas des critiques, mais des conseils avisés :D

    C'est un plus reposant pour les yeux en tout cas.
    Evite de trop te disperser dans les couleurs. Vert d'un côté et bleu de l'autre, c'est un peu le grand écart pour des couleurs qui se marient mal.

    Par contre pour le logo : <img height="36" src="http://localhost/pluxml/themes/defaut/img/liberathon.png"></img>, ça va pas le faire avec localhost sur Internet :(
Connectez-vous ou Inscrivez-vous pour répondre.