[SPXWRESPONSIVESLIDES] Slider responsive administrable

je-evrardje-evrard Membre
juin 2016 modifié dans Plugins
Ce plugin va vous permettre d'administrer l'affichage de un ou plusieurs sliders responsive.

spxwresponsiveslides.jpg

Une petite demo d'affichage : ici

Chaque slide est composé de :

[list=*]
[*]une image[/*]
[*]un titre (optionnel)[/*]
[/list]

Note importante :

Ce plugin, d'un genre nouveau, est utilisé comme widget du plugin spxdatas.

Pour rappel : spxdatas permet la gestion et l'administration de données structurées (widgets).

Vous devrez donc avoir installer au préalable le plugin spxdatas version officielle dans le dossier plugin de pluxml. Pour la configuration de spxdatas, c'est extrèmement simple... voir la configuration simplissime ici.

il est indispensable d'obtenir une version de spxdatas >= 1.60.

Voici a quoi ressemble l'administration du slider :

widget6.jpg


Caractéristiques :

[list=*]
[*]intègre la librairie responsiveslides[/*]
[*]administration via widget (un ou plusieurs slider)[/*]
[*]configuration complète via shortcodes[/*]
[*]possibilité de fixer les droits de lecture, création, modification, suppression selon le niveau d'admin[/*]
[*]une aide soignée[/*]
[*]nécessite le plugin spxdatas version >= 1.60 et spxshortcodes[/*]
[/list]

Voici les possibilités de customisation via shortcodes
[== Indéfini ==]
extract(shortcode_atts(array(
		'id' => '',
 		'title' => '',
		
		'width'=>'100%', 
		'pos'=>'',
		'displaytitle'=>'true',
		'displaythumbs'=>'false',
		'colortheme'=>'light',
		
		'auto' =>  'true',             
		'speed' =>  '500',            
		'timeout' =>  '4000',          
		'pager' =>  'false',           
		'nav' =>  'false',             
		'random' =>  'false',          
		'pause' =>  'false',           
		'pauseControls' =>  'true',   
		'prevText' =>  "Previous",  
		'nextText' =>  "Next",       
		'maxwidth' =>  "",          
		'navContainer' =>  "",       
		
		'namespace' => "rslides"
		
		
 	), $atts));


Niveau d'usage : facile

Compatible : pluxml 5.1.7 - 5.2 - 5.3 - 5.3.1 - 5.4

spxwresponsiveslides 1.5 version officielle

Note: le plugin est disponible via le spxpluginDownloader

Ne pas hésiter si vous avez des questions...

Réponses

  • DudyDudy Membre
    octobre 2015 modifié
    La voilà enfin bravo je je
    Très belle les photos
    Bravo ca c'est du bon travail
    Si jamais est aussi compatible 5.3.4
  • @je-evrard

    super comme d'habitude, un gros travail pour la communauté
  • kowalskykowalsky Membre
    octobre 2015 modifié
    @je-evrard

    Il y a un bout de ton code qui nécessite de charger un script externe pour que cela fonctionne. :(
    http://desandro.github.io/imagesloaded/imagesloaded.pkgd.js
    

    Par sécurité, il serait mieux d'intégrer cela en local.
  • je-evrardje-evrard Membre
    octobre 2015 modifié
    @Dudy

    C'est surtout ton thème qui est magnifique. Merci encore à toi.

    @DjbWebmaster

    Merci. J'adore tes plugins personnellement tu as pensé a intégrer la liste des dépots de plugin ?

    @kowalsky

    J'ai codé le plugin en 4 heures ce week pour voir si c'était possible de faire vite. Je dois régler certain détails. Pas de soucis.
  • **** v 1.4. ****
    - mod help plugin for pluxml 5.5
  • **** v 1.5. ****
    - issue : fix issue for help

    Vous pouvez mettre à jour facilement via le spxplugindowloader
  • Bonjour,
    je me demandais si ce plugin est compatible avec PluXml 5.6, tout se passe bien au niveau de la configuration de mon diaporama via le widget, mais quand je veux afficher le diaporama (via $plxShow->callHook...) rien ne s'affiche...
    Merci et bonne journée !
Connectez-vous ou Inscrivez-vous pour répondre.