[Plugin] kzGallery : Afficher une ou plusieurs galeries de photos

bazooka07bazooka07 Membre
mai 2018 modifié dans Plugins
Bonjour,

Ce plugin permet d'ajouter une ou plusieurs galeries de photos dans un article ou une page statique.

Dans le gestionnaire de médias, créer un dossier et jeter y toutes les photos pour la galerie.
Cliquer sur le bouton copier à côté de la liste déroulante des dossiers
aller dans la page d'édition de l'article
2 possibilités :
en bas de la page, cliquer sur le bouton coller pour sélectionner votre dernier choix dans la liste déroulante des dossiers pour la galerie ou modifier votre choix avec la liste déroulante. La galerie sera ajoutée à la fin de l'article.
sinon afficher le code HTML de la page placer le curseur à l'endroit où il faut insérer la galerie appuyer sur les touches Ctrl-c pour recopier le code HTML qui va bien depuis le presse-papier. Ajouter dans l'article autant de galeries que nécessaire.

Pour les pages statiques, afficher le code HTML/PHP et procéder de la même façon que pour un article.

Le plugin utilise la librairie Lightbox2 par défaut pour afficher le diaporama des photos. Ce choix est désactivable.
Idem on peut afficher un titre (figcaption) et encapsuler la vignette dans un lien A.

Télécharger la dernière version du plugin

Démo ici

2018-05-09 : version 0.8.3 : diverses corrections
2018-04-09 : version 0.8.2 : correction bug pour page statique et dans le copiez-collez du gestionnaire de médias
2018-03-22 : version 0.8.0 : 1ère release

Réponses

  • Intéressant, ce plugin, à tester !

    Merci bazooka07 :)
  • Excellent !

    Mais il faudrait rajouter bien visible dans l'aide que le répertoire visé doit aussi contenir les vignette miniatures.

    Autrement, vraiment cool et pratique. :)
  • Beau site d'échec bravo !
  • Salut,
    Je suis en train de tester le plugin, mais j'ai un soucis sur une page statique ... :/
    Ma galerie ne s'affiche pas, et quand je regarde le code source de ma page, il manque dans l'URL de lightbox.min.css le dossier plugin/kzGallery
    Voilà ce que je vois dans la source de cette page :
    <link rel="stylesheet" href="http://monsite.com/pluxml/lightbox2/css/lightbox.min.css" />
    
    Une solution ?
    Merci ! ;)
  • bazooka07bazooka07 Membre
    avril 2018 modifié
    @Noogaty,
    J'ai corrigé 2 ou 3 petits bogues qui mettaient le bazar.

    Supprime le plugin et installe la version 0.8.2

    @Jack31,
    J'ai rajouté un paragraphe dans l'aide

    @je-evrard,
    Merci.
    Le site s'étoffe au fil des années et des besoins.
  • bazooka07 a écrit:
    @Noogaty,
    J'ai corrigé 2 ou 3 petits bogues qui mettaient le bazar.

    Supprime le plugin et installe la version 0.8.2
    Bon, il y a du mieux, la galerie s'affiche, mais sans lightbox ... Juste les miniatures avec liens vers les grandes ...
    Et toujours le même problème cité plus haut ...(http://monsite.com/pluxml/lightbox2/css/lightbox.min.css)

    Par contre, je viens de voir que les photos doivent être dans un dossier, dans le dossier "medias". Sauf que de mon coté, mon dossier ne s'appelle pas "medias", mais "media" sans "s". C'est un Pluxml que j'ai mis à jour (5.6), et j'avais mis sans le "s". Et pas trop envie de renommer le dossier car pas mal d'adresse de photos à changer ... :/
    Ca vient peut-être de là ? Peut-être configurer le plugin pour qu'il prenne le dossier enregistré dans "configuration avancé", "Emplacement des médias (dossier) :" ?

    PS: ton dernier lien n'est pas bon, mais celui du premier post est bon.
  • bazooka07bazooka07 Membre
    avril 2018 modifié
    Pour le lien de téléchargement c'est corrigé.

    Le dossier à afficher pour la galerie doit être placé dans le dossier indiqué dans "Emplacement des médias (dossier)" affiché dans la page "core/admin/parametres_avances.php".

    Quand tu es dans la page des médias, en cliquant sur le bouton copier à côté de la liste des dossiers, le bout de code à ajouter dans la page statique est copié dans le presse-papier.
    Tu peux l'afficher en le collant dans n'importe quel éditeur de code.

    Pour le lien vers la feuille CSS de Lightbox2, je ne comprends d'où cela vient.

    J'ai fait une install neuve chez Free.fr et aucun souci même si on renomme le dossier "data/medias" en "data/photos"
    http://kazimentou.free.fr/

    Ton site est en ligne ?
    Tu avais quelle version de PluXml avant la 5.6 ?
  • Je ne sais plus trop la version ... 5.1 ou dans le genre ...
    Je t'envoie le lien du site en MP, ce sera plus simple ! ;)
    C'est pas urgent ! :)
  • Je soupçonne un conflit avec un autre plugin ou le thème.

    Il faut déjà corriger les erreurs qui existent
    Dans ton navigateur (Firefox ou Chrome, ..) appuye sur la touche F12 pour ouvrir l'inspecteur web et clique sur l'onglet console pour afficher les messages d'erreurs :
    [== Inspecteur Web ==]
    TypeError: $.Isotope is undefined[En savoir plus]
    isotope-article.js:14:1
    Échec du chargement pour l’élément <script> dont la source est « http://ton-site.com/pluxml/lightbox2/js/lightbox-plus-jquery.min.js ».
    
    D'après ce que je vois tu as désactivé lightbox2 dans kzGallery. Ce n'est pas un problème si un plugin ou le thème le charge correctement. Ce qui n'est pas le cas

    Pour reprendre le lien vers la feuille de style que tu as donné précèdemment
    [== HTML ==]
    <link rel="stylesheet" href="http://monsite.com/pluxml/lightbox2/css/lightbox.min.css" />
    

    Cela ne correspond pas kzGallery. Le lien généré par ce plugin est :
    [== HTML ==]
    <link rel="stylesheet" href="http://mon-site/plugins/kzGallery/lightbox2/css/lightbox.min.css" />
    
    Donc il manque les dossiers plugins/kzGallery dans le lien que tu donnes.

    Tu utilises le thème pluxmag et le plugin plxResponsiveSlidesJs. Il y a peut-être un conflit avec l'un d'eux mais je ne les connais pas. Donne moi les liens de téléchargement pour les deux si tu n'arrives pas à régler le problème.

    Il y a d'autres soucis par ailleurs quand on affiche le code source de la page html en appuyant sur la touche Ctrl-U: balises en rouge orphelines ou mal fermées.
  • noogatynoogaty Membre
    avril 2018 modifié
    Tu as raison !

    C'est bien un conflit avec le plugin plxResponsiveSlidesJs !

    Quand je le désactive, cela fonctionne très bien.

    Je sais que j'ai encore quelques erreurs à corriger dans le code, je suis en train de refaire ce site. ;)

    Voilà le lien du plugin qui cause problème : http://forum.pluxml.org/viewtopic.php?id=4257

    J'espère pouvoir résoudre le problème car j'aime bien ton plugin de galerie simple et efficace.

    Ou je vais essayer de trouver un autre plugin slideshow pour remplacer plxResponsiveSlidesJs qui cause problème ...


    Edit : j'ai parlé trop vite ! En fait, cela fonctionne avec plxResponsiveSlidesJs mais il faut que ton plugin soit placé plus haut dans la liste des plugin ! Si il est en dessous, erreur ...
  • Hello à tous, :)

    J'ai instrallé la 0.8.2

    @Bazooka, je me demande si cela ne serait pas plus clair en proposant...

    Utiliser lightbonx2 : Oui/Non
    Voulez-vous un lien vers les images ? : Oui/Non
    Voulez-vous le titre des images ? : Oui/Non

    Cela dit, F12 me donnait comme erreur...
    [== Indéfini ==]
    Échec du chargement pour l’élément <script> dont la source est « http://claudio-liberman.reseauk.info/lightbox2/js/lightbox-plus-jquery.min.js ».
    

    J'ai désactivé et reactivé mes plugins un à un et tout est redevenu normal.
  • Bonjour,

    merci pour ce plugin que j'aimerais utiliser afin de pouvoir utiliser plusieurs diaporamas différents sur mon site (ce que je n'arrive pas à faire avec MySlippry).

    Le bouton "Copier" qui s'ajoute dans la page 'Gestion des medias' après installation du plugin reste grisé quand je sélectionne le dossier contenant mes images, donc pas possible d'avoir le code à copier... une idée ?

    J'ai tout désactivé (y compris Lightbox2) dans la configuration. Cette librairie Ligtbox2, il fautl'installer ? Et si oui comment ?

    En utilisant <div data-gallery="/mon-repertoire-diapo/"> copié directement dans ma page statique ça ne fonctionne pas non plus.

    Merci et bonne journée !

    Guillaume
  • guillaumix a écrit:
    Bonjour,

    merci pour ce plugin que j'aimerais utiliser afin de pouvoir utiliser plusieurs diaporamas différents sur mon site (ce que je n'arrive pas à faire avec MySlippry).

    Le bouton "Copier" qui s'ajoute dans la page 'Gestion des medias' après installation du plugin reste grisé quand je sélectionne le dossier contenant mes images, donc pas possible d'avoir le code à copier... une idée ?

    J'ai tout désactivé (y compris Lightbox2) dans la configuration. Cette librairie Ligtbox2, il fautl'installer ? Et si oui comment ?

    En utilisant <div data-gallery="/mon-repertoire-diapo/"> copié directement dans ma page statique ça ne fonctionne pas non plus.

    Merci et bonne journée !

    Guillaume

    Salut guillaumix, je pense que c'est dû à la génération des miniatures qui est nécessaire pour ce script. Essaie de les générer à nouveau pour voir.

    Bazooka, Le plugin est-il adapté pour revoir plusieurs galeries à différents endroits de la page ? J'ai l'impression que non.
  • IronIron Membre

    Bonjour,

    Je viens d'installer et de tester ce plugin en créant un seul et unique dossier nommé "mk11" pour un test. (je suis chez Free)

    Ça marche impeccable. Sauf que si je créé un second article (ou tout autre article et même des articles déjà créés), le dossier "mk11" est sélectionné par défaut pour la galerie sans pouvoir indiqué autre chose (je ne veux pas de galerie dans cet article).

    Comment y remédier ?

    Merci à vous de vos retours.

Connectez-vous ou Inscrivez-vous pour répondre.