[Résolu] artChapo ne veut pas cacher le chapo

PPmarcelPPmarcel Membres
juillet 2018 modifié dans Bogues
Bonjour,

Sur mes pages de listing des articles (home, catégories, tags, etc), je ne voudrai afficher que le titre des articles ainsi que le lien pour aller dans l'article.

J'ai donc utilisé artChapo ainsi : <?php $plxShow->artChapo('Lire la suite',false); ?>
Mais je constate que j'ai toujours le contenu du chapo affiché. Le false n'a aucun effet.

J'utilise bien le thème sur lequel je travaille, je n'ai aucune erreur dans les logs de mon serveur web.

Quelqu'un observe-t-il le même comportement ?

PluXml version 5.6
Version de PHP : 7.0

Besoin d'idées d'évasion en France et ailleurs ? C'est ici, sur frenchvadrouilleur.fr !

Réponses

  • PPmarcelPPmarcel Membres
    juillet 2018 modifié
    Ah j'ai trouvé, dans le code il est écrit : "content: affichage oui/non du contenu si le chapô est vide".

    Donc en gros comme mes chapo ont toujours du texte, il sera toujours affiché quoique je fasse. Je suis visiblement parti du mauvais côté.

    Il faut donc que je créé mon bouton dans le thème et que j'utilise la fonction artUrl à la place.

    Besoin d'idées d'évasion en France et ailleurs ? C'est ici, sur frenchvadrouilleur.fr !

  • Bonjour,

    Il faut faire $plxShow->artTitle('link') dans une boucle d'articles comme dans le fichier home.php du thème par défaut.
  • Salut Bazooka,

    J'avais regardé cette fonction en début d'après-midi. Mais j'ai déjà le titre qui l'utilise. Il me fallait juste régler le problème du gros bouton "lire la suite" en dessous, qui nécessitait artUrl quant à lui.

    Maintenant tout roule comme je le voulais. ;)

    Besoin d'idées d'évasion en France et ailleurs ? C'est ici, sur frenchvadrouilleur.fr !

Connectez-vous ou Inscrivez-vous pour répondre.