Bug d'affichage plxtoolbar et plxeditor avec pluxml 5.7

zetraderzetrader Membre
28 janv. modifié dans Bogues
Hello les pluxmliens, j'ai voulu tester la dernière version de pluxml (5.7) dans un répertoire, avant éventuellement de migrer vers celle-ci, et sur une installation toute fraîche de test, j'ai mis le plugin plxeditor pour pouvoir rédiger des articles de test, les icônes se trouvent alors buggés à l'affichage, je désactive, j'essaie ensuite plxtoolbar, même chose, ce sont les dernières versions de ces plugins.
Je me dis alors que c'est peut-être mon hébergeur (1and1 devenu ionos) mais je ne comprends pas parce qu'en parallèle, j'ai du pluxml 5.5 installé, pour lesquels ces plugins marchent bien, et je me souviens qu'en testant pluxml 5.6 je n'avais pas rencontré de problème avec ces plugins.
Je refais l'installation avec pluxml 5.7 et les plugins, même binz, je supprime le cache, je relance, toujours ces bugs d'affichage.
J'ai alors l'idée d'essayer avec un pluxml 5.5 vierge dans un dossier : pas de bug d'affichage pour ces plugins.
Je tente ensuite avec un pluxml 5.6 vierge dans un dossier : idem, pas de bug d'affichage pour ces dossiers.
Quelqu'un sait d'où ça peut venir ce problème avec Pluxml 5.7 ?

EDIT
Une copie d'écran sera peut-être plus parlante si vous ne voyez pas le problème, là c'est avec plx editor avec chrome, mais le problème est similaire avec plxtoolbar :
bug-affichage-plx-editor-pluxml-5.7-chrome.jpg
Sous plxtoolbar, avec firefox :
bug-affichage-plx-toolbar-pluxml-5.7-firefox.jpg
J'ai essayé les 2 sous chrome ou firefox, aucun des deux ne s'en sort mieux.

Nota : j'ai une préférence pour plxtoolbar, car en essayant plx editor et ckeditor, ces 2 autres ne respectent pas le code html mis à la main, si on change du code à la main, celui-ci est ensuite modifié / déstructuré en modifiant l'article avec l'éditeur, plxtoolbar ne fait pas ça.

Réponses

  • GzygGzyg Membre
    29 janv. modifié
    J'ai la même chose mais comme je n'utilise que deux fonctionnalités (médias et plein écran) je les ai vite repérées (5e et 4e en partant de la fin) et j'ai renoncé à hercher une solution et donc à faire un post... :lol:

    Merci de l'avoir fait. ]:D
  • De rien, j'ai aussi hésité à le reporter, mais après tout je me suis dit, c'est peut-être mieux que les gens le sachent, et qui sait, peut-être quelqu'un verra une solution facile à ce problème ;)
    Je me demande si cela peut venir du changement de version de PluCSS, en effet entre la version 5.7 et 5.6, un des différences c'est qu'on passe de PluCSS 1.2 à PluCSS 1.3 :
    https://www.pluxml.org/download/changelog.txt
    Mais bon c'est juste une hypothèse, je ne sais pas si PluCSS change quelque chose côté admin ou si c'est juste côté visiteurs.
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    Bonjour

    J'ai corrigé le problème d'affichage des icônes sur les 2 plugins.
    Les sources sont à récupérer ici:

    plxtoolbar v.1.5: https://github.com/Pluxopolis/plxtoolbar/releases
    plxEditor v1.6: https://github.com/Pluxopolis/plxEditor/releases

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • GzygGzyg Membre
    Merci Stéphane, ça fonctionne nickel pour les deux ! :)

    [HS] Toujours aussi réactif malgré la "retraite" ;) [/HS]
  • Un grand merci aussi à Stéphane, qui reste impressionnant de réactivité :)
  • zetraderzetrader Membre
    29 janv. modifié
    Je viens d'essayer plxtoolbar 1.5, cela s'affiche bien maintenant les icônes, mais il en manque quelques unes par rapport à plxtoolbar 1.4.1, les 4 boutons finaux sont manquants :
    - vidéo youtube
    - insérer tabulation
    - smilies
    - couleur

    EDIT : testé sous chrome et firefox et vidé le cache, ces 4 icônes n'apparaissent pas.
    Par contre en survolant avec la souris, je me rends compte qu'ils sont là mais invisibles, en blanc sur fond blanc, et dans l'ordre couleur, vidéo youtube, insérer tabulation, smilies.
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    @zetrader: c'est corrigé

    plxtoolbar v.1.5.1: https://github.com/Pluxopolis/plxtoolbar/releases

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • zetraderzetrader Membre
    30 janv. modifié
    Je viens de tester plxtoolbar 1.5.1, c'est nickel, toutes les icônes apparaissent bien maintenant, je voulais faire le pouce levé dans les smileys, je ne le trouve pas mais l'idée est là : bravo et merci ;)
    Sinon je n'ai pas testé pour plxeditor, si il y a le même bug des quelques icônes manquants, tu veux que je teste ?
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    zetrader a écrit:
    Sinon je n'ai pas testé pour plxeditor, si il y a le même bug des quelques icônes manquants, tu veux que je teste ?

    Avec plaisir. Merci

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • zetraderzetrader Membre
    30 janv. modifié
    Je viens de tester avec plxeditor 1.6, pas de problème, aucun icône manquant.
    Le seul reproche par rapport à plxtoolbar, c'est que cela modifie le code html mis à la main et rajoute beaucoup de div là où des <br /> suffiraient. D'ailleurs en parlant de br, si on met du <br /> pour aller à la ligne, ce qui est la syntaxe correcte au niveau html, cela le change par <br> (syntaxe incorrecte théoriquement puisque toute balise ouverte doit être ensuite fermée, j'imagine que tu sais, bon c'est pas dramatique non plus puisque visiblement tous les navigateurs interprètent bien <br>) et cela l'entoure éventuellement de <div></div> ce qui fait facilement un paquet de balises <div> pour un petit texte.
    Bon cela dit c'est mieux que que ckeditor qui fait systématiquement des <p> pour le retour à la ligne, ajoutant systématiquement des espaces.
    Sinon j'ai pas testé l'intégration youtube sur plxeditor, est-ce que c'est mieux que plxtoolbar au niveau responsive design ? Je vais essayer pour voir, parce qu'avec plxtoolbar, il m'a semblé que cela débordait un peu sur le mobile la vidéo intégrée youtube.

    EDIT : je viens de tester l'intégration youtube avec le bouton youtube des dernières versions de plxtoolbar et plxeditor, c'est plxeditor qui s'en sort le mieux sur pc et sur mobile.
    1) sur pc, [del]la vidéo youtube est plus grande, sans déborder, avec plxeditor (s'adapte mieux à la taille disponible de l'écran)[/del], en actualisant, les vidéos font la même taille
    2 ) sur smartphone, la vidéo youtube est trop grande avec plxtoolbar, et déborde sur le côté (même en actualisant), alors que plxeditor l'a ajusté pour être à la bonne taille, ne pas déborder

    Finalement il n'est pas si mal ce plxeditor, et il a l'avantage de faire les retours à la ligne tout seul (pour plxtoolbar, c'est assez basique, on rajoute soi-même les retours à la ligne, soit en faisant le br à la main, soit avec le bouton qui fait des <br />, l'ajout automatique des <div></div> économise au moins le geste de faire les retours à la ligne.
  • StéphaneStéphane Membre, Ancien responsable de PluXml
    en html5 <br> est parfaitement valide.
    en xhtml on utilise <br />, car il oblige d'avoir la balise de fermeture

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

Connectez-vous ou Inscrivez-vous pour répondre.