problème avec mise à jour

webassowebasso Member
février 2019 modifié dans Entraide
Bonjour,
je viens de mettre à jour mon site http://spirit.ouvaton.org/ avec la dernière version de PluXml comme indiqué ici https://wiki.pluxml.org/installer/installation/ en gardant le dossier /httpdocs/themes/defaut_ok puisque c'est ce thème là qui est utilisé

j'ai aussi mis à jour le plugin share_me 1.2.1

Le problème est que sauf la page contact, mes pages statiques dans le menu horizontal ne fonctionnent pas... seul leur titre apparait

J'ajoute que tout ce qui concerne les liens Facebook ne fonctionnent pas non plus, les pages sur lesquelles jusqu'à présent des posts FB étaient présents montrent un espace blanc à la place...

Quel est le problème et comment le régler svp ?

Réponses

  • Tu pourrais mettre un exemple de code d'une de tes pages statiques ?
  • Bonjour,
    Voilà ce que j'ai sur le fichier static.php
    [== Indéfini ==]
    <?php include(dirname(__FILE__).'/header.php'); ?>
    
    	<main class="main">
    
    		<div class="container">
    
    			<div class="grid">
    
    				<div class="content col sml-12 med-8">
    
    					<article class="article static" id="static-page-<?php echo $plxShow->staticId(); ?>">
    
    						<header>
    							<h2>
    								<?php $plxShow->staticTitle(); ?>
    							</h2>
    						</header>
    <?php eval($plxShow->callHook('share_me')); ?>
    						<?php $plxShow->staticContent(); ?>
    
    					</article>
    
    				</div>
    
    				<?php include(dirname(__FILE__).'/sidebar.php'); ?>
    
    			</div>
    
    		</div>
    
    	</main>
    
    <?php include(dirname(__FILE__).'/footer.php'); ?>
    
  • Il semble que le plugin share_me soit en cause.
  • Bonjour,
    ... Une idée de comment ça se règle ?
  • Jerry WhamJerry Wham Member
    février 2019 modifié
    Poster un message au dév du plugin ?
  • Je regarde cela ce week-end ( Un peu trop pris par mes obligations professionnelles pour faire cela en semaine ).
  • garys02garys02 Member

    Est-ce que le plugin marche chez-vous ?
    v1.2.1 avec pluxml 5.8.3 et php 7.3
    Fatal error: Uncaught Error: Call to undefined method share_me::_getStaticContent() in /home/clients/d737c40ccb48c0d5ee571cf62c8c925e/........ /plugins/share_me/share_me.php on line 670

    Merci

Connectez-vous ou Inscrivez-vous pour répondre.