Difficulté d'accès à la page d'administration

yanstvyanstv Membre
Bonjour à tous,

Je n'arrive pas à me connecter dans la page administration sur Pluxml après avoir rempli le formulaire de pour admin.

Lorsque je rempli le formulaire de connexion qui est à cette adresse: http://icietlabas.cm/new/blog/core/admin/auth.php?p=/new/blog/core/admin/ , quand j'appui sur le bouton Valider je suis redirigé hors du site pluxml avec une addresse qui pointe ici : https://www.google.com/?p=http%3A%2F%2Ficietlabas.cm%2Fnew%2Fblog%2Fcore%2Fadmin%2F

Du coup je suis complètement hors du site à chaque fois. Pourtant la connexion en admin marche bien en local. Quel peut être la cause s'il vous plait?

Cordialement,
Yannick

Réponses

  • Salut Yannick,

    de mémoire il y un plugin qui pose ce genre de problème mais je ne me souviens plus duquel (recherche dans les archives du forum).

    En attendant, connecte toi en FTP à ton site et renomme temporairement le répertoire "plugins" (ce qui aura pour effet de le désactiver) et reconnecte toi sur ta page admin et dis nous si ça marche ou pas :)
  • yanstvyanstv Membre
    Bonjour kowalsky!
    Merci pour l'intervention. J'ai fais la manipulation (renommer le repertoire plugins) Mais rien cela fait toujours la même chose.

    Il y a t'il une autre solution?
  • Il y a toujours une solution :)

    Que se passe-t-il quand tu essayes d'accéder de nouveau à http://icietlabas.cm/new/blog/core/admin/ après être passé par le formulaire admin ?

    Sinon vu qu'il s'agit d'un site de test sans données, supprime le et fait une nouvelle installation pour voir si ça se passe mieux :)
  • yanstvyanstv Membre
    Quand j'essaie d'accéder à nouveau à http://icietlabas.cm/new/blog/core/admin/ ça fait la même chose lorsque et me ressort du site que le mot de passe soit bon ou mauvais. Tu peux essayé toi même le lien. Il est disponible.

    J'ai réinstallé la solution mais le même problème persiste.

    Je suis dans l'attente de vous lire.
  • Tu as essayé en désactivant tous les plugins ?

    Comme tu n'as plus accès à la console admin, il faut prendre un logiciel de FTP et éditer le fichier data/configuration/plugins.xml en supprimant toutes les balises <plugin>...</plugin>

    Si tu as de nouveau accès, active les plugins un par un jusqu'à remettre le bazar.
  • P3terP3ter Responsable de PluXml
    Bonjour,

    Si tu as tout supprimé et réinstallé PluXml de zéro sans ajouter de plugin, alors il s'agit peut-être d'un problème de configuration sur ton serveur Apache.

    Au clic sur "Valider" il y a une redirection 302 vers :
    http://icietlabas.cm/new/blog/core/admin/auth.php?p=http://icietlabas.cm/new/blog/core/admin/
    

    Ce qui est normal.

    En revanche, dans l'entête de la réponse HTTP, on voit que l'url de redirection renvoyée par le serveur est :
    https://www.google.com/?p=http%3A%2F%2Ficietlabas.cm%2Fnew%2Fblog%2Fcore%2Fadmin%2F
    

    au lieu de :
    http://icietlabas.cm/new/blog/core/admin/
    
  • Faudrait peut-être commencer par mettre à jour PHP !

    la version 5.4 n'est plus maintenue depuis des lustres et on ne peut pas perdre du temps à garantir que PluXml marche avec d'antiques versions de PHP.
    La plus ancienne version de PHP maintenue est 7.0 et on conseille de passer à la 7.2

    Après, il faudrait voir ce qu'il y a dans ton fichier "http://icietlabas.cm/new/blog/.htaccess"
  • SudwebdesignSudwebdesign Membre
    23 févr. modifié
    Salut Yannick,

    En remontant a la racine de ton domaine (http://icietlabas.cm),
    on est redirigé vers ton (vrai) site Joomla à l'adresse http://icietlabas.cm/index.php/fr/
    Qui plus est, lorsque l'on clique sur valider (Login et MDP vide) on reste bien sur PluXml.
    je pencherai donc vers une incompatibilité entre ces deux systèmes sur le même domaine et non le PHP.

    AMHA le .htaccess de joomla doit faire quelque chose de zarbi avec ton nouveau (sous-dossier) Pluxml.


    Où est placé ton site joomla, a la racine du serveur, un sous-dossier?
    Si il est a la racine, c'est Joomla qui prend la main (en toute probabilité) et qui comprend rien a ce que pluxml lui envois (POST) et c'est normal ;)
    Nous rediriger chez GG c'est chelou tout de même 8o


    Une piste a suivre : renomme le .htaccess (celui de Joomla) en _htaccess, teste le login de Pluxml, si ça passe c'est bien ça. Une fois les tests fait renommer le .htaccess :)

    2e piste plus longue et dangereuse : déplacer tout joomla dans un sous dossier genre www/joomla (avec le fichier .htaccess)
    Tester le login de Pluxml, si tu passe c'est bien ça.
    Puis peut-être (re)configurer Joomla (avec l'admin) ou modifier le .htaccess de Joomla en ajoutant le sous-dossier ou remettre les choses en place afin que ton site (Joomla) soit de nouveau fonctionnel.

    3e piste plus sage : créer un sous domaine pour ton nouveau PluXml qui pointe vers ton dossier new/blog/ (voir avec l'interface de ton hébergeur). Comme cela il y aura aucun conflit entre les deux C.M.S.


    En aparté:
    deux belles Fiat 500 ;)
    http://icietlabas.cm/administrator/
    http://icietlabas.cm/administrator/index.php?option=com_config

    deux belles Peugeot 404 ;)
    http://icietlabas.cm/index.php/administrator
    redirigé vers http://icietlabas.cm/index.php/fr/administrator

    En réalité GG utilise le paramètre url p pour la pagination et il utilise le q pour les termes recherchés
    ?p=http%3A%2F%2Ficietlabas.cm%2Fnew%2Fblog%2Fcore%2Fadmin%2F

    Et vive le Cameroun Libriste.

    Notre temps est la seule monnaie vraie ;)

    Site, Dépôt, framagit, MyShop, Factux

Connectez-vous ou Inscrivez-vous pour répondre.