[Résolu] plxNNForum : Erreur sur config.php

fabrice0101fabrice0101 Membre
1 août modifié dans Bogues

Hello :)

J'ai installé et activé le plugin plxNNForum mais lorsque que je clique sur Configuration, une erreur survient:

"Parse error: syntax error, unexpected TLOGICALAND, expecting ')' in /var/www/vhosts/ti99.com/httpdocs/ti/plugins/plxNNForum/config.php on line 63"

Connaissez-vous une solution à ce problème? par avance, merci!

Réponses

  • Cela veut dire qu'il y a une erreur de syntaxe ligne 63 du fichier "/var/www/vhosts/ti99.com/httpdocs/ti/plugins/plxNNForum/config.php". Il faudrait que tu nous copies/colles cette ligne pour que l'on puisse te dire quoi corriger...

  • Bonjour fabrice0101,

    Indique également ta version de PluXml et du plugin "plxNNForum".

    As-tu ce problème si le plugin "plxNNForum" est le seul activé ?

  • fabrice0101fabrice0101 Membre
    29 juil. modifié

    Oui, et j'ai édité cette ligne, corrigé le problème de parenthèse, sauf qu'en retournant sur la configuration du pluging, je me retrouve avec une autre erreur de syntaxe, que je corrige pour me retrouver avec une autre erreur et ainsi de suite. Je me dit qu'il n'est pas possible que ce plugin ait autant d'erreurs, le problème est ailleurs, non?

    Voici la ligne 63:

    if (!empty($POST['forumusers'] AND $POST['confirmdel'] == 1)) {


    J'ai également tenté ce plugin en désactivant tous les autres, mais le problème est identique.

    Quelqu'un a t-il testé ce plugin? fonctionne t-il?

    J'utilise la version 5.7 de PluXml

  • Essaie ça :

    if(!empty($POST['forumusers']) AND $POST['confirmdel']==1){
    


    Ça devrait aller mieux...

  • fabrice0101fabrice0101 Membre
    30 juil. modifié

    C'est exactement la modification que j'ai faite quand j'ai découvert l'erreur, mais je me suis retrouvé avec une autre erreur plus loin dans le code (identique), que j'ai corrigé...et qui m'a renvoyé une erreur plus loin encore, pas de syntaxe cette fois-ci mais plus grave. Aussi j'ai arrêté de toucher au code voyant que quelque chose cloche vraiment sur ce plugin. D'où ma question : Ce plugin fonctionne t-il vraiment? Quelqu'un l'a t-il déjà testé?

  • SudwebdesignSudwebdesign Membre
    4 août modifié

    Pour ma part je l'ai mis en place pour une asso sur un pluxml 5.6 avec php 5.6 (chez free) et il roule bien en v1.0.0.2

    En effet cela semble être une erreur de syntaxe*, je suis en train de le re-tester avec pluxml 5.7 + php 7.0 et aucune erreur lors des configurations...

    Quelle est ta version de php, PluXml, la version de nnforum ;)


    Et surtout a quel moment cela arrive t'il?

    avec quel onglet?


    *Merci @Jerry Wham

    Notre temps est la seule monnaie vraie ;)

    Site, Dépôt, framagit, MyShop, Factux

  • fabrice0101fabrice0101 Membre
    30 juil. modifié

    J'utilise la version 1.0.0.2 du plugin, sous PluXml 5.7 avec... php 5.3.3 (chez Magic Online). Je réalise que cette version est complètement obsolète. Je vais la mettre à jour de ce pas :) Cela dit, je ne pense pas que le soucis vienne de là car ce plugin est basé sur NoNonSense Forum qui requiert PHP 5.2.3. Mais il se peut que NNforum soit plus exigeant.

    La version minimale de PHP exigée n'est pas précisée sur le site de l'auteur du plugin.

    L'erreur survient dès que je cherche à configurer le plugin dans la gestion des plugins. Impossible donc d'utiliser le forum.

    J'ai cherché à tester la toute première version du plugin mais elle n'est pas (plus) téléchargeable sur le site de l'auteur.

  • fabrice0101fabrice0101 Membre
    3 août modifié

    J'ai mis à jour PHP en 5.6.40 et... le plugin fonctionne :)

    Je ne pensais pas qu'une version obsolète de PHP allait gérer des problèmes de syntaxe à ce point. A ce jour, je vais rester sur cette version de PHP car, avant de passer à une version 7, il me faut d'abord retravailler un autre de mes sites web qui ne la supporte pas.

    Merci à ceux qui se sont penchés sur mon problème.

  • Au cas ou,

    A l'époque, le serveur de dev (v1.0.0.2) était avec php 5.5 et il tournait bien (il est possible qu'il tourne aussi avec php 5.4)

    Notre temps est la seule monnaie vraie ;)

    Site, Dépôt, framagit, MyShop, Factux

Connectez-vous ou Inscrivez-vous pour répondre.