répertoire racine

JoséJosé Membre

Bonjour


j'ai chargé la dernière version dans un répertoire local : Pluxml.

j'ai démarré la construction de mon site en local, avec un titre différent du nom de répertoire

Si je change le nom du répertoire racine, le site ne répond pas . Dans quel fichier dois-je modifier le nom du répertoire ?

merci

Réponses

  • Bonjour josé,

    ton fichier de configuration se trouve dans : data/configuration/parametres.xml

    Vérifie les lignes :

    <parametre name="homestatic"><![CDATA[]]></parametre>

    <parametre name="urlrewriting">1</parametre>

    (qui devraient ressembler à cela pour une installation à la racine du serveur)


    Normalement le changement de nom du répertoire hébergeant PluXml après installation ne devrait pas poser de problème.

    Quelques pistes :

    • Quand tu dis "le site ne réponds pas", as-tu une page d'erreur ou une page blanche ?
    • Usage de majuscules/minuscule, espaces ou accentuation dans le nom du répertoire ?
    • As-tu vidé le cache de ton navigateur ?
    • Il est conseillé de désactiver les addons avant de migrer ou mettre à jour son site
    • Si le serveur est en local sur ton ordinateur, que donne l’accès par : http://localhost/nomdurepertoire ? Vois-tu le nouveau répertoire quand tu vas sur http://localhost/ ?
    • Puisqu'il s'agit d'une installation sur un serveur local, as-tu vérifié la configuration du serveur ? Avais-tu fais un lien symbolique ou autre ?

    Plus d'info : https://wiki.pluxml.org/

  • JoséJosé Membre

    Bonsoir

    à la racine du serveur j'ai plusieurs dossiers dont PluXml dont je veux changer le nom en Parcours

    j'ai les deux lignes

    <parametre name="urlrewriting">1</parametre>

    <parametre name="homestatic">001</parametre>

    lorsque je change le nom du répertoire , je ferme les pages et je relance Wamp

    le message d'erreur est :

    Not Found

    The requested URL /PluXml/index.php was not found on this server.


    Alors que je ne trouve nulle part le mot PluXml dans parametres.xml


    j'explore les pistes que tu m'indiques

    Merci

    ( heureusement quand je renome le dossier en PluXml je retrouve mon travail ! )

  • Bizarre ce "001". Mais ça fait longtemps que je n'ai pas fait tourné un WAMP, je ne peux pas vérifier à quoi cela correspond. Regarde dans les fichiers de conf apache si par hasard tu n'aurais pas le lien /PluXml/ en dur dans l'alias 001 de site-enabled (un truc comme ça).

    Si tu ne trouves rien, garde ton répertoire en "PluXml", remplace ta ligne "homestatic" par celle que j'ai copié et regarde si tu as toujours accès à PluXml.

    Si c'est le cas, renomme ton répertoire et vérifie si tu as toujours accès au site.


    Si cela ne marche pas, fais une nouvelle installation de PluXml depuis https://www.pluxml.org/download/pluxml-latest.zip :)


    Pour info, les appels (par défaut) vers les répertoires dans le fichier parametres.xml ressemblent à ça :


    <parametre name="racine_articles"><![CDATA[data/articles/]]></parametre>

    <parametre name="racine_commentaires"><![CDATA[data/commentaires/]]></parametre>

    <parametre name="racine_statiques"><![CDATA[data/statiques/]]></parametre>

    <parametre name="racine_themes"><![CDATA[themes/]]></parametre>

    <parametre name="racine_plugins"><![CDATA[plugins/]]></parametre>

    <parametre name="homestatic"><![CDATA[]]></parametre>

    <parametre name="hometemplate"><![CDATA[home.php]]></parametre>

    <parametre name="urlrewriting">1</parametre>

  • JoséJosé Membre

    Cela m'était déjà arrivé par le passé. J'avais du refaire une installation!

    Quand je passe du local vers une installation sur site à la racine , je ne rencontre pas de problème.

    c'est seulement en local.

    Est ce que cela pourrait provenir des données à l'installation dans le répertoire PluXml: le fichier "install", avant sa suppression, contenait la ligne:

    <tags><![CDATA[PluXml]]></tags>

  • JoséJosé Membre

    Je relance ! les difficultés sont plus sérieuses

    • avec la réécriture d'URL activée , les envois <form method="POST" action="?static8/statique-8" ... , je reste sur la page en cours
    • avec la réécriture d'URL desactivée, j'ai le message "The requested URL /PluXml/static5/statique-5 was not found on this server."

    Moralité : il ne faut pas renommer le répertoire local , une fois installé ?

    je crois que je vais devoir faire une nouvelle installation , en choisissant un nom de répertoire définitif


    José

  • Slt @José

    c'est curieux, il semble que la réécriture d'url soit inversé dans ton exemple 🙄

    Lorsque la réécriture d'url est activé, les adresses ressembles a : www.monpluxml.net/static5/statique-5

    et lorsqu'elle est désactivé elles ressembles a : www.monpluxml.net/index.php?static5/statique-5

    Notre temps est la seule monnaie vraie ;)

    Site, Dépôt, framagit, MyShop, Factux

  • StéphaneStéphane Membre, Ancien responsable de PluXml

    Bonjour

    Quand la réécriture d'url est activée et que tu renommes après le dossier d'installation, il faut éditer et modifier le fichier .htaccess à la racine de ton site, paramètre RewriteBase

    nb: attention aux minuscules, majuscules (éviter les espaces) si vous mettez au point votre site sous Windows et que vous le passer ensuite sur votre hébergeur sous Linux. Windows n'est pas case sensitive contrairement à Linux

    Consultant PluXml

    Ancien responsable du projet (2010 à 2018)

  • cpalocpalo Membre

    Bonsoir,

    J'utilise Xampp en local.

    Le problème que l'on peut avoir lorsque la réécriture d'url est activée, c'est comment on "appelle" son pluxml.

    http://127.0.0.1/dossier-pluxml/

    ou http://pluxml.local si on a crée des virtualhosts.

    Je pourrai expliciter un peu plus demain si nécessaire.

    Cordialement

  • JoséJosé Membre


  • JoséJosé Membre

    Merci de vos commentaires.


    j'ai désactivé la ré-écriture d'URL.

    Je n'ai pas de fichier .htaccess à la racine du site ( en local , sous le répertoire PluXml ).

    le seul fichier .htaccess est situé dans le /core.

    il contient une seule ligne :

    Options -Indexes

  • Il s'agit du fichier .htaccess qui se trouve à la racine de ton serveur.

  • cpalocpalo Membre

    Ci-dessous mon fichier htaccess avec la ré-écriture d'url activée et qui fonctionne sans problème en local avec Xampp


    Options -Multiviews


    <IfModule mod_rewrite.c>

       RewriteEngine on

       RewriteBase /

       RewriteCond %{REQUEST_FILENAME} !-f

       RewriteCond %{REQUEST_FILENAME} !-d

       RewriteCond %{REQUEST_FILENAME} !-l

       # Réécriture des urls

       RewriteRule ^(?!feed)(.*)$ index.php?$1 [QSA,L]

       RewriteRule ^feed\/(.*)$ feed.php?$1 [QSA,L]

    </IfModule>


    Options -Indexes


    <Files ".htaccess">

       Order Allow,Deny

       Deny from all

    </Files>


    <Files "config.php">

       Order Allow,Deny

       Deny from all

    </Files>


    <Files "core/lib/*.php">

       Order Allow,Deny

       Deny from all

    </Files>


    # END -- Pluxml

  • JoséJosé Membre

    Je désespérais de ne pas trouver mon fichier .htaccess à la racine! c'était pas juste.


    en activant la ré-écriture d'URL : miracle j'avais mon fichier :

    # BEGIN -- Pluxml

    Options -Multiviews

    <IfModule mod_rewrite.c>

    RewriteEngine on

    RewriteBase /PluXml/

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteCond %{REQUEST_FILENAME} !-l

    # Réécriture des urls

    RewriteRule ^(?!feed)(.*)$ index.php?$1 [L]

    RewriteRule ^feed\/(.*)$ feed.php?$1 [L]

    </IfModule>


    Je reviens donc à ma question initiale , et la réponse de Stéphane est maintenant forcément plus claire pour moi!

    alors je teste et forcément ça fonctionne: super

    Merci de m'avoir aidé sur ce point

  • kowalskykowalsky Membre
    21 août modifié

    Par déduction, il devrait te suffire de désactiver la ré-écriture d'URL avant le changement de nom de dossier, puis de la réactiver ensuite pour n'avoir à modifier aucun fichier.


    Sinon à minima remplacer RewriteBase /PluXml/ dans .httacces


    On notera cependant que ton site PluXml n'est pas à la racine de ton serveur local, mais dans un sous-répertoire.

  • JoséJosé Membre

    oui effectivement, le site est dans un sous-répertoire dont j'ai voulu changer le nom. (en local j'ai 8 sous-répertoires à la racine )

    Dans ma configuration le fichier htaccess n'est accessible que si la réécriture d'URL est activée

    Comme je travaille sans activer la réécriture d'URL , je ne comprenais pas d'où venait le plantage

Connectez-vous ou Inscrivez-vous pour répondre.