kzContact "Uncaught error: call to a member function q() on null"

cpalocpalo Member
19 févr. modifié dans Entraide

Bonjour

@bazooka07

Je viens d'installer ton plugin sur une version 6.0 sans aucun plugin d'installé.

Pas de problème pour l'activation et la config.

Mais lorsque je vais sur la page pour remplir le formulaire, j'ai ce message d'erreur en dessous-du champ texte.

Fatal error: Uncaught Error: Call to a member function q() on null in E:\htdocs\PluXml\core\lib\class.plx.show.php:1663
Stack trace:
#0 E:\htdocs\PluXml\plugins\kzContact\my-form.inc.php(106): plxShow->capchaQ()
#1 E:\htdocs\PluXml\plugins\kzContact\form.contact-pro.php(45): include('E:\\htdocs\\mySim...')
#2 E:\htdocs\PluXml\core\lib\class.plx.show.php(1568): require('E:\\htdocs\\mySim...')
#3 E:\htdocs\PluXml\themes\defaut\static.php(19): plxShow->staticContent()
#4 E:\htdocs\PluXml\index.php(63): include('E:\\htdocs\\mySim...')
#5 {main}
 thrown in E:\htdocs\PluXml\core\lib\class.plx.show.php on line 1663

Dans formulaire pro petite erreur en début de fichier deux fois <php

Réponses

  • cpalocpalo Member

    Oups.. je ne l'ai pas mis dans la bonne rubrique du forum... Pour le déplacer?

  • Kube17Kube17 PluXml Staff
    26 janv. modifié

    Comme c'est une demande d'aide et non un plugin je pense que la meilleure place pour cette discussion est sur Entraide (ou plutôt Bogues étant donné qu'il pourrait s'agir d'un bogue du plugin). Pourquoi vouloir la mettre dans plugins ?

    FR/EN MP - Mail - unkorneglosk.fr - Twitter - Je suis modérateur, je dois donc modérater. Ou modérationner. Ou je sais plus. Mais je le fais. En ce moment j'ai des problèmes d'accès à internet je peux mettre du temps à répondre.

  • cpalocpalo Member

    Bonsoir,

    Parce que c'était lié au plugin en question.. Et il me semblait plus logique, ou souhaité par les auteurs de plugins, que les bugs ou problèmes rencontrés avec un plugin soit dans le fil du plugin en question.

    Mais sinon à mon niveau cela ne me gène pas plus que ça qu'il soit dans la rubrique entraide.

  • Kube17Kube17 PluXml Staff

    En fait la rubrique Plugins sert surtout de vitrine. Après oui il est possible de mettre les bugs dans la discussion du plugin en question, mais comme tu as ouvert une autre discussion, sa place n'est pas vraiment dans plugins (de plus ton titre peut être trompeur - dans la catégorie plugins on peut penser qu'il s'agit de la discussion de présentation du plugin kzContact).

    FR/EN MP - Mail - unkorneglosk.fr - Twitter - Je suis modérateur, je dois donc modérater. Ou modérationner. Ou je sais plus. Mais je le fais. En ce moment j'ai des problèmes d'accès à internet je peux mettre du temps à répondre.

  • cpalocpalo Member

    Bonjour,

    le problème vient si on active dans le plugin l'option anti-spam

  • cpalocpalo Member

    Bonjour,

    Version stable 5.8.2 et devpt 5.8.3 , test avec un seul plugin.

    Si on desactive l'option antispam du plugin, pas de pb il fonctionne.

    Mais comment rajouter un anti-spam dans ce cas?

    Cordialement

  • @cpalo ,

    Effectivement il y a un problème avec l'anti-spam

    PluXml crée un objet plxCapcha pour les commentaires des articles, mais pour les pages statiques.

    La version 2.1.0 corrige ce problème.

    Elle apporte d'autres améliorations :

    • nettoyage du code pour l'injection de code dans les hooks
    • utilisation directe de la fonction mail de PHP ( pas de serveur SMTP à configurer )
    • spinner CSS3
    • Fix le problème avec l'anti-spam (capcha)
    • utilisation de ob_start() pour générer le corps du message

    Télécharger la dernière version de ce plugin

  • cpalocpalo Member

    Bonsoir,

    @bazooka07

    Merci.

    Cela fonctionne avec la version stable 5.8.2 et celle de développement 5.8.3 et la version php 7.2.29

  • cpalocpalo Member

    Bonjour,

    Juste une petite précision, mais ce n'est pas grave en soi car cela fonctionne correctement en ligne.

    En local (xampp php 7.2.28), la page formulaire s'affiche sans problème. Mais lorsque je fais un test d'envoi jusqu'au bout (ce qui fonctionne avec d'autres plugins contact) j'ai ce message d'erreur après avoir fait envoyer:

    Warning: mail(): "sendmail_from" not set in php.ini or custom "From:" header missing in E:\htdocs\PluXml-5.8.3\plugins\kzContact\kzContact.php on line 65

    Une erreur est survenue pendant l'envoi de votre message

    \n

    Cordialement

  • Cela veut dire que Windows ne sait pas comment envoyer un mail.

    Sous Linux, j'utilise msmtp pour faire l'envoi. C'est paramétré dans php.ini.

    kzContact utilise directement la fonction mail de PHP. L'avantage est qu'il n'y a rien à paramétrer. Juste préciser le nom du destinataire.

Connectez-vous ou Inscrivez-vous pour répondre.