PluXml 5.8.3 released

P3terP3ter PluXml Project Manager

(en) After the release candidate launch on April 26, PluXml 5.8.3 comes out of its test phase and is now available in a stable version. More information in this post.

(fr) Après la publication d'une release candidate le 26 avril, PluXml 5.8.3 sort de sa phase de test et est désormais disponible en version stable. Plus d'information dans cet article. Si vous avez installé la version 5.8.3 RC il est recommandé de faire la mise à jour vers la version stable, en utilisant la procédure habituelle.

Site : p3ter.fr - Twitter : @P3terFr

Mots clés:

Réponses

  • zetraderzetrader Member

    Excellente news, merci pour les corrections de bug par rapport à la 5.8.2, je vais tester cette dernière version aujourd'hui :)

  • garys02garys02 Member
    20 mai modifié

    Good, merci! C'est normal si il propose pas d'update à partir de la RC ? J'ai écrasé les fichiers core et update, pas d'écran update.

  • MAPC2012MAPC2012 Member

    Merci à l'équipe PluXml d'avoir mis à jour le système. Merci les gars!

  • SudwebdesignSudwebdesign Member
    24 mai modifié

    beau boulot ;)

    Petites retouches pour ma part

    • ds : core/lib/class.plx.motor __construct()
            if(!defined('PLX_SITE_LANG')) define('PLX_SITE_LANG', $this->aConf['default_lang']);
    
    • ds : themes/defaut/css/theme.css
    .header .grid {/* Fix sub Menu are (in)visible; ) */
        overflow: initial;
    }
    

    Il semble qu'il efface les "antislash" (\) lorsque l'on édite le css du theme par défaut (php 7.3)

    .menu>li span::before {/* \/ menu */
        content: '\25bc';
    }
    

    Devient :

    .menu>li span::before {/* / menu */
        content: '25bc';
    }
    

    ET

            content: '\2630';
    

    Devient :

            content: '2630';
    

    @ vérifé :)

    Notre temps est la seule monnaie vraie ;)

    Site, Dépôt, framagit, MyShop, Factux

  • bazooka07bazooka07 Member

    Le problème avec "content: '\25bc';" vient de l'appel à la fonction plxUtils::unSlash(...) à la ligne n°43 dans le fichier core/admin/preprend.php.
    Pour l'instant, je ne saisis pas l'intérêt d'un tel appel à cette fonction.
    Pour régler provisoirement ce problème, modifier la ligne 43 comme suit

    if($_SERVER['REQUEST_METHOD'] == 'POST' and basename($_SERVER['PHP_SELF']) !== 'parametres_edittpl.php') $_POST = plxUtils::unSlash($_POST);
    

    Concernant la langue, l'utilisateur peut utiliser une langue différente de celle du site. Pour la connaitre, il existe une variable de session $_SESSION['admin_lang']. Côté site, il n'y a a priori pas besoin d'une telle constante.

    Concernant le menu, il marchait bien avec PluXml-5.7. Il y avait également la class sticky. Mais je ne vois pas encore la modif de PluXml 5.8.3 qui met le bazar.

  • krockroc Member
    28 mai modifié

    Bravo pour cette nouvelle version.

    J'ai juste une remarque : lorsqu'on enregistre ou réalise une action dans le backoffice, un cadre s'affiche en jaune pendant 2 secondes en haut de l'écran pour nous confirmer l'action. Ce cadre masque les boutons de navigation du backoffice.
    Je trouve ça un peu ennuyeux à l'usage car on est obligé d'attendre que ce cadre disparaisse pour pouvoir poursuivre les manipulations. Ce n'est pas grand chose, mais ça m'a gêné.

    Merci !

    Mes sites propulsés par ce cher PluXml : www.krocui.com - www.lucasdebruyn.com - www.coolraool-publishing.com

  • bazooka07bazooka07 Member

    Dans le fichier core/admin/theme/theme.css, vers la ligne n°551, modifie la règle CSS pour .notification comme suit :

    .notification {
            position: absolute;
            top: -13rem;
            left: 1.5rem !important;
            right: 1.5rem;
            margin: 0;
            padding: .25rem 1rem;
            border: .25rem solid;
            color: #000;
            text-align: center;
            z-index: 999999;
    }
    

    Tu peux aussi modifier les couleurs avec les class .error, .success et .warning

  • krockroc Member

    Merci ! En fait de façon générale j'ai décidé de ne rien changer aux fichiers par défaut de PluXml, pour éviter les problèmes aux changements de version !

    Mes sites propulsés par ce cher PluXml : www.krocui.com - www.lucasdebruyn.com - www.coolraool-publishing.com

  • bazooka07bazooka07 Member

    Pas de souci :
    tu peux mettre cette règle dans un fichier "data/admin.css" par exemple.
    Ensuite depuis le back-office de PluXml, cliquer sur configuration avancée.
    Dans le champ Emplacement et nom du fichier css personnel.., mettre "data/admin.css"

    Tu trouveras d'autres règles pour agrémenter le back-office dans cette discussion :
    https://forum.pluxml.org/discussion/6751/amelorer-le-look-du-back-office-admin#latest

  • krockroc Member

    Merci beaucoup pour ce tuyau Bazooka !

    Mes sites propulsés par ce cher PluXml : www.krocui.com - www.lucasdebruyn.com - www.coolraool-publishing.com

  • krockroc Member
    1 juin modifié

    Bonjour, j'ai rencontré deux bugs dans le gestionnaire de médias sur la 5.8.3 :

    1-impossible de trier par date (la fonction JS semble inopérante) :
    TypeError: document.forms[0].sort is undefinedmedias.php:1:1

    2-les icônes de renommage et de copie du chemin se superposent au header au scroll :
    ligne 251 de admin/theme.css, retirer le "z-index:5"

    Mes sites propulsés par ce cher PluXml : www.krocui.com - www.lucasdebruyn.com - www.coolraool-publishing.com

  • garys02garys02 Member
    6 juil. modifié

    Je confirme @kroc enlever le z-index:5, et aussi la couleur verte des notif c'était super avant ^^
    Impossible de faire du référencement si on ne peut pas enlever une page ou un article du sitemap, quand je mets une page en no-index je me fais tackler par google parce-qu'elle est dans le sitemap...

  • P3terP3ter PluXml Project Manager

    Hello @kroc, j'ai apporté des correctifs sur la futur version 5.8.4 disponible ici : https://github.com/pluxml/PluXml/archive/5.8.4.zip

    Site : p3ter.fr - Twitter : @P3terFr

  • cpalocpalo Member

    Bonjour,
    Pour la 5.8.4 quelle est est la version de Php recommandée ? Php 7.4 est-il supporté?

  • P3terP3ter PluXml Project Manager

    Bonjour,
    Oui PHP 7.4 est supportée depuis la version 5.8 de PluXml, il s'agit bien de la version recommandée.

    Site : p3ter.fr - Twitter : @P3terFr

  • cpalocpalo Member

    Voilà j'ai donc fait la migration en local vers xampp 7.4 et chez mon hébergeur Nuxit php 7.4

  • I find that a little boring in use because we have to wait for this frame to disappear in order to be able to continue the manipulations. It's not much, but it bothered me.
    Regarding the menu, it worked well with PluXml-5.7. There was also the sticky class. But I do not yet see the modification of PluXml 5.8.3 which is causing a mess.

Connectez-vous ou Inscrivez-vous pour répondre.