Modification d'url avec la nouvelle version de PluXml

zetraderzetrader Member
22 juin modifié dans Bogues

Bonjour, j'ai migré mon contenu de la 5.7 vers la 5.8.3, et je me retrouve avec des urls qui font des erreurs.
Motif : la dernière version de PluXml a visiblement une fonction "intelligente" qui se permet de supprimer le mot "en" (et peut-être d'autres mots ?) lors de sauvegarde d'articles ou pages statiques. Ce qui fait par exemple que si il y avait gagner-en-bourse dans l'url, cela devient gagner-bourse après modification ou nouvelle sauvegarde de l'article ou la page statique. Avec MyBetterUrls qui veut une url "stricte", c'est un problème puisqu'on se retrouve avec une erreur 404.

Ce ne serait pas un gros problème si l'interface admin laissait modifier l'url à la main comme c'était le cas avant, mais dès lors qu'on rajoute le "en" à la main dans l'url puis on sauvegarde, cela saute à chaque fois, il refuse de garder cette modification d'url manuelle.
Donc si on veut conserver nos urls, il faut alors supprimer le fichier xml (article) ou php (page statique) et uploader l'ancien fichier, mais pour la page statique c'est plus problématique, elle n'apparaîtra plus dans la liste des pages statiques côté admin (peut-être du fait d'avoir le mot "interdit") et ne sera pas non plus accessible sur le site, ou renommer le fichier xml via un logiciel FTP pour les articles, parce que pour les pages statiques qui sont des fichiers php, visiblement c'est foireux, ce ne sera pas accessible sur le site ni en admin.
Enfin bref, le CMS vient apporter des difficultés pour une supposée fonction intelligente qui vient mettre le bordel quand avant ce n'était pas un problème.
On fait comment pour désactiver cette nouvelle fonction de "correction/optimisation d'url" ?

Sinon ça oblige soit à adapter toutes les urls, soit à ne plus toucher à ces articles ou pages statiques via l'éditeur PluXml, éditer à chaque fois en externe pour éviter les modifications d'url...

EDIT : je vois que cela le fait pas seulement avec "en" mais aussi avec :

  • "de" ou "des", "un" ou "une", "le" (mais pas "les" bizarrement..) ou "la", "vers", "du" (où est la liste complète ? J'en découvre régulièrement), et même chose, l'interface empêche de corriger à la main l'url, si on corrige en modifiant l'url via l'interface cela refuse de garder les changements, cela supprime de toutes façons ces mots de l'url, donc pas mal d'erreurs 404 en perspective.

EDIT 2 : Après test, je vois que cela le fait aussi pour les catégories, suppression de certains mots des url des catégories, quand on sauvegarde après création d'une nouvelle catégorie, donc d'autres erreurs 404 du côté des catégories.

Réponses

  • GzygGzyg Member

    C'est dû à une nouvelle fonction. Il y a déjà plusieurs posts sur ce sujet qui a embêté beaucoup de monde ! :)

  • zetraderzetrader Member
    22 juin modifié

    Ah oui, vu, merci, bazooka07 donne la réponse là, si on veut désactiver la fonction :
    https://forum.pluxml.org/discussion/comment/59959/#Comment_59959
    Après je comprends l'idée, et cela permet des urls plus courtes, cela a aussi ses avantages, mais ça demande un gros boulot d'adaptation des urls en internes si il y a beaucoup d'articles puis aussi un boulot de redirection de toutes les possibles erreurs 404 lorsqu'on se retrouve avec une nouvelle url pour le même article.
    À voir, le mieux c'est peut-être de laisser la possibilité côté admin d'activer ou désactiver cette option, plutôt que d'aller modifier le code du noyau ce qui risque de sauter à la prochaine version sans qu'on sache pourquoi (on peut avoir oublié).

  • zetraderzetrader Member
    22 juin modifié

    Par contre je vois un petit bug, parfois avec ? ou : dans le titre, cela se traduit en deux tirets dans l'url.
    Exemple, un titre de test "Tu m'aimes ? Je veux une réponse claire : Oui ou Non ?"
    En url donne tu-maimes--je-veux-reponse-claire--oui-ou-non
    Cela devrait plutôt être un seul tiret entre les mots tu-maimes-je-veux-reponse-claire-oui-ou-non (l'interface laisse corriger les doubles tirets de l'url)

    Que ce soit en mettant remove sur false ou true (activant ou désactivant la fonction).

    Edit : Après test sous PluXml 5.7, cela donne bien tu-m-aimes-je-veux-une-reponse-claire-oui-ou-non comme url, c'est donc un bug de PluXml 5.8.3

  • kowalskykowalsky Member

    La solution la plus simple étant de rester en version 5.7 ;)

  • P3terP3ter PluXml Project Manager

    Bonjour, cette fonctionnalité est activable/désactivable via l'admin, dans la prochaine version majeur de PluXml (6.0), disponible ici : https://github.com/pluxml/PluXml. Attention, il s'agit d'une version en cours de développement.

    Site : p3ter.fr - Twitter : @P3terFr

Connectez-vous ou Inscrivez-vous pour répondre.