Pages Statiques

Bonjour,

Merci pour cette mise à jour :)

Depuis des jours je cherche à corriger un souci sur mon site http://j-mg.ovh lors de la mise en ligne des pages statiques, l'URL est tronquée par exemple, pour la page FRAMA l'URL :

https://framasphere.org/people/13667db01cfe0138501f2a0000053625

devient

https://framasphere.orgpeople13667db01cfe0138501f2a0000053625

Je n'arrive pas à trouver l'origine du problème ?

Merci pour votre aide

Cordialement

Réponses

  • P3terP3ter PluXml Project Manager

    Bonjour,

    Tu es en version 5.8.3 ? Si tu crées une nouvelle page ça fonctionne ou pas ?

    Site : p3ter.fr - Twitter : @P3terFr

  • jmglzjmglz Member

    Bonjour @P3ter Oui je suis avec la dernière version 5.8.3 et en serveur PHP 7.1 Si je crée une nouvelle page effectivement cela ne fonctionne pas, j'ai essayé plusieurs fois à chaque fois l'URL est tronquée (plus de /) comme indiqué ci-dessus (tu peux voir le résultat sur mon site à la page FRAMA avec d'autres URL le soucis est le même ?!). Je ne trouve pas la solution...

  • jmglzjmglz Member

    Re...avec les URL en https:// cela ne fonctionne pas (avec une URL courte en http:// ça à l'air de marcher..)

  • noogatynoogaty Member
    10 juil. modifié

    @jmglz si je peux me permettre, tu devrais essayer avec PHP 7.3, voir 7.4 si tu peux, car 7.1 est périmé.
    https://www.php.net/supported-versions.php
    Peut-être que ton problème vient de là ?

  • jmglzjmglz Member

    @noogaty Merci pour l'info, j'ai fait l'upgrade pour PHP 7.4 mais le problème continue...J'ai même réinstallé Pluxml 5.8.3 sans solution au soucis...

  • P3terP3ter PluXml Project Manager

    Hello, il s'agit bien d'un bug de la version 5.8. Je regarde pour faire une correction dans la prochaine version.
    En attendant, il est possible de modifier manuellement le fichier data/configuration/statiques.xml pour corriger l'url.

    Site : p3ter.fr - Twitter : @P3terFr

  • jmglzjmglz Member

    ok merci 👌et bon week-end !

  • cpalocpalo Member

    Bonjour,
    Je viens de voir que sur Github tu avais mis une branche 5.8.4 avec cette correction.
    Doit-on utiliser utiliser cette branche branche 5.8.4 plutôt que la 5.8.3?

  • P3terP3ter PluXml Project Manager

    Hello, il s'agit bien de la branche pour la prochaine version (5.8.4), il me reste quelques points à finaliser et des tests pour publier cette version, mais vous pouvez commencer à la tester. La branche 5.8.3 sera bientôt supprimée.

    Site : p3ter.fr - Twitter : @P3terFr

Connectez-vous ou Inscrivez-vous pour répondre.