Problème de mise à jour de 5.1.5

dadou001dadou001 Member
dans Bogues

Bonjour,
J'ai un souci de mise à jour. Je suis en version 5.1.5, en voulant passer sur la dernière version, j'ai remplacé le dossier data de la nouvelle version (qui fonctionne sans ça) par l'ancienne, rajouté deux dossiers qui n'y étaient pas (medias et templates) et tenté de faire une mise à jour. La page suivante apparait

Mise à jour PluXml 5.8.4

Applications des mises à jour version 5.1.6

Mise à jour du fichier parametres.xml
Mise à jour du fichier ()
Mise à jour du fichier ()

Applications des mises à jour version 5.1.7

Mise à jour du fichier parametres.xml
Migration des fichiers de paramétrage des plugins dans le dossier de configuration

mais quand je veux recharger la page pluxml, elle me renvoie vars la page de mise à jour et ça tourne en rond.

Qu'ai-je oublié ?

Cordialement

Damir

Réponses

  • bazooka07bazooka07 Member

    2 remarques pour commencer :

    • désactive la ré-écriture d'url
    • Fais d'abord ta mise à jour. Tu créeras tes dossiers plus tard si besoin.

    C'est une trèèès vieille version. Elle ne figure même pas dans le dépôt Github de PluXml.
    Difficile de t'aider comme cela.
    Tu dois avoir des messages d'erreur dans ton fichier de log du serveur HTTP (Apache)
    Tu as quelque version de PHP ?

  • kowalskykowalsky Member

    En complément des conseils de bazooka07, et puisque tu es sur une version 5.1.5, je t'invite à d'abord faire une MAJ en 5.4. Si celle-ci se passe bien de faire ensuite une MAJ en 5.6 où il y a eu beaucoup de changement au niveau du code de PluXml. Ensuite la MAJ en 5.8.4 ne devrait plus poser de problèmes

    Les anciennes versions sont là : https://github.com/pluxml/PluXml/releases

  • bazooka07bazooka07 Member

    Attention à la version de PHP si on installe de trop anciennes versions de PluXml.

    Sur mon PC, j'ai PHP version 7.4.3 sous Ubuntu 20.04.
    Avec PluXml 5.2, j'ai des messages d'erreurs :

    • "deprecated: function get_magic_quotes_gpc() is deprecated" dans le fichier class.plx.utils.php
    • "deprecated: function create_function() is deprecated" dans le fichier article.php. Idem dans medias.php
Connectez-vous ou Inscrivez-vous pour répondre.