[AUTO-RÉSOLU] MyBettersURL 404 not found

petitpouyopetitpouyo Member
11 nov. modifié dans Plugins

Salut à tous,
voila j'ai installé le plugin plxMyBetterUrls depuis le début sur mon blog, jusqu'à présent je n'ai jamais eu de soucis mais depuis ce matin toutes mes pages s'affichent avec une erreur 404 not found.

Alors comme hier j'ai bidouiller mon fichier .htaccess à la racine pour pouvoir personnaliser ma redirection 404 je m'étais dis que ça doit venir de là, j'ai donc retirer les lignes que j'ai ajouter dedans hier, vider le cache du navigateur mais rebelote erreur 404.

Ensuite j'ai supprimer le plugin plxMyBetterUrls et ça marche mais avec l'affichage par défaut:
monsite.fr/static1/nom-de-page.

Plus moyen de remettre des urls propre avec ce plugin, j'ai beau essayer de le réinstaller etc... je tombe toujours sur une erreur 404.
Mes urls propre avec ce plugin étaient du style:
monsite.fr/nom-de-page, en effet dans la configuration j'avais laisser l'espace à personnaliser correspondant à

Article, Catégorie, Page statique

vide afin d'avoir directement le nom de la page, de la catégorie ou de la page statique après mon nom de domaine.

Ci-dessous mon code htaccess

# BEGIN -- Pluxml
Options -Multiviews
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l
# Réécriture des urls
RewriteRule ^(article\d*|categorie\d*|tag|archives|static\d*|page\d*|telechargement|download)\b(.*)$ index.php?$1$2 [L]
RewriteRule ^feed\/(.*)$ feed.php?$1 [L]
</IfModule>
# END -- Pluxml
[== .htaccess ==]

Réponses

  • Je tiens aussi a rajouter que ma page contact ne marche plus, j'ai tenter d'installer le plugin MySuperContact et pareil son lien redirige vers une erreur 404 (https://petitpouyo.fr/supercontact)

  • Bon c'est bon j'ai trouver d'où venais le problème en fait ça vient de la modification du fichier class.plx.admin.php dans le dossier /core/lib/.

    Dans la fonction plxShow::htaccess():

            $plxhtaccess = '
    # BEGIN -- Pluxml
    Options -Multiviews
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteBase '.$base['path'].'
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
    # Réécriture des urls
    RewriteRule ^(article\d*|categorie\d*|tag|archives|static\d*|page\d*|telechargement|download)\b(.*)$ index.php?$1$2 [L]
    RewriteRule ^feed\/(.*)$ feed.php?$1 [L]
    </IfModule>
    # END -- Pluxml
    ';
    

    Par contre mon image du header du blog n’apparaît plus lol je vais farfouiller encore.

Connectez-vous ou Inscrivez-vous pour répondre.