[RESOLU] site en http au lieu de https

webassowebasso Member
20 sept. modifié dans Entraide

Bonjour,
Je viens d'installer un nouveau site avec pluxml avec la dernière version 5.8.7 mais l'url de son adresse est en http, comment la mettre en https ?

Réponses

  • Ayden29Ayden29 Member

    Comme toute chose, la sécurité passe avant tout, c’est pourquoi on utilise https . Mais quoi qu'il en soit , c'est une question de choix, non?

  • webassowebasso Member

    ... Merci, je n'ai rien eu à choisir ni rien fait de spécial en installant le site et quand j'ai mis en ligne l'url s'est affichée en http, alors comment le met-on en https maintenant ?

  • 17 sept. modifié

    Bonjour,

    Quelles sont les options (de configurations) proposées par ton hébergeur ?

    As tu la possibilité de générer ou d'ajouter un certificat SSL gratuit ?

    As tu tenter quelque choses au travers d'un fichier .htaccess ?

    Apparemment ton hébergeur est OVH, regardes ici peut-être : https://docs.ovh.com/fr/hosting/passer-site-internet-https-ssl/

    Edit En passant en https, pense à mettre à mettre à jour les fichiers liés en https aussi. Par exemple une image qui ne s'affiche plus parceque <img src="http://lesaubes.fr/monimage.jpg"> au lieu de attendu <img src="https://lesaubes.fr/monimage.jpg"> .

    Remise en ligne et test de mon vieux site re7net.com . le design et moi on ne sait ... s'est jamais reconnu en fait! mais je fait des efforts.

  • webassowebasso Member

    Super conseil, MERCI,
    le SSL chez OVH était bien activé, je l'ai quand même régénéré vu que c'était pour un nouveau site...
    je crois que j'ai réglé le problème en ajoutant dans le fichier .htaccess du site le code suivant... et je crois que tout est ok sur le site :
    #ON OBLIGE LE HTTPS
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

Connectez-vous ou Inscrivez-vous pour répondre.