Réécriture url simplifiée

webassowebasso Member

Bonjour,
sur mon site pluxml V5.8.7 (avec pligin CKEditor 4 PHP #sudwebdesign - Version 4.11.1_PHP (30/11/2018))

La réécriture des url est activée, mais comment faire pour ne laisser que l'adresse de la page (article ou static) sans que ces deux termes soient présent dans l'url ?

  • éviter ce genre d'url : //monsite.fr/article2/les-salles-dactivites-drome
  • préférer celui-ci : //monsite.fr/les-salles-dactivites-drome

Réponses

  • cpalocpalo Member

    Bonjour
    Tu peux utiliser le p!ugin myBetterUrl

  • webassowebasso Member

    Bonjour, merci pour le tuyau, je viens de l'activer sur mon site mais j'ai toujours le mot "article", "static" etc. qui est inséré dans le corps de l'url.
    Ce n'est pas possible de faire en sorte que l'on ait que ceci : //monsite.fr/les-salles-dactivites-drome

  • webassowebasso Member
    20 sept. modifié

    Heuuu je viens de faire un test sur deux sites distincts et je n'ai pas le même résultat,

  • Salut Webasso,

    après avoir installé le plugin, si tu be l'as pas déjà fait, va dans la "Configuration avancée" et désactive puis réactive la "la réécriture d'URL". Cela devrait corriger tes problèmes d'URL.

  • webassowebasso Member

    Bonsoir kowalsky
    Je reprends depuis le début... sur un site pluxml V5.8.7 avec :
    le pluging plxMyBetterUrls v 1.5.5 installé et activé
    si je fais la manip que tu dis j'obtiens ça au niveau de l'url : https://monsite.fr/le-sens-dune-paix-commune
    mais avec une page d'erreur 404 Not Found
    Je me demande si ça vient pas de la version du pluXml ?
    Vois-tu où est le problème ?
    (dans l'immédiat je remets les choses de façon à voir le contenu et ça donne ça : https://monsite.fr/article69/le-sens-dune-paix-commune)

  • Bonsoir,
    J'utilise une v5.8.7 avec le même plugin et cela fonctionne, même si au début puis au déménagement du site vers un autre hébergeur (même NDD) il faut batailler un peu et refaire la configuration en désactivant la réécriture d’URL native de PluXml et le plugin, puis recommencer :)

    cdt

    Remise en ligne et test de mon vieux site re7net.com . le design et moi on ne sait ... s'est jamais reconnu en fait! mais je fait des efforts.

  • webassowebasso Member

    Bonjour,
    Ben c'est ce que j'ai fait... et plusieurs fois en plus !
    mais pourquoi ça ne marche pas ?

  • Chez quel hébergeur es-tu ?
    Quel type de serveur (apache-nginx) ?
    Peux-tu nous recopier ton fichier htaccess ?

  • webassowebasso Member

    Hébergeur et type de serveur : ? technologie SSD NVMe / https://www.o2switch.fr/hebergement-illimite/#
    fichier htaccess :
    # BEGIN -- Pluxml
    Options -Multiviews

    RewriteEngine on
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
    # Réécriture des urls
    RewriteRule ^(article\d|categorie\d|tag|archives|static\d|blog|page\d|telechargement|download)\b(.)$ index.php?$1$2 [L]
    RewriteRule ^feed\/(.
    )$ feed.php?$1 [L]
    # Plugins "officiels" plxMySearch, plxMyContact
    RewriteRule ^(search|contact)\b(.)$ index.php?$1$2 [L]
    # règle plus laxiste à décommenter si besoin. Ecrase les règles précédentes
    # RewriteRule ^([a-z][\w-]
    )\b(.)$ index.php?$1$2 [L]RewriteRule ^feed\/(.)$ feed.php?$1 [L]

    # END -- Pluxml

  • Je n'ai pas la même version de PluXml que toi (plus ancienne) mais on a le même hébergeur. Voici ce que j'ai actuellement si tu veux essayer et voir ce que cela donne.

    # BEGIN -- Pluxml
    Options -Multiviews
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
    
    # Réécriture des urls
    RewriteRule ^(?!feed)(.*)$ index.php?$1 [QSA,L]
    RewriteRule ^feed\/(.*)$ feed.php?$1 [QSA,L]
    </IfModule>
    # END -- Pluxml
    
  • webassowebasso Member

    ... ben non désolé ça ne marche pas, j'ai toujours la même erreur 404 avec le pluging activé et les url sur "oui"

Connectez-vous ou Inscrivez-vous pour répondre.