Redirections HTTP > HTTPS

perolivperoliv Member

Bonjour à tous,

Je cherche à paramétrer des redirections 301 entre les versions HTTP et HTTPS de mes URLs.
J'ai passé pas mal de temps à faire des tests sur le .htaccess, avec des résultats variables, mais en gros j'ai soit :

  • une redirection qui fonctionne mais qui désactive la réécriture d'URLs
  • un plantage complet du site (HTTP 500)
  • une cohabitation entre HTTP et HTTPS (situation actuelle)

Je suis sur la version 5.6 de PluXml et sans plugin tiers.
J'ai pris le temps d'éplucher la doc et ce forum avant de venir demander ici, mais je sèche.
D'avance merci !

Réponses

  • 14 avril modifié

    Bonsoir, @peroliv

    voici ce que j'ai qui fonctionne avec la réecriture d'url activée:
    ou tonsite.com est a remplacer par ton ndd
    Les lignes avnat # BEGIN -- Pluxml, sont à ajoutées au fichier htaccess généré par PluXml lorsque tu actives la réécriture d'url , en gros , il faut rééditer à la main le fichier à chaque fois que tu bascules entre réécriture activée ou non dans l'admin en conservant les 3 premières lignes.

    RewriteEngine On
    RewriteCond %{HTTP_HOST} !^tonsite.com [NC]
    RewriteRule (.*) https://tonsite.com/$1 [QSA,R=301,L]
    
    # BEGIN -- Pluxml
    Options -Multiviews
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
    # Réécriture des urls
    RewriteRule ^(?!feed)(.*)$ index.php?$1 [L]
    RewriteRule ^feed\/(.*)$ feed.php?$1 [L]
    </IfModule>
    # END -- Pluxml
    

    Il me semble aussi avoir tenté de configuré mon hébergeur pour rediriger automatiquement les http vers https. Mais chaque hébergeur est de configuration différentes , alors je ne sais plus si j'ai du me résoudre à en passer le htaccess ou si j'ai fais ce choix délibérément, je suis passé d’hébergement en hébergement durant quelques mois, je ne suis pas assez familier de ce genre de chose pour les avoir complètement assimilées.

    ♣♣♣♣ <°(((((-{ ~ Mon site avec PluXml: https://re7net.com | Mes plugins : https://github.com/gcyrillus PluXml 5.8.7 sur free ? oui c'est possible : http://gcyrillus.free.fr/new }-))))°> ♣♣♣♣

  • Pierrot14Pierrot14 Member
    25 avril modifié

    Hello

    Perso j'utilise MyBetterUrls et j'avais le même soucis, réglé de cette façon :

    # BEGIN -- Pluxml
    Options -Multiviews
    <IfModule mod_rewrite.c>
    RewriteEngine on
    RewriteCond %{HTTPS} off [OR]
    RewriteCond %{HTTP_HOST} !^www\. [NC]
    RewriteCond %{HTTP_HOST} ^(?:www\.)?(.+)$ [NC]
    RewriteRule ^.*$ https://www.%1%{REQUEST_URI} [L,NE,R=301]
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
    # Réécriture des urls
    RewriteRule ^(?!feed)(.*)$ index.php?$1 [L]
    RewriteRule ^feed\/(.*)$ feed.php?$1 [L]
    </IfModule>
    <FilesMatch "\.(jpg|gif|png|css)$">
    Header set Cache-Control "max-age=600"
    </FilesMatch>
    # END -- Pluxml
    

    La partie ajoutée :

    RewriteCond %{HTTPS} off [OR]
    RewriteCond %{HTTP_HOST} !^www\. [NC]
    RewriteCond %{HTTP_HOST} ^(?:www\.)?(.+)$ [NC]
    RewriteRule ^.*$ https://www.%1%{REQUEST_URI} [L,NE,R=301]
    

    et cela fonctionne nickel, pour checker si tout est OK > https://seobility.net/en/redirectcheck/

  • perolivperoliv Member

    :o
    Merci beaucoup @Pierrot14 ! Ca a fonctionné en ajoutant ces 4 lignes juste après le RewriteEngine on
    Je me sers de cet outil pour être bien sûr que les bots des moteurs de recherche voient ce qu'il faut : https://technicalseo.com/tools/pre-rendering/

    Merci aussi @gcyrillus-nomade pour tes insights, ça m'a aidé à comprendre.

    Bon j'y touche plus et je retiens pour les futurs sites avec ce CMS !

Connectez-vous ou Inscrivez-vous pour répondre.