Banière non responsive

basylbasyl Member

Bonjour, la bannière de mon site n'est pas responsive avec le thème defaut.
Cela est-il normal. Le site : https://mushingspirit.fr/
Merci pour votre aide.

Réponses

  • bonjour,

    tu peut éventuellement lui donner une hauteur maximale relative à la largeur de la fenêtre:
    ex theme.css - ligne 61:

    .bg {
      background: url(../img/bg.jpg) no-repeat top left;
        background-size: auto;
      -webkit-background-size: cover;
      -moz-background-size: cover;
      -o-background-size: cover;
      background-size: cover;
      height: var(--bg-height);
      max-height: 25vw;
    }
    

    Cdt

    ♣♣♣♣ <°(((((-{ ~ Mon site avec PluXml: https://re7net.com | Mes plugins : https://github.com/gcyrillus PluXml 5.8.7 sur free ? oui c'est possible : http://gcyrillus.free.fr/new }-))))°> ♣♣♣♣

  • basylbasyl Member

    Bonjour et merci pour la réponse rapide. J'ai copié collé mais cela n'a rien changé...

  • kowalskykowalsky Member
    23 juin modifié

    Salut @basyl
    L'espace dévolu à la bannière est bien "responsive" mais il y a un petit souci de ratio dans l'affichage de l'image selon le media utilisé dès que l'on dépasse une résolution supérieure à 1280px de large. En dessous de 1280px l'image s'affiche intégralement, au dessus de 1280px c'est tronqué sur le bas.
    C'est un effectivement un "bug" de PluXml (lié à l'usage des "media queries", très certainement corrigeable mais en y passant un peu de temps)

  • basylbasyl Member

    Bonjour et merci pour l'information.

  • basylbasyl Member

    Bonjour depuis mes manipulations, sur PC le menu en haut à droite apparaît et fonctionne mais sur smartphone cela m'affiche le nombre2630 à la place du menu qui fini par s'afficher...Une idée ?

  • kowalskykowalsky Member

    Salut @basyl,

    Vérifie la ligne 604 de ton fichier theme.css, le bon code est le suivant :

        .responsive-menu label:after {
            content: '\2630';
        }
    

    Est-ce que le caractère " \ " (barre oblique inverse) est toujours présent avant le 2 ?

    Si oui, vérifie que le dossier "fonts" soit présent dans ton thème et contienne les polices référencés en ligne 15 du fichier theme.css

  • 23 juin modifié

    Bonjour depuis mes manipulations, sur PC le menu en haut à droite apparaît et fonctionne mais sur smartphone cela m'affiche le nombre2630 à la place du menu qui fini par s'afficher...Une idée ?

    Oui, si tu as edité ton théme depuis l'administration, PluXml enleve les\, il faut les echappées à chaque modif en les doublant .et récrire 2630 en \\2630 pour qu'il reste aprés l'enregistrement \2630 , l'unicode correspondant aux trois barres horizontal de ton burger menu.

    Si tu est amené à souvent éditer tes fichier dpuis l'administration de pluXml , tu peut te servir de ce plugin : https://github.com/gcyrillus/PLX-cssBackSlash Il doublera pour toi tous les \ qu'il trouvera . Il te restera cependant à penser à doubler tout ceux que tu ajouteras ( on en trouve dans les CSS, javascript, PhP , en gros un peu partout.

    Cdt

    Les \ perdus sont récurrent avec PluXml, dernier cas https://forum.pluxml.org/discussion/comment/62876/#Comment_62876 , tu n'as rien fait de mal :)

    ♣♣♣♣ <°(((((-{ ~ Mon site avec PluXml: https://re7net.com | Mes plugins : https://github.com/gcyrillus PluXml 5.8.7 sur free ? oui c'est possible : http://gcyrillus.free.fr/new }-))))°> ♣♣♣♣

  • basylbasyl Member

    Bonjour à tous les deux, quelle réactivité je vais modifier selon vos indications. Merci

Connectez-vous ou Inscrivez-vous pour répondre.