Auto-hébergement et changement de Freebox

zornzorn Member
27 juil. modifié dans Entraide

Bonjour,
J'auto-héberge depuis toujours mes sites web sous PluXML. Mais au fil des années et des "incidents", cela devient de plus en plus compliqué à faire tourner...
Le dernier épisode en date est le suivant : j'ai changé physiquement de Freebox. Et du coup, mes sites se retrouvent inaccessibles (tant via internet qu'en local). Je fais ici un court RETEX et suis preneur de vos commentaires et conseils
Les éléments du diagnostic sont les suivants :

  • je "vois" toujours mes NAS sur le réseau (au travers de l'explorateur Windfows) et donc le LAN fonctionne
  • je peux toujours appeler l'interface de gestion de mes NAS Synology avec l'adresse IP suivie de ":5000" mais "localhost" n'est plus reconnu
  • je tourne sous une version DSM Synology 6.2 donc l'utilitaire que j'utilise (où sont paramétrés mes VHOST) est Web Station et les paramètres de redirection sont toujours bien là

A priori, j'ai besoin de (re)mettre en place des redirections de port.
Selon moi, ça se passe sur http://mafreebox.freebox.fr dans le menu "paramètres de la Freebox", mode avancé, dans "gestion des ports", où j'ai commencé par saisir un redirection pour le port 80 (là, j'ai essayé de vous joindre une copie d'écran mais ça ne marche pas...)
Du coup, c'est mieux pour voir mes sites =)
Merci d'avance

Réponses

  • Salut @zorn,

    tu devrais plutôt demander de l'aide sur les forums de Free, car si j'ai bien compris ton explication, le seul élément que tu as modifié dans ta config est ta box.

    Quelques pistes supplémentaires :

    • aurais-tu modifié précédemment ton fichier "hosts" sur ton PC pour renvoyer "localhost" vers ton NAS ? Normalement si tu tapes "localhost" dans ton navigateur ça renvoi vers ton PC en 127.0.0.1
    • regarde aussi le paramétrage de ton serveur DHCP sur ta nouvelle box, y as-tu reconstruit ton ancien réseau ?
  • 29 juil. modifié

    Bonsoir,

    je viens de faire l'expérience avec Pluxml sur un synology et webstation avec une mini 4k , (ne pas oublier de lancer apache!) Cela fonctionne en local via (pc ou smartphone connecter sur la boxe) , mais pas depuis l'extérieur.

    • 192.168.x.xxx
    • mon IP
    • ou en utilisant mon compte xxx.synology.me

    Pour accéder aussi au serveur sur mon NAS depuis l'extérieur , il faudrait que je fasse une demande d'IP Full Stack à partir de mon espace abonné Free sur le compte principal/ de la box. Je ne souhaite pas aller jusque là.

    @zorn
    Voir ce post https://www.forum-nas.fr/threads/résolu-ds220-accéder-à-mon-nas-de-lextérieur-freebox-pop.18075/ Il semble assez récent pour ne pas être obsolète ;)

    Si ton changement de boxe est consécutif à un passage à la fibre : voir aussi cet article : https://www.magentix.fr/blog/un-serveur-web-a-la-maison.html#p3

    Cdt

    ♣♣♣♣ <°(((((-{ ~ Mon site avec PluXml: https://re7net.com | Mes plugins : https://github.com/gcyrillus PluXml 5.8.7 sur free ? oui c'est possible : http://gcyrillus.free.fr/new }-))))°> ♣♣♣♣

  • zornzorn Member

    Bonjour,

    Merci kowalsky et gcyrillus-nomade - et oui, tu as raison, "Cela fonctionne en local via (pc ou smartphone connecter sur la boxe) , mais pas depuis l'extérieur.". Sauf que j'ai déjà une adresse IP fixe V4 full-stack. Et non, je n'ai pas reconstruit mon ancien réseeau - car comme je n'avais pas compris que j'aurai ça à faire, je n'ai pas une copie des paramètres :(
    Je continue à chercher

  • kowalskykowalsky Member
    7 août modifié

    salut @zorn
    dans ton message initial, tu indiques que tes sites étaient inaccessibles aussi bien en local que depuis internet mais dans ton dernier messages tu indiques uniquement depuis l'internet. Ce qui est très différent.

    Par "reconstruire ton réseau", il faut comprendre en très gros réassigner les mêmes adresses ip fixes pour les différentes adresses MAC de tes équipements. :)

    Quelques autres pistes :
    Comment accèdes-tu à ton serveur depuis l'internet ? via un @ip fixe ou un nom de domaine ?
    Si @ip fixe, est-ce que tu peux la pinguer depuis l'internet ? Est-ce que tu vois dans les logs de ta box un tentative de connexion à cette adresse ?
    Si par nom de domaine, est-ce que ton enregistrement DNS est à jour chez ton registrar ? Renvoie-t-il bien vers l'adresse publique de ta box ?
    Au niveau de ton NAS, est-ce que l'adresse gateway de ta box est la même que précédemment ?

    Dans le premier lien de @gcyrillus-nomade il y a un lien vers un tuto Accéder à son NAS depuis l'extérieur qui date de 2019 mais semble complet. L'as-tu consulté ?

Connectez-vous ou Inscrivez-vous pour répondre.