PHP 5.6

jane76jane76 Member
28 juil. modifié dans Entraide

Bonjour,
mon site est hébergé chez ovh et apparemment certaines personnes ne peuvent plus y accéder pb parse php pouvez vous m'aider sur ce sujet me suffit il de passer chez ovh en version 7 de php sinon que dois je modifier

Réponses

  • Bonjour,

    Peut tu préciser la version de PluXml que tu utilises ainsi que la version php de ton hébergement.

    ... apparemment certaines personnes ne peuvent plus y accéder

    Okay, donc cela fonctionnait avant, mais avant quoi? :

    • as tu modifier quelque chose sur les options de configuration de ton hébergement
    • ou fait , par exemple, une mise à jour de PluXml , si oui de quelle version vers quelle version ?
    • ou installer un nouveau plugin?
    • autre?

    Cdt

    ♣♣♣♣ <°(((((-{ ~ Mon site avec PluXml: https://re7net.com | Mes plugins : https://github.com/gcyrillus PluXml 5.8.7 sur free ? oui c'est possible : http://gcyrillus.free.fr/new }-))))°> ♣♣♣♣

  • jane76jane76 Member

    Merci de ce retour,
    Je suis hébergé chez ovh et la version php 5.4 ne semble plus maintenue.
    Depuis certaines personnes accède a mon site et d'autres pas alors que je n'ai opéré aucune modification. Sur le site ovh je peux demandé jusqu'à la version 7 de php mais je ne sais pas si cela aura des conséquences sur mon site. Je n'ai opéré aucune modification depuis très longtemps
    "
    Ces informations vous renseignent sur le fonctionnement de votre PluXml et peuvent s'avérer utiles pour son dépannage.

    PluXml version 5.6 (encodage UTF-8)

    Version de PHP : 5.3.29 "

    je viens de télécharger la dernière version de pluxml pour faire une migration mais j'espère que cela est encore possible. Par contre je galère car je ne sais pas exécuter la nouvelle version en local devserver 17 ne fonctionne pas sur mon pc (proxy ou autre que faire?)

  • 28 juil. modifié

    Si ton serveur est en php 5.3.6, ne fait surtout pas de mise à jour de PluXml, les dernières versions demandent php 7 , cela ne fonctionnera pas. éventuellement, si tu as une version php 5.4.x en option , essai voir si cela arrange un peu les choses.

    En local, je ne sais pas à quoi tu fais référence en parlant de "devserver 17" ah okay, c'est easyphp, il faut , quelque soit le serveur que tu utilises, lancer l'application/le serveur. ensuite en tapant localhost ou http://127.0.0.1/ dans ta barre d'adresse tu arrives sur la racine de ton serveur, perso , sous windows, j'utilise maintenant laragon comme serveur .
    Il y a des versions portable (que tu peut mettre sur une clé USB ) ex: 38MO et qui embarque php 5.4 , utilisable pour faire tourner en local une copie de ton PluXml actuel et y dénicher d’éventuelles erreurs -> https://github.com/leokhoa/laragon/releases/download/5.0.0/laragon-portable.zip

    Pour faire tourner php7-8 , il te faudra prendre une version plus récente de laragon

    version 32bits https://laragon.org/download.html ou 64bits https://laragon.org/download/index.html

    Cdt

    ♣♣♣♣ <°(((((-{ ~ Mon site avec PluXml: https://re7net.com | Mes plugins : https://github.com/gcyrillus PluXml 5.8.7 sur free ? oui c'est possible : http://gcyrillus.free.fr/new }-))))°> ♣♣♣♣

  • 28 juil. modifié

    Pour revenir à ton probléme actuel, quel est ce message d'erreur et à t'il lieu de façon aléatoire ou sur une page, une catégorie, un article précis ?

    Cdt

    ♣♣♣♣ <°(((((-{ ~ Mon site avec PluXml: https://re7net.com | Mes plugins : https://github.com/gcyrillus PluXml 5.8.7 sur free ? oui c'est possible : http://gcyrillus.free.fr/new }-))))°> ♣♣♣♣

  • jane76jane76 Member

    le message d'erreur est le suivant
    parse error: syntax error, unexpected T_STRING, expected T_Old_Function or t8function or t_var or } in
    home/elisabetz/ww/core/lib/class.plx.date.php on line 21

    lorsque tu parles de mon serveur parles tu du serveur ovh? car en local je n'arrive à rien c'est desespérant

  • re, bonsoir,

    je parle de ton serveur en local , apparemment tu utilises easyphp si j'ai bien compris.

    Ton message est surprenant. Est ce que tous tes articles ont bien les champs date remplis ?
    est ce sur quelques pages ou toutes les pages que tu as ce message d'erreur ?

    Cdt

    ♣♣♣♣ <°(((((-{ ~ Mon site avec PluXml: https://re7net.com | Mes plugins : https://github.com/gcyrillus PluXml 5.8.7 sur free ? oui c'est possible : http://gcyrillus.free.fr/new }-))))°> ♣♣♣♣

  • jane76jane76 Member

    re bonsoir,
    je tente d'utiliser en local mais ne parviens pas a le faire certaines personnes ont le message en activant le lien sur internet mais moi par exemple sur pc ou tablette je ne l'ai pas
    Après je suis un peu perdue avec tes messages précédents j ai téléchargé laragon et je rencontre le meme probleme il ne se passe rien.

    http://www.elisabeth-magnetiseur.com/

  • Salut @jane76 ,

    Cela ne va pas faire avancer le problème mais ton site est pleinement fonctionnel depuis chez moi. J'ai testé plusieurs pages au hasard et tout s'affiche.
    Il faudra que tu demandes aux personnes rencontrant le problème de t'indiquer la page consultée, pour voir si c'est global ou lié à certaines pages.

    D'un autre coté puisque ton site tourne sur un PluXml en version 5.6, tu devrais pouvoir basculer ton hébergement OVH en version PHP 7 sans rencontrer de problème derrière. Les pré-requis pour une installation (récente) de PluXml étant : PHP 5.6 ou supérieur (7.4 recommandé)

    Pour info j'ai un ami dont le site tourne sur PluXml en version 5.4 chez OVH avec PHP en version 5.6.40. Et comme ça marche bien il a décidé de ne rien changer pour le moment :) Si le saut en PHP 7 t’inquiète, tu peux déjà essayer de passer en 5.6.40 si tu en as la possibilité et voir si cela résout ton problème.

  • 28 juil. modifié

    Je n'ai pas de message d'erreur non plus en parcourant le site, étrange.

    Pour les messages précédents:
    Les articles semblent être correctement enregistrés (dates ...) .

    Pour utiliser un serveur en local, il faut le démarrer ainsi que les services (pour pluxml, pas besoin de lancer les bases de données).
    Pour laragon, c'est le bouton en bas à gauche qui ou il est écrit démarrer ou stop (si demarrer) Easyphp DevServer a aussi une interface ou il faut démarrer les services (ex: apache)

    Il ne faut pas non plus tenter de démarrer deux serveurs en même temps.

    Généralement, les fichiers sont à déposer dans le répertoire www ( selon les serveurs/applications , ce dossier peut avoir un nom différent, voir les fichiers d'aide ou tutoriels) Pour Laragon le repertoire www se trouve dans le dossier programFile/laragon/www

    ..certaines personnes ont le message en activant le lien sur internet ..

    De quel lien s'agit-il ? est ce le même que tu viens de donner ?

    cdt

    ♣♣♣♣ <°(((((-{ ~ Mon site avec PluXml: https://re7net.com | Mes plugins : https://github.com/gcyrillus PluXml 5.8.7 sur free ? oui c'est possible : http://gcyrillus.free.fr/new }-))))°> ♣♣♣♣

  • jane76jane76 Member

    merci beaucoup pour ces retours très précis.après enquete les personnes qui rencontraient ce probleme avaient un pb de cache sur google donc pb semble résolu . Si je peux passer sous php 7 sans pb sur OVH je vais le faire. merci encore pour ton aide et tes éclairages.

Connectez-vous ou Inscrivez-vous pour répondre.